autodiscover for exchange

I want to use a single host name in certificate for my webmail and autodiscover, how to make it?

tks
AXISHKAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Muhammad MullaSystems AdministratorCommented:
Are you asking about getting a non SAN certificate for Exchange?

I don't believe it would be supported, if it were possible.
AXISHKAuthor Commented:
do u mean the certificate should include 2 names
mail.abc.com and autodiscover.abc.com

I see a client that include a single name in the host, how to make it ?
Muhammad MullaSystems AdministratorCommented:
You need to start by creating a certificate request.

This guide should help:

http://exchangeserverpro.com/configure-an-ssl-certificate-for-exchange-server-2010/
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

David SankovskySenior SysAdminCommented:
You need to get a wildcard certificate, they are more expensive but they cover everything under your domain (including the domain itself) so if your domain is contoso.com , a wildcard certificate will cover contoso.com , webmail.contoso.com , autodiscover.contoso.com and eny other subdomain you can think of (unlimited number)
Muhammad MullaSystems AdministratorCommented:
A wildcard certificate, as suggested by David is an easy option. However, you need to be aware of the security implications. It's also worth bearing in mind that wildcard certs weren't supported before Exchange 2010.
AXISHKAuthor Commented:
the client works well for some times but some clients pop out the warning

it seems that there is some trick to use single certificate name for mail and autodiscover

tks
Eprs_AdminSystem ArchitectCommented:
Have you also created a new zone in DNS ?
AXISHKAuthor Commented:
where can I set it
Eprs_AdminSystem ArchitectCommented:
Please check your DNS, normally you have 2 zones,

1. with mydomain.local
2. with mydomain.com, here you need your autodiscover settings.
AXISHKAuthor Commented:
Do you mean I need to create a host record under my DNS mydomain.com ?  

Same domain name (mydomain.com) is used in internal and public. The AD DNS is only resolved locally
Muhammad MullaSystems AdministratorCommented:
External autodiscover URL needs to be set.

Use the Microsoft tester:

https://testconnectivity.microsoft.com/
AXISHKAuthor Commented:
the service is unavailable...
AXISHKAuthor Commented:
Anything may be missing or need to check ??

Get-clientAccessServer | fl Name,AutoDiscoverServiceInternalUri

Name                           : ABCDC01
AutoDiscoverServiceInternalUri : https://office.abc.com.hk/Autodiscover/Autodiscover.xml
------
Get-OabVirtualDirectory |  fl Server,Name,internalurl,externalurl

Server      : PCLDC01
Name        : OAB (Default Web Site)
InternalUrl : http://office.abc.com.hk/OAB
ExternalUrl : https://office.abc.com.hk/OAB
----
Get-WebServicesVirtualDirectory | fl name,internalurl,externalurl

Name        : EWS (Default Web Site)
InternalUrl : https://office.abc.com.hk/EWS/Exchange.asmx
ExternalUrl : https://office.abc.com.hk/ews/exchange.asmx
Eprs_AdminSystem ArchitectCommented:
you need a mx record in your dns zone
AXISHKAuthor Commented:
MX record has been setup in my DNS zone.

Is it possible to disable Outlook / Exchange to use autodiscover host name for resolution ?

Using the link below but it doesn't work.

https://support.microsoft.com/en-us/kb/2783881
Will SzymkowskiSenior Solution ArchitectCommented:
The reason why you are getting popups after configuring this you need to also update your virtual directories as well using the FQDN for mail.domain.com. Once you have done this you will no longer see the popups.

Take a look at the HowTo i have created which should help guide you through these setps.

http://www.wsit.ca/how-tos/exchange-server-2/configure-split-dns-and-exchange-2013-virtual-directories/

Will.
AXISHKAuthor Commented:
I have checked this before but it doesn't work for me.

My client's local and public domain using the same name "mydomain.com". For the current certificate loaded in Exchange, it doesn't include a autodiscover.mydomain.com.
The public DNS record has setup autodiscover while the internal DNS doesn't work.

Below is a nslookup on our internal network where autodiscover doesn't setup but finally it return with public IP (guessing internal DNS forward to external DNS for resolution). If I remove the autodiscover name in the public DNS, will it work ?  ... but I afraid it may affect other user as well.

nslookup -q=a autodiscover.abc.com.hk
Server:  abcdc01.abc.com
Address:  192.168.16.20

Non-authoritative answer:
Name:    office.abc.com.hk
Address:  220.241.136.50
Aliases:  autodiscover.abc.com.hk


Just want to look for a way to disable the autodiscover warning as only one workstation has problem. (but I have no idea why others works well). Try to follow the link below but it doesn't work.

https://support.microsoft.com/en-us/kb/2783881
Jeff GloverSr. Systems AdministratorCommented:
To get Autodiscover to resolve correctly, you need split brain dns. which means, in your internal dns, you need to make a zone for abc.com.hk. In this zone, you need to have an Autodiscover record pointing to your Exchange servers internal address (or the VIP if you are using a load balancer). This will make internal users see Autodiscover internally. You also need to have Autodiscover.abc,com.hk. on the certificate. A UC certificate or SAN certificate is the way to go.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AXISHKAuthor Commented:
Tks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.