Hyper-V Generation 2 Virtual Machines

Hyper-V Generation 2 Virtual Machines

We have a Dell PE R530 Server on Server 2012 R2 Standard as a host server - Dell build of this host is absolutely fine.

When we try to add a VM server using generation 2 VM, we get an error message when attempting to boot from the .iso file.

Boot failed. EFI SCSI Device.    (see the attached).

We have been applying the scripts from John Howard (Senior Program Manager, Hyper-V team, Windows Core Operating System Division at Microsoft;

http://blogs.technet.com/b/jhoward/archive/2013/10/24/hyper-v-generation-2-virtual-machines-part-1.aspx 

We have applied the script specifically in PART 4  and in PART 9 of John Howards articles on this matter and all of these command line scripts to inject the "Windows6.2-HyperVIntegrationServices-x64.cab" file into the base Windows Server 2012 R2 Standard .iso file - these all reported as successfully completed.

We also carried out the rename of the cdboot.efi and efisys.bin files so that we get no prompt for a keyboard stroke when booting to the .iso file.

When we then recreate a patched .iso file for Windows Server 2012 R2 Standard using the oscdimg utility, we still get the failure to boot from the modified .iso in generation 2 vm.

We believe we have correctly carried out the instructions of Part 4 and Part 9 of John Howards article, but we still fail with the same error message attached when we start the VM.

Any assistance would be much appreciated.

Regards,

Netopa
Hyper-V-Boot-Error.JPG
Assist-NetopaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
Yeah, don't do part 4 or part 9.

Regarding part 4, 2012 R2 has the necessary drivers. Injection is only necessary for older OSes. Use the native ISO.

Regarding part 9, things don't work as you'd expect.  Instead, go into the VM and ensure the virtual CD is first in boot order (it often isn't.) Then connect to the VM, then boot. Make sure you press a key when prompted quickly. The message will NOT go away, so it is simply a matter of timing. If you miss it, simply hit the reset button to reboot the VM and try again.

In short, if you are messing with the ISO via injection or renaming files, you may be breaking more than you are fixing.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rindiCommented:
Does the server itself have an UEFI BIOS? If so is it set to UEFI mode, and did you install the host OS in UEFI mode to a GPT Disk Volume?

Gen 2 VM's are only supported if the host is setup in UEFI mode onto a GPT disk.

The only reason for Gen 2 VM's in my point of view is that you can use virtual disks larger than 2TB for the boot disk, and no one would ever use  such a large disk just for the OS. You'd ratheruse as small a disk as possible for the OS, and use large disks for the data and programs. So there is really no good reason for using Gen 2 VM's...
Assist-NetopaAuthor Commented:
Reset with a fresh iso file & rebooted O.K.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hyper-V

From novice to tech pro — start learning today.