Shared drive issue: “The action can’t be completed because the folder or a file in it is open in another program”

We had a windows 2008 R2 file server that was used to hold documents for our web servers.  We began to experience an issue when creating new folders named anything but the default "New Folder" as well as renaming new folders.  The error was “The action can’t be completed because the folder or a file in it is open in another program” - we couldn't figure it out, and the server was old and running out of space anyway, so we bought a new 2012 server and moved all the files to it, and named it the same as the old server.  A few days later, the same error began to happen intermittently.  There's nothing on the server other then AVG Corporate, which we disabled while it was occurring, which didn't help.  There was an article describing an issue with the thumbsdb caching causing locks, so I disabled it in gpedit.  That fixed it for a few hours, but it began happening again.  It only happens when we try to create new folders.  Copying existing folders to the drive works fine.

As I said, its a simple, domain joined Windows 2012 server with no IIS, no other roles other then file services - its a RAID 1 drive with two partitions - the OS and the drive for the share.  The drive is shared to everyone - full control and the folders are all in the root of the drive.

Any ideas/suggestions?  Thanks.
mchad65Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lionel MMSmall Business IT ConsultantCommented:
is the error the same on the new server, namely “The action can’t be completed because the folder or a file in it is open in another program” ? This says some program or some service has it in use--which for a newly created folder is very strange indeed. Do you have any other security software on the server, malwarebytes, anything?
mchad65Author Commented:
I'm glad someone finally responded.  I guess its a good mystery!

The only third party software on the server is AVG Corporate - which I have disabled while it happened and that doesn't resolve it.  It is a brand new box, so nothing has been installed.  My next step will be installing process explorer and seeing if I can catch the offender in the act.
Lionel MMSmall Business IT ConsultantCommented:
is it the same error message
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Lionel MMSmall Business IT ConsultantCommented:
What about using task manager, processes from all users and see what "un-usual" is running. Can you check schedules tasks see if anything is there?
Lionel MMSmall Business IT ConsultantCommented:
mchad65Author Commented:
I already saw that site, and tried it.  No joy.  Regarding your question "is it the same error message" - I don't understand.  If you mean is it the same error all the time, yes.  

And yes, I already checked task manager - nothing obvious, and there are no scheduled tasks.
Lionel MMSmall Business IT ConsultantCommented:
I re-read (quickly) what you already said, but have you tried this with different users and all users have the same result? As far as the error message question goes, I was asking if it was the same error on both servers, which now I know it is.
mchad65Author Commented:
Well, we use a single domain account which is local admin on the server when RDP'd to the server.  However it also occurs when using the share on a users local pc, so yes, it happens to all users - and its been intermittent (which points to something locking the drive) but damned if I can find anything...
Lionel MMSmall Business IT ConsultantCommented:
I suggest you start "resource monitor" and look at the disk section and see if that file/folder is in use and by what

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mchad65Author Commented:
Its happening right now.  Process explorer has nothing obvious and resource monitor doesn't even show the new folder being created.  Heres another oddity.  The share is on the root of the drive (the drive itself is shared with full control to everyone) and while I can create a new folder using the default "New Folder" name - if I try and change the name during the creation - it gives the deny message.  Same message if I try and rename the new folder.  HOWEVER, I just discovered that this only occurs on folders created on the root of the drive - if I create a folder within a folder on the root - it behaves as normal.  Is there something I'm missing about sharing the root of a drive?
Lionel MMSmall Business IT ConsultantCommented:
resource monitor doesn't even show the new folder being created
you should see in disk activity what is open/using "the root" of the folder you are trying to create
mchad65Author Commented:
Ok well, I appreciate all the suggestions, but I believe I discovered the issue. I noticed it had been happening at certain times, usually in the mornings.  One morning I opened file share management in computer manager and began dropping connections of users connected to the share, trying it to see if that resolved it.  Once I dropped a particular user, the problem stopped.  So I took a stroll over to that user and had a look at his laptop, and I found he had folder synchronization enabled on one of the folders off the root of the share.  He didn't even know it was set.  So I disabled it and it hasn't happened since.  

The odd thing is that it was a specific folder, not the entire share, but as it's stopped, it must have been that...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.