Reinstall Office 2000 to TS 2003 VBE / DLL errors

Hello!
 Had a working 2003 TS with MSO 2000,  Office / Outlook was changed somehow (or updated) and refused to work.  Research showed it needed to be reinstalled.  I tried it and the install keeps failing at VB6EXT.OLB.  I cant manually register it as it isn't a DLL file and gives some error.  If I ignore, there are more DLLs that cant be registered and ultimately the install fails completely.   Client really need office installed.  
 I tried installing MSO 2003 and the install almost gets through to the end and then reverses and fails.  I am thinking some type of update somewhere is preventing this all from happening..
 Anyone have an ideas how I can get this back installed?  2003 or 2000 is AOK, just as long as its there.
 HEEEEELLLLLLLPPPPPPPPPPP!!!!

 TIA.
LVL 1
Lorenzo CricchioPresidentAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pjamCommented:
What version of office.  I vaguely remember that Enterprise version was needed for TS but not sure it went that far back.
0
Lorenzo CricchioPresidentAuthor Commented:
Office 2000 SBE.  Its been working for a number of years.  But someone changed something.  It did work without issue.  I just need to reinstall it.  Ive added some registry entries to allow the OLB file to get registered, to no avail.   Still failing on a number of levels.  MSO 2003 SBE also failing.  
 After an uninstall, didn't seem like the files actually did uninstall. I renamed some of the files referenced in the error to .old, also with same result.
0
pjamCommented:
I did a search on VB6EXT.OLB, apparently a bad actor. Seems to be part of visual Basic 6.
Please look at this post:
https://social.technet.microsoft.com/Forums/office/en-US/1d3e9aa0-2069-4f7b-b6cf-c47e00d637f5/vbe6extolb-could-not-be-loaded?forum=officeitproprevious

Here is another possible answer:
http://stackoverflow.com/questions/3129879/could-not-start-visual-basic
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Lorenzo CricchioPresidentAuthor Commented:
Saw both of these posts.  If you drill down and read the first one say to ultimately run repair on excel, but I cant because it isn't installed.

 The other link you provided has contains an additional link that says I have to perform a bind with VBA (??)  Unsure what that means, however, is there a straight forward VBA install I can do on the server so that whatever versions its trying to register match?  Or remove an older one?  Is it possible there are more than one version of the files and that's causing the issue?  Seriously need some assistance.
 Thanks.
0
pjamCommented:
Did you do a search after allowing hidden files to be viewed to see if there is more than one?
I would download Microsofts VB6 Runtime files are messed up at:
https://support.microsoft.com/en-us/kb/192461
 in case your You could also try ccleaner from piriform to cleanup unused stuff and the registry.  It is very safe.
0
Lorenzo CricchioPresidentAuthor Commented:
Yes, I did search for more than one.. I think downloading and installing VB6 (provided its the version MSO 2000 will look for) will do the trick.

I am familiar and use CCleaner often, however, don't know if there is anything *wrong* with the registry, just that it didn't contain certain entries.  Will give the VB install a go.  Thanks.
0
Lorenzo CricchioPresidentAuthor Commented:
Ugh.  No dice.  Says "could not register type library for file <path>VBE6EXT.OLB.. yada yada yada..
 Any other ideas?
0
pjamCommented:
If ccleaner did not find a broken link and fix things, then I guess you better ask for more help through EE.
Sorry out of ideas
0
Lorenzo CricchioPresidentAuthor Commented:
Where / what area would you suggest I look or post?
  It has something to do with the VBE files being able to register themselves which are failing.  Installing to Terminal Server is a unique install and cannot be bypassed or "worked around".
0
pjamCommented:
Sorry Lorenzo,
Somewhere on your post you can ask for elevated help.  I thought you knew that.
Possibly More Resources to the left, not sure I never had to do that.
0
Lorenzo CricchioPresidentAuthor Commented:
ultimately this was a permissions issue in the registry.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pjamCommented:
How did you figure that out, I have never encountered?
0
Lorenzo CricchioPresidentAuthor Commented:
A gent proficient in TS and office install caught the install after it installed but before it "deleted" itself from the profiles.  Once caught at the right time, it worked.  I don't think I would have been able to figure that out.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.