USB 3 Issue in Windows 10 upgrade ...

I upgraded my Windows 7 Dell desktop to Windows 10.  I have several external hard drives attached, and two of them are Seagate USB 3 drives.  Since the upgrade I've had problems with the drives dropping off.  Sometimes I have to reboot and sometimes I can just go into Device Manager and uninstall and scan to get them back.  Never had this problem with Windows 7, and no issue with the USB 2 drives attached.  All drivers are up to date, and I've uninstalled / scanned for new hardware everything under Universal Serial Bus Controllers in Device Manager.  Dell's tools as well as Seagate's tools claim my machine is up to date.  Once reconnected, the drives will be okay for anything from several minutes to a couple days before one or both drop off again.  Typical event log entry below.  Not sure how to proceed with this.  

 Log Name:      System
Source:        Microsoft-Windows-DriverFrameworks-UserMode
Date:          9/19/2015 12:55:10 PM
Event ID:      10110
Task Category: User-mode Driver problems.
Level:         Critical
Keywords:      
User:          SYSTEM
Computer:      Jacks-Dell
Description:
A problem has occurred with one or more user-mode drivers and the hosting process has been terminated.  This may temporarily interrupt your ability to access the devices.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-DriverFrameworks-UserMode" Guid="{2E35AAEB-857F-4BEB-A418-2E6C0E54D988}" />
    <EventID>10110</EventID>
    <Version>1</Version>
    <Level>1</Level>
    <Task>64</Task>
    <Opcode>0</Opcode>
    <Keywords>0x2000000000000000</Keywords>
    <TimeCreated SystemTime="2015-09-19T16:55:10.220337900Z" />
    <EventRecordID>13906</EventRecordID>
    <Correlation />
    <Execution ProcessID="572" ThreadID="1384" />
    <Channel>System</Channel>
    <Computer>Jacks-Dell</Computer>
    <Security UserID="S-1-5-18" />
  </System>
  <UserData>
    <UMDFHostProblem lifetime="{175C1A12-4DB0-48E6-98FD-EB644F12B150}" xmlns="http://www.microsoft.com/DriverFrameworks/UserMode/Event">
      <Problem code="3" detectedBy="2">
      </Problem>
      <ExitCode>3</ExitCode>
      <Operation code="259">
        <Message>72448</Message>
        <Status>4294967295</Status>
      </Operation>
    </UMDFHostProblem>
  </UserData>
</Event>
nssjmc01Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
This is seen with 8.1 also and Lenovo confirmed this problem to me on a t540p. Their "solution" so far is to use the original Intel driver, not the built in one of windows. Problem is: Though it worked stable, it only uses USB 2.0 speed.

I'd like to see that solved, myself.
0
Michael-BestCommented:
MS bugs take time to fix ... (wait)
0
nssjmc01Author Commented:
Is this a known Windows 8/10 bug?  If it truly is, why do I seem to be the only one complaining about it?  I keep checking for others that may have this problem, but I always seem to come up blank.  And if it was a bug in Windows 8, why wasn't it fixed in Windows 8?   Is there a way of finding out known Windows 10 issues awaiting fixes?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

McKnifeCommented:
I have experienced exactly what you describe on win 8.1 and 10 with four different devices, three were Intel usb3 controllers on Lenovo laptops, the fourth was on an Asus main board based desktop.
The problem is there on a clean installation. If I choose to install win7 there, it works fast and stable. That driver is installable on 8.1 or ten, too, is stable, but only slow usb2 speed for whatever reason. I have seen others report the same.

Ask Lenovo, they will be the right ones to tell Microsoft.

No, there's no such list.
0
nssjmc01Author Commented:
I've done more research and my problem has changed as of now.  I have 4 external usb drives: 2 usb2 and 2 usb3.  The usb 2 drives have no issues.  The usb 3 drives are both Seagate; a 3TB and a 5TB.  The 3TB is usually okay, but almost everytime the computer wakes up from sleep, the 5TB drive can't be accessed.  I/O error.  Sometimes the error occurs even when the computer hasn't gone to sleep.  Running chkdsk on the 3TB drive shows a file system of "RAW".  A reboot or a reconnect of the drive fixes it.  I suspected a bad drive, but replacing it with another new one exhibits the same problem.  Seagate offered me a replacement, but I don't think there's anything wrong with the drive.  I really don't want to do a clean install of Windows 10, but that looks like my only option now if nobody has any new ideas.  Thanks.
0
McKnifeCommented:
I told you that the problem is acknowledged by Lenovo and it would be microsoft's duty to change their USB3 xhci driver. As long as that has not been done, there won't be a solution.
That different end devices might behave differently - sure. But the problem is there with USB 3 xhci. And that's nothing expert advice may change.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.