Make Windows 10 ethernet network private

Hello. I've two computers Lenovo Y510p (Windows 10 Home) and G50-80 Touch (Windows 8.1). Both are x64. I want to connect them through ethernet. I can't find the way to define the ethernet connection like private. First I want to fix the problem on my W10 computer. I've logged in as administrator and I've opened Setting > Network > Ethernet and then I clicked on my ethernet network name but I can't see the switch to "Find devices and content" as I've read on some postings about this subject. Both computers are connected with a switch TrendNet TE100-S5.
Thanks
ConsJMEAAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Delete the wired profile (forget it) and then restart the computer. It will make a new wired profile. When it asks if you wish to be discoverable and devices to be discoverable answer yes. That should make the connection Private.

Actually on a home network, public and private work about the same way. In a café or like surrounding, public (wireless) prevents unwanted access.
Larry Struckmeyer MVPCommented:
Hi:

From either system can you connect to the internet?  From both systems open a "dos" or cmd prompt and type ipconfig /all and let us know the ip address and subnet mask.  Then open "this pc" and then "network" and see if the other system is shown.

Please let us know the result.

In Control Panel  - Network and Sharing Center click Advanced Sharing Settings and be sure network discovery is enabled on work or private networks.  If not available, click View Active Networks - type - and change from public - if that is the current type.
ConsJMEAAuthor Commented:
Thanks to John Hurst and Larry Struckmeyer MVP. I've seen the option to forget in the menu for Wifi but not in the ethernet menu. I've opened Network on Windows Explorer and I've received a message about turning on Network Discovery and I've selected "make my network private". The problem is that both networks (wifi and ethernet) are now Private. But I want only the wired network to be private. The wifi network must be public. Temporarily I've changed off File sharing on Private profile.

The output of ipconfig/all is:

ipconfig/all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Qhari05
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Local Area Connection* 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
   Physical Address. . . . . . . . . : FC-F8-AE-CC-99-A9
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Wireless-N 7260
   Physical Address. . . . . . . . . : FC-F8-AE-CC-99-A8
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2604:2000:6179:c500:8d1c:851f:1762:68e6(Preferred)
   Temporary IPv6 Address. . . . . . : 2604:2000:6179:c500:7120:69f8:39e6:d042(Preferred)
   Link-local IPv6 Address . . . . . : fe80::8d1c:851f:1762:68e6%7(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.5(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : sábado, 19 de septiembre de 2015 22:46:30
   Lease Expires . . . . . . . . . . : domingo, 20 de septiembre de 2015 00:16:30
   Default Gateway . . . . . . . . . : fe80::4270:9ff:fe4d:9377%7
                                       192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 83687598
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-A0-CE-39-28-D2-44-5F-5B-47
   DNS Servers . . . . . . . . . . . : 209.18.47.61
                                       209.18.47.62
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Qualcomm Atheros AR8171/8175 PCI-E Gigabit Ethernet Controller (NDIS 6.30)
   Physical Address. . . . . . . . . : 28-D2-44-5F-5B-47
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::dd89:7fd:511b:fb42%9(Preferred)
   Autoconfiguration IPv4 Address. . : 169.254.251.66(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 53006916
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-A0-CE-39-28-D2-44-5F-5B-47
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Ethernet 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : TAP-Win32 Adapter V9
   Physical Address. . . . . . . . . : 00-FF-FE-CB-05-CC
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{92167379-54D2-4780-80DC-7B82F2D9D4DD}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{51E9A84F-15E9-46C0-9426-D6165AD02F8C}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Open in new window

Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

JustInCaseCommented:
You can acheive what you need through powershell

run powershell  with elevated privileges to identify network interface index that you want to change network type
> Get-NetConnectionProfile

Name             : Hm1  2
InterfaceAlias   : WiFi
InterfaceIndex   : 2

NetworkCategory  : Private
IPv4Connectivity : Internet
IPv6Connectivity : LocalNetwork


> Set-NetConnectionProfile  -InterfaceIndex 2 -NetworkCategory Public

Name             : Hm1  2
InterfaceAlias   : WiFi
InterfaceIndex   : 2
NetworkCategory  : Public
IPv4Connectivity : Internet
IPv6Connectivity : LocalNetwork
JohnBusiness Consultant (Owner)Commented:
You can also just forget the Wireless Profile, remake and say you do NOT want to be discovered or attach to other devices. I have found this over the years with Windows 8 and 10 to be the simplest and fastest way.
ConsJMEAAuthor Commented:
Thanks to Predrag Jovic. I've set WiFi-Public and Ethernet-Private with PowerShell:
Name             : TG1672G72
InterfaceAlias   : Wi-Fi
InterfaceIndex   : 7
NetworkCategory  : Public
IPv4Connectivity : Internet
IPv6Connectivity : Internet

Name             : Unidentified network
InterfaceAlias   : Ethernet
InterfaceIndex   : 9
NetworkCategory  : Private
IPv4Connectivity : NoTraffic
IPv6Connectivity : NoTraffic

Open in new window


but when I restart, Ethernet is back to public mode:
PS C:\WINDOWS\system32> Get-NetConnectionProfile


Name             : TG1672G72
InterfaceAlias   : Wi-Fi
InterfaceIndex   : 7
NetworkCategory  : Public
IPv4Connectivity : Internet
IPv6Connectivity : Internet

Name             : Unidentified network
InterfaceAlias   : Ethernet
InterfaceIndex   : 9
NetworkCategory  : Public
IPv4Connectivity : NoTraffic
IPv6Connectivity : NoTraffic

Open in new window


I had already tried the suggestion of John Hurst but I will try again in a more detailed way.

I'm doing all these tasks with an Administrator account.
ConsJMEAAuthor Commented:
When I try to connect to Network on File Explorer I select the option to make private the network to which I'm connected. But I'm connected to two networks (wifi and ethernet). Thus the steps that I've followed are:

* Open my Administrador account
* Disconnect wifi and ethernet
* Forget wifi
* Disable wifi and ethernet adapter
* Restart like administrator
* Verify that both adapters are disabled
* Enable only Ethernet
* On PowerShell:
PS C:\WINDOWS\system32> Get-NetConnectionProfile

Name             : Unidentified network
InterfaceAlias   : Ethernet
InterfaceIndex   : 9
NetworkCategory  : Public
IPv4Connectivity : NoTraffic
IPv6Connectivity : NoTraffic

Open in new window

* I exit from PowerShell
* Open File Explorer and click on Network
* I receive a message that Network Discovery is off and I click to change
* I select "No, make the network that I am connected to a private network"
* On File Explorer - Network I can see the name of my computer (the other computer is off)
* On Network and Sharing Center I can see only the ethernet network and is Private
* On PowerShell:
PS C:\WINDOWS\system32> Get-NetConnectionProfile

Name             : Unidentified network
InterfaceAlias   : Ethernet
InterfaceIndex   : 9
NetworkCategory  : Private
IPv4Connectivity : NoTraffic
IPv6Connectivity : NoTraffic

Open in new window

* Then I restart again like administrator
* Both in PowerShell and Network and Sharing Center the Ethernet network is back to Public (???)
* I've enabled WiFi to have Internet connection

As further explanation, I use Comodo TrustConnect when traveling to protect the use of public networks. This creates a third adapter Ethernet2. But all these tasks I have done with TrustConnect disabled in anticipation that interfere with the network configuration.
JohnBusiness Consultant (Owner)Commented:
I do not have all this difficulty and I proceed in a much simpler fashion and can make my internet connections public or private at will.

First, remove Comodo Trust Connect at least until problems are resolved (uninstall it).
Second, Windows will disconnect Wi-Fi when you connect Ethernet. Do not try to use both at once.
Third, remove ALL Wi-Fi profiles. I keep records of these. Open cmd.exe with Run as Administrator:

netsh wlan delete profile name="Profile Name"  for all profiles.

With cmd.exe still open run SFC /SCANNOW twice. close out, shut down and start up with the Ethernet only connected.

The Ethernet profile should now be Private. Is it Private?  Let's start here.

Now assuming so, disconnect Ethernet and make ONE Wi-Fi connection. If you are at home, make it Private by telling it you want to see and be seen. Does it come out Private?

Now when you go to a café you should be able to easily make a Public connection.

If ALL this works, then now consider reinstalling Trust Connect.
ConsJMEAAuthor Commented:
Now I'm travelling. In two days I'll try this solution.
Larry Struckmeyer MVPCommented:
From the posted ipconfig the Ethernet wired adapter is not receiving an IP address?  Is there a DHCP server for wired connections turned on anywhere in your network... usually the router/firewall?  If not and you want these two devices to "see" or communicate with each other you will have to give them both static IP addresses in the same subnet as the LAN side of your router, which probably is but may not be the same as the wireless, I. e. 192.168.0.x
ConsJMEAAuthor Commented:
John Hurst:
First, remove Comodo Trust Connect at least until problems are resolved (uninstall it).
I've uninstalled it
Second, Windows will disconnect Wi-Fi when you connect Ethernet. Do not try to use both at once.
For testing this issue I'll disable WiFi but for my work I need both Ethernet connected (for sharing data with another computer) and WiFi too (for Internet access). Usually I configure a metric 10 for WiFi and 20 for Ethernet in order to connect OK with Internet without problems.
Third, remove ALL Wi-Fi profiles. I keep records of these. Open cmd.exe with Run as Administrator:

netsh wlan delete profile name="Profile Name"  for all profiles.
I've done it

With cmd.exe still open run SFC /SCANNOW twice.
I've done it:
C:\WINDOWS\system32>sfc /scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.

Open in new window


close out, shut down and start up with the Ethernet only connected.
I've done it. I've disabled WiFi > shut down and start up with the Ethernet only connected

The Ethernet profile should now be Private. Is it Private?  Let's start here.
The Ethernet profile is Public. I can make it Private but after restarting is Public again.
JohnBusiness Consultant (Owner)Commented:
If you keep Wi-Fi disabled (not connected) for testing and then if you make Ethernet Private and it becomes Public on restart, then there is something wrong with your Windows 10.  You tried SFC, so now try DISM.

Open cmd.exe with Run as Administrator.
DISM.exe /Online /Cleanup-Image /Scanhealth (takes 15 - 20 minutes).
DISM.exe /Online /Cleanup-Image /Restorehealth (takes 15 - 20 minutes).
Restart the computer and test.

If that does not work, then consider ignoring Public / Private until such time as you have a reason to reinstall Windows 10.
ConsJMEAAuthor Commented:
Larry Struckmeyer MVP:
From the posted ipconfig the Ethernet wired adapter is not receiving an IP address?  Is there a DHCP server for wired connections turned on anywhere in your network... usually the router/firewall?
The Ethernet adapter without IP is the one created by Comodo TrustConnect. Now I've uninstalled TrustConnect and the new IP configuration is:
ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Qhari05
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : cantv.net

Wireless LAN adapter Local Area Connection* 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
   Physical Address. . . . . . . . . : FC-F8-AE-CC-99-A9
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : cantv.net
   Description . . . . . . . . . . . : Intel(R) Wireless-N 7260
   Physical Address. . . . . . . . . : FC-F8-AE-CC-99-A8
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::8d1c:851f:1762:68e6%7(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.115(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : jueves, 24 de septiembre de 2015 18:04:58
   Lease Expires . . . . . . . . . . : viernes, 25 de septiembre de 2015 18:05:03
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 83687598
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-A0-CE-39-28-D2-44-5F-5B-47
   DNS Servers . . . . . . . . . . . : 200.44.32.12
                                       200.109.78.12
                                       192.168.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Qualcomm Atheros AR8171/8175 PCI-E Gigabit Ethernet Controller (NDIS 6.30)
   Physical Address. . . . . . . . . : 28-D2-44-5F-5B-47
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::dd89:7fd:511b:fb42%9(Preferred)
   Autoconfiguration IPv4 Address. . : 169.254.251.66(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 53006916
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-A0-CE-39-28-D2-44-5F-5B-47
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{92167379-54D2-4780-80DC-7B82F2D9D4DD}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.cantv.net:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : cantv.net
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Open in new window

ConsJMEAAuthor Commented:
I've changed the switch TrendNet TE100-S5 for another router/switch that I've and now all is OK. On start, Windows has configured the WiFi adapter as Public and the Ethernet adapter as Private.
Now I'll configure the Windows 8.1 computer and I'll post any problems.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Larry Struckmeyer MVPCommented:
Glad you found it, but the solution is not one that any of us (or most anyone) would have figured out... although someone may have offered it as a swag.  Switches do not usually disable communication between devices on the network and still allow communication between them and the  router/internet.  

The lesson here is one that most of us learned long ago.  What ever the common element, in this case the switch, first power cycle it, then in the case of a switch, try different ports and cables.  If it is a managed switch it may have different vlans assigned which could cause the symptoms you experienced, but a simple unmanaged switch would have to have massive internal failure to allow port 1 and 2 to see port 5 but not each other.
ConsJMEAAuthor Commented:
The solution was to change the swicht but I've learned useful tools for network management in some postings.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.