We help IT Professionals succeed at work.
Get Started

Unable to install Windows 7 Service Pack 1

Last Modified: 2015-09-21
I am unable to install Windows 7 Service Pack 1 on a desktop PC.  I get this error message:

Installation was not successful
"The referenced assembly could not be found"

I have tried running a couple utilities from Microsoft:

* Automatically reset Windows Update components
* System Update Readiness Tool for Windows 7 (KB947821) [August 2011]
* sfc.exe /scannow

I also updated the driver for the graphics card.

Any help would be greatly appreciated.

Thanks, Jon
Watch Question
Most Valuable Expert 2015
This problem has been solved!
Unlock 1 Answer and 11 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE