RDS Remote Gateway Service not installing

on a new 2012R2 deployment, we have 5 new servers to configure RDS solution

we follow the standard procedures to add the RDS service http://blogs.technet.com/b/askperf/archive/2015/03/04/step-by-step-instructions-for-installing-rds-session-deployment-using-powershell-in-windows-server-2012-r2.aspx

but we don't pass from the installation of the connection broker

i checked the windows internal database service is running
i changed the user to domain admin or service admin or local user but still the issue

try install the service using the domain controller ith domain admin account same issue.

server is fresh only all updates applied.

thanks for any help
error.jpg
LVL 1
sk391Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
Just for the record, the connection broker and the gateway are two different roles. Your subject says gateway, but the error is shows a failing connection broker install.

With that said, the error pictures is (as I'm sure you realized) not going to help you. It lets you know *that* the deployment failed, but not the why. For that, you should view the event logs on the server you attempted to deploy the RDCB role to. The failure should have logged more detailed events.
0
sk391Author Commented:
this is one of the error in the event logs
i have try all users i can imagin still not work

The MSSQL$MICROSOFT##WID service was unable to log on as NT SERVICE\MSSQL$MICROSOFT##WID with the currently configured password due to the following error:
Logon failure: the user has not been granted the requested logon type at this computer.
 
Service: MSSQL$MICROSOFT##WID
Domain and account: NT SERVICE\MSSQL$MICROSOFT##WID
 
This service account does not have the required user right "Log on as a service."
 
User Action
 
Assign "Log on as a service" to the service account on this computer. You can use Local Security Settings (Secpol.msc) to do this. If this computer is a node in a cluster, check that this user right is assigned to the Cluster service account on all nodes in the cluster.
 
If you have already assigned this user right to the service account, and the user right appears to be removed, check with your domain administrator to find out if a Group Policy object associated with this node might be removing the right.
0
Cliff GaliherCommented:
By default, when you install the Windows Internal Database, the account is created and granted those rights. But if it was already installed, or if you have a group policy overriding the defaults, then the WID will fail to start. It doesn't matter what user you use to install the role. THAT isn't the problem. The problem is that the database itself runs with its own unique user, and that unique user doesn't have the necessary permissions.  You can uninstall and reinstall the WID role/feature. Or you can manually add that account to the necessary permissions in the local security policy. And you may need to adjust any high-security group policies that may be superseding the local policy to allow that account to run as a service.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

sk391Author Commented:
hi,

interesting how can i do this

"Or you can manually add that account to the necessary permissions in the local security policy."

thanks,
0
sk391Author Commented:
cgaliher, would you recommend removing the WID, manually adding a new account with these permissions to the local security policy, or maybe just starting from scratch with a new OS installation?

if you could provide some guidance on the suggestion for "manually adding that account to the necessary permissions in the local security policy.", it would be great. thanks again
0
Cliff GaliherCommented:
The first thing I'd do is look for group policies that may be overriding your settings. If there are, then uninstalling WID, or even reinstalling the OS, would do no good.

Once you've determined that there are no conflicting group policies, either by fixing them or by analysis, then I'd uninstall and reinstall WID. Since this is a new deployment, that's the easiest way forward. Manually adding the account would be a path if there was essential data in the database already that would be destroyed by an uninstall/reinstall.

Flattening and reinstalling the whole OS is probably overkill.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sk391Author Commented:
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.