SBS 2011 & Assign A IPV6 Static IP Address

I just took on a new client that has an SBS 2011 server.  In reviewing the setup for the server the first thing I noticed is the IPV6  checkbox for the NIC was disabled.  My understanding is Windows Server wants IPV6 enabled so that things continue working smoothly.  This server has DNS issues, so I enabled IPV6, but it defaults to a dynamically assigned IP address.  BPA is complaining the address should be static.  I ran Fix My Network, but it did not change it to a static address.  

So, my question is how can I change it to a static address.  The IPV4 address for the server is 192.168.1.2, Mask 255.255.255.0.  Should the IPV4 192.168.1.2 be converted to IPV6 and should I enter it there, or should the IPV6 be different?   I looked at other SBS2011 servers that I manage, and they have static info defined for IPV6.  I never messed around with it since it was setup that way by default.  I basically need to know what to put for the IPV6 when the IPV4 IP is 192.168.1.2.  Thanks.
cmp119IT ManagerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mal OsborneAlpha GeekCommented:
Probably no need to configure anything. By default, a link local IPV6 should automatically configure. This is conceptually sorta similar to an APIPA address in IPv4. It will be in the fe80::/10 range.

If you start sniffing packets, you will probably discover that workstations are already accessing SMB shares via IPV6.

https://en.wikipedia.org/wiki/Link-local_address
Larry Struckmeyer MVPCommented:
Hi:  There is an explanation about half way down in this KB:  https://support.microsoft.com/en-us/kb/929852  But I cannot be sure that what you have done has not erased the values in the disabled components.
cmp119IT ManagerAuthor Commented:
I have an even more pressing issue in that the server keeps dropping the network connection entirely.  I was informed today that the server lost connection when people arrived at work in the morning.  The SBS 2011 server connects directly to a Netgear WNDR4500V3 router.  On the router the LAN port indicates a blinking green light two times and then an amber light over and over again.  The NIC on the server shows flickering green on the left side and the right side is either amber or not lit.  I cannot remember what the user told me earlier today.  Anyway, the office incurred the same problem last week,  I replaced the outdated Cisco RV110 router with the Netgear router mentioned above.  Cox Communications was dispatched and located some problems with exterior facility connections and re-provisioned the router.  They also noticed fluctuations in packets that did not look right, but the server was still able to access the Internet.  They are investigating the problem.  

In the mean time, I am able to remote into the router, but I notice the server is not listed as an attached device.  DHCP was disabled on the router as well.  I can see other devices, but not the server.  I had the user power down the server, and boot it back only to experience the same problem of not connecting.  

This is a really weird issue that I have inherited.  I tried both NICs on the server, and it does not appear to connect.  The lights on the NIC should both be green on the left and right hand side.  I cannot remember the NIC manufacturer at the moment.  It's weird that it works for about a week, and then the server loses its connection even when directly connected to the router.  I believe there are ISP issues, but the server should still be able to connect to the internet, and other workstations on the LAN should be able to see the server.  Right now all workstations cannot connect to the server.  Last week, Cox replaced the cable modem and some other things and then the server could connect to the Internet and the workstation could access the server for about a week until this morning.  Last week I even took the server to a shop that actually built the server, and they had no problem accessing the Internet.  I do not believe the issue is with the NIC.  The server event viewer looks pretty clean with no errors.  I know its a gigabit nic and the router has gigabit ports.  

I need to ask, what sort of problems will occur if the NIC drivers are updated?  I believe attempting to update a NIC's firmware usually causes communications problems and should be avoided.  Actually, the shop that built the server sent an identical NIC that installed on the motherboard, and it could not access the internet either.  I did not attempt updating the NIC drivers since I do not want to break comms any further.  

I am thinking of acquiring another NIC from another manufacturer, and installing the drivers if necessary and using that NIC.  I can't say it will make a difference, but then again it could be a NIC issue after all.  The existing dual NICs are embedded on the motherboard by the way.  Not sure if changing the link speed from auto to 1000 will make a difference.  I just don't that is necessary either.  I am just stuck between the problem centered with Cox and the server NIC.  I know that when everything is working fine the server NIC's left light flickers green, and the right side is solid green.  The right side solid green is the link speed (green for gigabit and amber fast Ethernet).  The LAN port on the router where the server is connected should display flickering green.  Last week the port showed amber color.  I moved it from port 1 to port 2 with the same thing.  In my experience if there are Internet issues, the workstations should still be able to connect to the server.  Meaning LAN communications should still function.  The only way they resumed was after Cox replaced the cable modem and did some things on their end, and now the issue is back.  Do you have any ideas what's could possibly be going on?  I do want to know about possible issues updating NIC drivers, and if its recommended to do so.
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

cmp119IT ManagerAuthor Commented:
Over the weekend I updated the Intel 82574L Gigabit NIC driver from version 11.0.5.22 (4/6/2009) to 12.7.28.0 (5/26/2015).  I ran a cable test of which disables communications during the test, and I notice when the test finishes, and it renables the NIC, it indicates its connected to the network but a cannot communicate at all, meaning I can't ping and access any network resources via windows explorer.  However, if I physically disconnect the Ethernet cable from the server and plug it right back in communications are re-established.  I also noticed when the server connects to a Zyxel 8-port gigabit switch or directly connected to the Netgear LAN port, which is also gigabit, the cable diagnostics fail on the last cable two tests.  I do not remember the exact names of the two failed items, but they have to do with receive and transmit...  So I connected a Netgear 5-port 10/100 switch, and the cable tests pass with no error.  However, when the test completes and the NIC is re-enabled communications do not work even though its indicates its connected to the network as well.  I physically disconnect the cable, and then reconnect it and it works fine.  I do not see any hardware or software errors pertaining to the NIC in Windows event viewer, and the NIC seems to be working fine with the exception of the above mentioned things.  Since the server NIC is now connected to a 10/100 Netgear hub the Intel NIC card on the serve now displays the right light as amber which is normal, and the Netgear router LAN port that the Netgear 10/100 switch is now iluminated amber as well.  That is all normal, but I thought I'd mention it anyways.   Please remember the NICs are embedded in the motherboard.
Larry Struckmeyer MVPCommented:
Have you replaced the cable?
cmp119IT ManagerAuthor Commented:
The original 2ft Ethernet cable from the server to the Netgear 10/100 switch is still connected.  The 15ft Ethernet cable connected on another Netgear 10/100 port is a new cable that I have used without issue.  Before I updated the NIC driver over the weekend, I have even tried connecting the 15ft Ethernet cable directly connected from the server to the Netgear router, and when there are server communications issues the server NIC card right light is either amber or not lit at all.  The Netgear router LAN port is either amber in color, or not lit at all.  So thus far, I basically updated the NIC driver, replaced the router, replaced the Ethernet hub, and in many instances used different Ethernet cables as well.  It appears when the server NIC experiences any loss of communications, it cannot re-establish communications.
Larry Struckmeyer MVPCommented:
So to recap:  New ISP device, no internal router, new/different cables,  new/different switches, new NIC drivers, alternate on board NIC,  system works as expected at another location, does not work in the office.  Static IP on the NIC in the server.  No IP conflicts in the network.

I'm still not comfortable with the cable response.  New cable to switch, or to router, same result... funky lights?  On either on board NIC with the other disabled?
cmp119IT ManagerAuthor Commented:
Attached you will find screenshots of the IPV settings.  

To answer your questions:  The ISP replaced the cabled modem and provisioned it.  I've tried using the existing cables and also used my owned Ethernet cables, I currently installed my own Netgear 10/100 5-port switch.  I have not tried using the other embedded NIC for about two weeks now, so since updating the drivers over the weekend it has been left disabled.   The unit was taken to the local shop that built the server, and it was able to connect to the Internet without issue.  However, this is not a good test.  The problem does not appear extablishing an initial connection, and is moreso an issue of maintaining the connection.  Thus far, we're able to re-establish communications for about three or four days, and then when everyone arrives in the morning the server is down and so is the Internet.  Last week, the user indicated every ten minutes they would loss the Internet about every 10 or 15 minutes, and needed to disconnect the router LAN port to the server and then reconnect it for it work again.

Also, please note the IPV6 DHCP settings.  IPV6 was initially disabled for some reason, and now that I enabled it, I cannot figure out how to get the appropriate IPV6 settings.  Look at the ipconfig screenshot and you'll the additional problem of the 192.168.1.200 address.  I needed to know how to set the correct static IPV6 settings.
IPV4_Settings.jpg
IPV6_Settings.jpg
ipconfig.jpg
Larry Struckmeyer MVPCommented:
The "fix my network wizard" should fix any issues with the IP settings.  But only ONE nic should be enabled on SBS for the wizards to work properly.  All others should be disabled in BIOS or in Device Manage or in Network Sharing Center.
cmp119IT ManagerAuthor Commented:
It was disabled in the past.  I think I left it enabled by mistake since last week trying to see if enabling and using the alternate NIC made any differences.  I just disabled it using Network Sharing Center.  A couple of weeks ago I ran fix my network wizard several times, and it did not make a difference.  It detected the router, etc.  I did this before updating the NIC driver over the weekend.  Not sure if I try and run it now while users are accessing the server if it will disconnect them or cause network issues.  Since the office was down a good portion of last week, I really want to avoid any more server connection issues.
Larry Struckmeyer MVPCommented:
I did not compare your IP screen shots with any others, but the actually look normal afaik.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cmp119IT ManagerAuthor Commented:
I am just digging around for any differences related the network settings.  I manage several other SBS 2011 server without issue.  I attached an IPConfig and the IPV6 settings for another server that has no problems at all.  I believe I added the loopback address as a secondary DNS server because the BPA indicated best practices suggest a second DNS server defined.  I did that a long time ago and left it as is without any problems.  I cannot seem to get the static information for IPV6 to populate on this server.  I am not even sure that it matters, and I am just fishing around for differences to locate possible network connectivity problems.
SRV1_IPConfig.jpg
SRV1_IPV6Settings.jpg
cmp119IT ManagerAuthor Commented:
Since I posted this question, I have everything alone.  I have not experienced any issues, so I will simply leave it alone.  Thanks for your help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.