Exchange 2010 - Setting up a receive connector for internal network scanners?

I am wondering what the best minimum way is to setup a receive connector for internal scanners on the network to use for relay, in order to e-mail PDF's/Images from the scanner to internal users' e-mail addresses.    
Do you just create an "Internal" receive connector, configure for anonymous access, and specify the IP/IP-range/subnet of the "allowed" network scanners?    
Do you need configure TLS in the receive connector?        
I get "login error" from scanner trying to scan but there aren't any credentials set anywhere, so I'm not sure if it's a scanner issue or an Exchange receive-connector issue.          

On one of my receive connectors, I believe it's configured properly, but I'm getting event log:    

Microsoft Exchange could not find a certificate that contains the domain name relay.cafelocal.com in the personal store on the local computer. Therefore, it is unable to support the STARTTLS SMTP verb for the connector relay with a FQDN parameter of relay.cafelocal.com. If the connector's FQDN is not specified, the computer's FQDN is used. Verify the connector configuration and the installed certificates to make sure that there is a certificate with a domain name for that FQDN. If this certificate exists, run Enable-ExchangeCertificate -Services SMTP to make sure that the Microsoft Exchange Transport service has access to the certificate key.      
       

I don't want to have to add anything to a certificate if I can help it.
garryshapeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Larry Struckmeyer MVPCommented:
Can't say I am familiar with that error.  Please review the following and see it you hit all the points:
http://exchangeserverpro.com/how-to-configure-a-relay-connector-for-exchange-server-2010

What is the event id and source of the error?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
garryshapeAuthor Commented:
Well when I telnet from a system on an IP that is in an IP range I specified for one receive connect, I'm getting helo from a different receive connect (the default Exchange receive connector that accepts from Full).
0
Budhi WitonoCommented:
This is not recommended, you can create receive connector uncheck all authentication , anynomous user permission , scope : scanner IP Address, hope this will worked,
0
garryshapeAuthor Commented:
http://www.petenetlive.com/KB/Article/0000791.htm  
This helped me. Not the firewall part, as it wasn't needed. Just the receive connector/Exchange authentication issue was what I need to read to get the fix.


Any change on an Exchange Server's Receive Connectors should be followed by you restarting the Microsoft Exchange Transport Service (on the server you made the change on) before you try again.

1. On the server you are trying to send TO, check the properties of the Default receive connector and ensure 'Exchange Server authentication' is selected.

Exchange Server authentication

2. On the server you are trying to send TO, If you have a connector configured to 'relay' mail, make sure that the server(s) or network specified DOES NOT include the IP address of the server you cannot send FROM. Also Make sure on the authentication tab 'Exchange Server authentication' is NOT selected.
0
garryshapeAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 250 points for fl_flyfishing's comment #a40990141
Assisted answer: 250 points for digitalplayground's comment #a40990174
Assisted answer: 0 points for garryshape's comment #a40990251

for the following reason:

other issue I was facing
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.