Alt+Enter With Office 2010 (64bit) freezes


I have a user that can't use the Alt+Enter key combination to add a line feed
with Office 2010 (64bit) - Word or Excel both react the same way, they lock up
Then one has to delete the process from the Task Manager

Any ideas ?
Yann ShukorOwnerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

I'm pretty sure ALT-ENTER is not a valid shortcut in Office 2010.
Maybe that key combination has been assigned to a macro?
In my installation the line feed combo in word is shift-enter but alt-enter in excel - I'm pretty sure they used to be consistent! -  and on investigation I found that word had a customised mapping changing it (alt+enter) to edit/redo and I've not yet found out how to change it back

you can check keyboard mapping under 'customise ribbon', 'customise keyboard shortcuts'.

I'm guessing its a mapping for different keyboard layouts; these are the official shortcuts for US layout:

whatever the reason there shouldn't be a crash so go into the customise keyboard dialog and in the 'new shortcut key' press alt-enter this will show what its currently assigned to and might point to where the problem lies

Also worth disabling any add-ins - especially Bluetooth - and seeing if that improves the crashing if not the user re-training!
Yann ShukorOwnerAuthor Commented:
thanks for your responses
I will try to repair the Office tonight and see if the result is any better
else I guess that I'll have to uninstall and reinstall the pack
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

i dont think that will help but the customisations are stored in the template so make sure you remove that when uninstalling or they will remain.

looking further I've found that shift+enter is not a key mapping that you can change and insert line feed is not offered as a command either so you may find that this is by design and can't be changed. I've switched to 2016 at my other office and will check if that's the same later today
Yann ShukorOwnerAuthor Commented:
I have tested Alt+enter on other machines running Office 2010 and they don't lock up

With Excel you get a line feed while typing in cell, and with Word you apprently duplicate  the text you just typed
yes in the later version of word the alt+enter seems to be mapped to editRepeatRedo - same as ctrl-y.

on the installation that breaks have you looked at the 'customise keyboard shortcuts' to see what alt-enter points at?

however this shouldn't be causing any problems in Excel because the key mapping isn't implemented there.

which keyboard layout do you have installed
Yann ShukorOwnerAuthor Commented:
Ok so last night I uninstalled the Office
removed folder Office entry from the Microsoft software registry section (HKLM & HKLU)
I ran Ccleaner, rebooted
Then I reinstalled Office
Alt+Enter stills locks up

I replaced the french keyboard layout with a UK
rebooted : Alt+Enter stills locks up

Launched Powerpoint and tested  Alt+Enter : doesn't lock up
In word:
go to backstage, options, customise ribbon,keyboard shortcuts [ customise], click on the 'press new shortcut key field' and press alt-enter - does this hang?

if not then on the lower left you should see what alt-enter is triggering (if anything) - what is shown?

Try re-assigning alt-enter to some other command and see if it still causes issues.

If none of this works then we should consider the possibility that its a keyboard/driver compatibility problem and only manifesting in word / excel for some obscure reason

In the meantime I think the users will have to get used to using shift+enter in Word and Alt+enter in excel because I can't see a way to remap them
Yann ShukorOwnerAuthor Commented:
Alt+Enter in Excel locks Excel up aswell
yes, sorry, I was thinking of something else.

given what we have uncovered so far I think it unlikely this is purely a word/excel problem, did you find out if the key has been mapped to something else?

the next stage would be to try with a different keyboard - from a machine that doesn't show the behaviour so we can exclude the keyboard hardware
Yann ShukorOwnerAuthor Commented:
I haven't checked the key mappings, but the user's first attempt was to swap keyboards with another user
I beginning to get the feeling that this might be a Windows issue rather than an Office problem
Was the swap keyboard a different make and model?

I agree its looking unlikely to be office however its worth trying some other things:
- if this is a laptop on a dock does the behaviour change if you switch between docked/un docked
- if this is a 64bit office try installing the 32bit and vice versa
- Is there anything in the event logs after a crash which indicates what broke

- please confirm you've disabled all add-ons especially Bluetotth
Yann ShukorOwnerAuthor Commented:
Thanks Reg
I called the user about the keayboard : different brands => DELL/Heden

The user gave me an additional indication though : the Alt+TAB freezes the app in focus and doesn't switch to the next app
So the issue is definately a Windows (or keyboard controller) issue
If it were a keyboard/controller problem I'd expect issues in other programs as well (and the keyboard driver sub system is pretty simple and solid) so I'd  check other drivers first. (it could be an intermittent hardware fault but if its reproducible in word/excel at any time that seems unlikely)

There was an old excel alt+tab problem that can sometimes be solved by
      File - Options - Advanced, Display category, uncheck "Show all windows in the Taskbar" but I'm not sure that's an option in 2010.
whilst there you could also try disabling 'hardware graphics acceleration'

Which Windows are you using? if you have Aero Peek  try disabling it

check you have the latest Graphics drivers installed and if the driver software includes any 'extras' such as Geforce Experience which might be mapping some other controlling functions with the alt combinations.

I think we are at the stage where you need to do a clean boot and see if the problem goes away

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Yann ShukorOwnerAuthor Commented:
I updated the graphics drivers: np improvement
Disbaled Aero: no improvement
I uninstalled unecessary utilities : Alt+Enter is working properly again
glad you got it resolved, if you can figure out which utility was causing it please post a follow up here for others who might use it
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.