What is keeping my template from being full width -- some padding/margin is on the left


Another basic question, but I've tried using firebug to zero in on the issue -- but can't resolve the issue on my own.

Please go to this website in development:  Left margin/padding issue

On a desktop you'll see that there is about 40 pixels padding or margin on the left of the page.  I'm trying to make it ZERO padding/margin on the left.


Rowby GorenAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Steve BinkCommented:
Bootstrap is setting -webkit-padding-start:40px on <ol> elements.  Place an override with padding:0 somewhere in your custom CSS.
Steve BinkCommented:
Actually, in my Chrome, the -webkit-padding-start is being set by the user agent stylesheet, not Bootstrap.  Still, an override will address the issue.
Rowby GorenAuthor Commented:
Hi Steve,

Thanks for helping.  

To really get to the bottom of this I downloaded the site (tons of files in this cms) and am using AstroGrep to track down that 40px padding

I tried searching for webkit-padding-start:40px  but nothing came up.  Perhaps you can give me a more generic search

OR give me the specific css override?  

However I'm thinking the code may be embedded in the php/html somewhere, so that's why I'm using Windows Grep to try to track it down in the 3000 plus files :)


Steve BinkCommented:
From what I could tell, it is my browser's internal style sheet presenting that padding.  You can override this by setting the padding in any style sheet for your site.  When you set it, don't use -webkit-padding-start, but rather set it on padding.  That will help with cross-browser compatibility.
ol { padding:0; }

Open in new window

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rowby GorenAuthor Commented:
Thanks Steve!

That "tiny" bit of css fixed it indeed!

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.