Avatar of Ralph Scharping
Ralph Scharping
Flag for Germany asked on

2012 R2 DC not reachable

Hi,

my business and I service about 300 customers in the small business range, mostly with pure Microsoft environments.

Our so far only two customers who run no servers other than Windows Server 2012 R2 experience this problem:

Every now and then, every other day or less frequent, logon into RDS is not possible because no domain controller is available.  DNS service does not work even though the service is running.  The AD member servers log frequent events relating to no DC available.  The DC logs no events, feels just fine, cannot resolve any DNS queries and sits there in ignorant bliss.
Restart of the service does not help, I have to reboot the entire machine .

Both customers run VMware, one has Exchange, the other does not.   Both customers have only one single DC. One domain, one tree.  
Eventlog does not record anything of any help.  

Many other customers run Server 2012 R2 for some services and 2008 R2 for others.  They don't report anything like this.

Does anybody have a clue what might be happening there?  Has anyone experienced something like that?

Thanks,
Ralph
Windows Server 2012Active Directory

Avatar of undefined
Last Comment
Ralph Scharping

8/22/2022 - Mon
Miguel Angel Perez Muñoz

Both customers run VMware, one has Exchange, the other does not.

Ensure vmware don´t do oversubscription/overcommit memory, focus especially on Exchange setup. I suggest you set fixed memory value.
Ralph Scharping

ASKER
Thas is the case.  Memory is not oversubcribed.
Miguel Angel Perez Muñoz

Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Ralph Scharping

ASKER
DNS is already configured as described.
Miguel Angel Perez Muñoz

And OS is updated?
Ralph Scharping

ASKER
Yes, no patches available.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Miguel Angel Perez Muñoz

Another thing, your DNS is configured to use any kind of router as forwarder?
Ralph Scharping

ASKER
No, I am forwarding to google.  But resolving even internally does not work when the issue occurs.
Miguel Angel Perez Muñoz

You can try disabling EDNS0, on command prompt run dnscmd /config /EnableEDNSProbes 0
Not requires restarts.
Your help has saved me hundreds of hours of internet surfing.
fblack61
Ralph Scharping

ASKER
The command went through without an error message.  But I'll have to wait a few days to check if this changed anything.

Somehow I don't think it is an isolated DNS issue...
kevinhsieh

Which type of NIC are the VMs using? They should be using Vmxnet3.
Ralph Scharping

ASKER
They are not.  Default is E1000 on VMware 5.5 and that's what they are.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
ASKER CERTIFIED SOLUTION
kevinhsieh

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Ralph Scharping

ASKER
Thank you for this hint.  I will change that and retry.  But I will need to wait a week to verify if this is really better.
Ralph Scharping

ASKER
I'm thinking we might be on the right track here.  Just exchanged the LAN adapters on all VMs.  First thing I notice is MUCH faster logon times...
kevinhsieh

:-)
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Ralph Scharping

ASKER
So far so good.  No crashes yet since I made the change.
Ralph Scharping

ASKER
Perfect!
I just wonder why the creation of a new VM defaults to E1000.
No trouble since I changed it....
Thanks a million!