virtual box in windows 10 not allowing to change processors

I'm running windows 10 and virtual box.  I tried to change the # of processors, but it's greyed out.
I did a search online, but I couldn't find anything.

I have a brand new Dell workstation T5810, with a 6core xeon processor, so since it's new, it should be supported I'm assuming.

Any ideas what I can't change the number of processors?
DanNetwork EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
And you run the latest version of both virtual box (5.x) and the virtual box extension pack?
0
DanNetwork EngineerAuthor Commented:
Yes, just downloaded virtual box today, but I never downloaded virtual box extension pack, not sure what that is.  I never had to install that before.
0
rindiCommented:
The extension pack is always needed and provides the virtual drivers for your VM's, so you can install the VBox additions within the VM.

But your issue probably doesn't have directly to do with that. Are you using Windows 10 Pro or above, and have you added the Hyper-V Feature? If that is so, Hyper-V will use your CPU's VT extensions and VirtualBox will only run in 32 bit mode. If it only runs in 32 bit mode, you can't use more than one virtual CPU in your VM's.

The same thing happens if you haven't enabled the VT extensions of your CPU in the BIOS.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

DanNetwork EngineerAuthor Commented:
Yes, when I open virtual box, every option is to run or install 32bit versions and I don't know why?
How do I change that, because I have a xeon E5-1650 v3 3.5ghz processor, it's a brand new processor (64bit).

I am running windows 10 pro 64bit.

You mentioned something about adding the hyper-V feature, I'm not sure what you're talking about?
Where do I add this?
0
JohnBusiness Consultant (Owner)Commented:
You can easily change the number of processors in VMware Workstation V12 made for Windows 10. You need to enable VT in BIOS as rindi mentioned, but once done, VMware Workstation supports multiple CPU's for a 64-bit guest. I do that for my 64-bit guests.
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
Hyper-V is Microsoft Virtualization solution and it's a FREE role in Windows 8, 8.1 and 10 Pro.  Just add it in the Control Panel / Program and Features. Then you won't need Virtual Box.

Further, Virtual box is a Type 2 hypervisor.  Hyper-V is type 1.  Type 1 Hypervisors are generally MUCH faster than type 2.  Google type 1 type 2 hypervisor for more information.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeCommented:
Before you try each and every possible hypervisor, here https://www.virtualbox.org/wiki/Downloads on the download page are the extensions
I have used vbox on 10 without problems and of course multi CPU cores work. Hyper-V is what I use mostly, it is good though I have to say it still has an annoyance on 10, when I maximize guest windows to full screen, it prompts me to logon again - happens often, but not every time.
0
rindiCommented:
You need to enable VT for your CPU in your BIOS. Usually that is disabled by default. If you haven't installed the Hyper-V feature of Windows 10 you should then be able to change your processors in VirtualBox, and also add 64 bit guests.

Hyper-V is not available for Windows 10 Home, so if you are on the home version, you needn't worry. But if it is Windows 10 Pro or enterprise, then check the features you have installed within Programs and features of the control Panel. If Hyper-V has been selected there and installed, VirtualBox will only run in 32 bit mode.
0
DanNetwork EngineerAuthor Commented:
Hey guys, thanks for all the good feedback, that's awesome.  Actually, when i was at work yesterday, I thought about using Hyper-V, and I think I'm going to go that route, as I think it's a better route.
I have win 10 pro, so I can use hyperV, actually, I also manage my other servers that are in a cluster, so now I have everything in one place, makes more sense.

I have looked in the bios, and I didn't see anything about VT, I just saw that virtualization is enabled.
0
rindiCommented:
That's probably the same thing. It isn't always called the same in the BIOS, and AMD CPU's use another name for it than VT.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.