Windows 10 Driver issue BSOD

Hello, I am facing an issue where I am facing a SAS card Highpoint RocketRaid 2722. I am running the latest driver and firmware. I had an issue with a portable hard drive that wont go beyond unlocking (WD Unlocker). I updated its firmware (which didnt help and i thrown it in garbage.). After the firmware update I have not been able to load windows. It gives be a BSOD with IRQL_NOT_LESS_OR_EQUAL 272x_1x.sys

All used to work well before this step using the WD firmware update utility. I tried system restore, with no avail. Only option I do now is to shut down the DAS and I can boot normally. As soon as I power it on the system crashes and I get the same error as I mentioned before.

I read there: http://windows7themes.net/en-us/5-ways-to-fix-irql-not-less-or-equal/?EsetProtoscanCtx=712a48 that the IRQ if shared with audio bus and raid controller it probably would cause this issue. I have no clue on how to let them use different IRQs. I ran msinfo and i verified this is true. I updated everything, the audio driver, MB chipset, GPU driver and still the same issue. I uninstalled the SAS raid controller with all its files from the system and added it again using the latest driver, still.

Its worthy to mention that I have another internal SATA RAID card installed from the same manafacturer: Highpoint RocketRAID 2320. This one is working with no issues. When I try to uninstall it, and check the delete driver files, and reboot I find it there again using the latest driver. Same when disabling it and restart, It becomes enabled again.

I got a dual boot with Windows 10 Professional x64 and Windows Server 2012. I do not face this issue with Windows Server 2012.

Please help.
LVL 3
infernumAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Davis McCarnOwnerCommented:
I think the root of your problem is in the WD drivers, not the Highpoint.
Get a copy of BlueScreenView ( http://www.nirsoft.net/utils/blue_screen_view.html ), boot into safe mode, and see if there isn't a WD? listed in there somewhere.
If there is, see if the WD junk will uninstall in safe mode.....
Lionel MMSmall Business IT ConsultantCommented:
I agree with the above--if you can boot into safe mode do so, and if removing the WD drivers AND software does not work use msconfig to do a diagnostic boot
infernumAuthor Commented:
used the blue screen analyzer it showed the above driver and ntoskrnl. also did Windows 10 repair didn't fix the problem.

I did uninstall WD junk still the same. if I power off the DAS boot and operation is normal. if it's on either at boot or after login I get the bsod.
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

infernumAuthor Commented:
System restore to an older date before this still the same issue. No issues with other Windows server 2012 r2.
Davis McCarnOwnerCommented:
" if I power off the DAS boot "  Huh, what does that mean?
infernumAuthor Commented:
If the storage unit was OFF the Windows boots normally. If I wait till I login AND then turn it on it crashes instantly
Lionel MMSmall Business IT ConsultantCommented:
OK says you can saying that everything works as long as you don't turn on the external storage and then when you do then it crashes your system?
infernumAuthor Commented:
Yes or if i boot while it is turned on. This behaviour does not happen with my second OS on this system, Windows Server 2012 R2.
infernumAuthor Commented:
Something interesting happened now. When I try to uninstall lit with delete driver files checkbox ticked from device manager it always returns. So I disabled it, uninstalled it, and went to the windows drive store (system32\drivers\) and deleted it manually. Now i tried with an older driver, it worked, but I could only see a JBOD volume, and the RAID array is not there. Whenever I try to upgrade the driver to the latest version I was using I get a bsod (with the box switched on, if it is off then no problem).
Davis McCarnOwnerCommented:
If I were you and there was anything I cared about on that array, I'd boot 2012 and get it backed up!
nobusCommented:
post the minidump plse
find it in Windows\minidumps
infernumAuthor Commented:
Solved. Deleted RAID array from bios and it worked fine after that. Also it didnt see a disk from the 6 disks used in the array. I wanted to add the 6th disk as a hot spare, but later on it saw it ,I think its a hardware issue.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
infernumAuthor Commented:
No one else provided a valid solution.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.