Cannot add any Domain Users to local Admin Group

Hi,

Ive got three W2k8 Servers and I need to add domain users to the local admin group of one of the servers. Im able to do it on two out of three of the servers but for some reason, on the third server, it just wont let me.

Ive ensure when I go an add, the location is pointing at the domain but no matter what, it doesnt find the domain account?? I can add local accounts to the group if I change the location to the local server but when I change the location back to the domain and try and add, it just doesnt find anything??

Any ideas why I can add to the others servers but not this particular one. The server also has SQL 2008 installed on it, but that shouldnt make any difference?

Thanks
SycamoreIT
SycamoreITAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Schnell SolutionsSystems Infrastructure EngineerCommented:
Hello,

Let's check if it is some problem contacting resources from the DC.

Please, try to review the DNS configuration for your SQL server. It must point to an IP address of a DNS containing your AD information (Usually it is your DC ip address).

Additionally, ensure that you can communicate from your SQL server to your DNS correctly. Try executing from a prompt: nslookup yourdomain.com. For example, if your AD domain name is experts.local, execute:

nslookup experts.local

and ensure that you have a positive answer for the return of this command.
SycamoreITAuthor Commented:
Ok, when I ran nslookup mydomain.local it came back with DNS timed out error.

I can confirm in the network settings of the server, the default gateway is set to the ip address of the DC which is the same as the other servers in the environment. When I run the same command on the other servers, I dont get the DNS timed out error.
Schnell SolutionsSystems Infrastructure EngineerCommented:
Good.

This is not normal that you use your DC as a default gateway. Maybe just for special cases where your DC is acting as a router.

But it looks that you need to specify your DC ip address as the preferred DNS for your SQL server. You can compare the information as you did with the rest of the servers.

After you are done, clean the DNS cache from your SQL server executing the following command:

ipconfig /flushdns

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SycamoreITAuthor Commented:
That the ticket, once I flush the DNS i was able to add the domain users. Thank you.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.