VMware Tool Install Problem

I have Fusion 6.0.6 and I am wanting to install VMware Tools on a guest Linux - Centos 6.4 VM.

I ran the command to remove any tools since I had tried before and I get these two screen  messages

https://gyazo.com/29b0440833be651669d425749cf38ee2 - this mentions some modules were already there even after I removed everything and ran vmware-uninstall-tools.pl

so I proceeded then I got this message
https://gyazo.com/a3bbb1610e45787347d21bc3559abfa1

Please help me to get these installed because I can't copy and paste anything and hopefully this will fix the problem of not installing properly.

Thanks,

Randal
sharingsunshineAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
It has been a while, but I remember having to upgrade the Linux kernel to upgrade the VMware Tools (and upgrade the install process to reference the new kernel). See if that might be the issue.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
there is now, sometimes no requirement to install VMware Tools, as support for the interface is already included in your Linux distribution.

also now, many have an open VMware Tools which is recommended for your distro, than VMware Tools installation with the OS.
0
rindiCommented:
As Hanccocka has mentioned, many distro's include Vmware Tools in their repo's, some of them automatically load them if they sense the OS is running on VMware, on others you need to install them via the package manager (in your case that would be yum). Although you can use the standard way to install them it is better to use the distro's package manager for that, as then kernel upgrades will automatically also include the new tools. If you don't use the package manager, any kernel upgrades will not automatically also upgrade the tools, so you would always have to reinstall them manually.

Whether CentOS automatically loads the tools if it recognizes it is running on VMware I don't know, but it certainly has them in the repo's.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

sharingsunshineAuthor Commented:
thanks for the answers but everything I read on the forums and net said vmware tools wasn't installed which was causing my copy and paste problem.

I can't copy text on the host and paste it on the guest nor can I do vice versa.  

I ran yum list vmware and many derivatives and find nothing in the package manager.  

So please tell me how to proceed.
0
JohnBusiness Consultant (Owner)Commented:
Try upgrading the kernel of your machine (which is always worthwhile to do anyway)
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I think some of the issues you are experiencing, is that you have downloaded, someones, ready made virtual machine, and you have not installed Centos, in a virtual machine, from the DVD/CDROM ISO distributions.

Most virtual machine experimentors, install the OS from scratch in the VM, which gives you a far better understanding of what is required, and what is missing, and needs adding.
0
rindiCommented:
At the moment I can't say, as I don't use CentOS, and it will take some time to get it downloaded and setup.
0
rindiCommented:
The other thing I have just noticed is that you are using an older version of CentOS. For older versions things may be different. Current would be CentOS 7.
0
sharingsunshineAuthor Commented:
"I think some of the issues you are experiencing, is that you have downloaded, someones, ready made virtual machine, and you have not installed Centos, in a virtual machine, from the DVD/CDROM ISO distributions.

Most virtual machine experimentors, install the OS from scratch in the VM, which gives you a far better understanding of what is required, and what is missing, and needs adding. "

I will follow the above quote

I need a CentOS 6. VM because this is a test system and currently our production site is using that version.  

OK, I am downloading an iso from http://ftp.usf.edu/pub/centos/6.7/isos/x86_64/ I chose
CentOS-6.7-x86_64-LiveDVD.iso      07-Aug-2015 14:23       1.9G       is that the best choice to load into the VM?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Correct, it is better to install from scratch.
0
sharingsunshineAuthor Commented:
It is much better and easier to work with.  However, I am still not able to copy text on the host and paste it on the guest nor can I do vice versa.  

This is very troublesome because of all the code I need to  put in at the command line.

I have loaded and reloaded vmware tools.  I have logged out each time as it states.  I have rebooted the system too.

Yum doesn't have it listed.  Any suggestions
0
JohnBusiness Consultant (Owner)Commented:
If you reinstalled Linux and then installed the tools, make sure in VMware, Virtual Machine Settings, Options, Guest Isolation that Copy and Paste is enabled.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Why  not just SSH to the VM, using PuTTY, and all your copy and paste issues will be history!

There is never any reason to use the console on a LInux VM!

As you are using Mac OS X, there is a ssh client included already, ssh.

otherwise this one with a GUI

https://cyberduck.io/?l=en
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sharingsunshineAuthor Commented:
I am not able to telnet into the site.  When I switch it away from Nat it doesn't have an ip address.  That's why I thought working with the console may help me to get past that hurdle.

It does have a browser and it worked when it was under Nat.
0
JohnBusiness Consultant (Owner)Commented:
When I switch it away from Nat it doesn't have an IP address  <-- What did you switch to? Bridged networking will give you an IP from the DHCP source your host machine uses. Do not use Host Only setup. Use either Bridged or NAT and you should have an IP address.
0
sharingsunshineAuthor Commented:
I changed it from Share with my Mac which is Nat to Wifi which is bridged.

see the screeshot

https://gyazo.com/0a22a1967b241572870df1077c03b9ee
0
rindiCommented:
Don't telnet. That is insecure and usually isn't installed anyway. As Hanccocka already mentioned, use SSH.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
There is a networking issues, if your VM, is unable to obtain a IP Address, via DHCP and Bridged Networking.

Do you get an IP Address issued by DHCP ?

This is unlikely to be the result of VMware Tools.
0
sharingsunshineAuthor Commented:
Yes, I got an ip address using dhcp with Nat.

I need to configure the network adapter but on 6.7 the file isn't named the same so I don't know what file to configure.

Here is the screenshot of where it used to be located.  That is the file ifcfg-eth0

[root@localhost ~]# cd /etc/sysconfig/network-scripts/
[root@localhost network-scripts]# ls
ifcfg-lo     ifdown-isdn    ifup-aliases  ifup-plip    ifup-wireless
ifdown       ifdown-post    ifup-bnep     ifup-plusb   init.ipv6-global
ifdown-bnep  ifdown-ppp     ifup-eth      ifup-post    net.hotplug
ifdown-eth   ifdown-routes  ifup-ib       ifup-ppp     network-functions
ifdown-ib    ifdown-sit     ifup-ippp     ifup-routes  network-functions-ipv6
ifdown-ippp  ifdown-tunnel  ifup-ipv6     ifup-sit
ifdown-ipv6  ifup           ifup-isdn     ifup-tunnel

So that seems to be the problem how to configure the network adapter?
0
sharingsunshineAuthor Commented:
this is ifconfig with using "Share my Mac" settings or Nat

[root@localhost network-scripts]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:43:FC:FD  
          inet addr:192.168.54.152  Bcast:192.168.54.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe43:fcfd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:311 errors:0 dropped:0 overruns:0 frame:0
          TX packets:356 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:75064 (73.3 KiB)  TX bytes:28515 (27.8 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1

this is with wi-fi or bridged settings

[root@localhost network-scripts]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:43:FC:FD  
          inet6 addr: fe80::20c:29ff:fe43:fcfd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:311 errors:0 dropped:0 overruns:0 frame:0
          TX packets:357 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:75064 (73.3 KiB)  TX bytes:28857 (28.1 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1872 (1.8 KiB)  TX bytes:1872 (1.8 KiB)
0
rindiCommented:
As I don't have a MAC I can't say exactly how the setup is done, but on VMware Player running on a PC when you open the settings of a VM and select "Network Adapter", you can chose between "Bridged" (and there under "Configure Adapters" you would select the actual NIC of your host, and that can also be the wireless NIC), "NAT", etc. If you want to have the VM reachable from your LAN, you must choose Bridged. I'm sure VMware fusion has similar options. There is also an "Advanced" button where you can see or create the virtual MAC Address for the Virtual NIC. You can use that to set an IP reservation on your DHCP server so the VM always gets the same IP. That way you don't have to get into the configuration of your virtual NIC within the VM, you can just leave it at the default DHCP.

The IP you get for your VM if setup properly should then be on the same LAN segment as the IP you get for your host OS (OSX).

An alternative to VMware fusion would be to use Oracle's VirtualBox, which is OpenSource and free, and generally works better with Linux guests as it is OpenSource. It also has options that allow you to enable copy and paste between guests and hosts. Also there the VirtualBox extensions are usually already included with the Distro's repositories. If they aren't there already by default you just need to add them via the distro's package manager (search for virtualbox guest).

https://www.virtualbox.org/wiki/Downloads
0
sharingsunshineAuthor Commented:
I have used virtualbox before and I prefer Fusion.  I made the change to the mac address in the advanced section but I had to create a file at etc/sysconfig/network-scripts/ifcfg-eth0 and modify /etc/udev/rules.d/70-persistent-net.rules to get an ip address via dhcp

Now I have an ip address
[root@localhost ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:82:00:45  
          inet addr:192.168.0.197  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe82:45/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:60 errors:0 dropped:0 overruns:0 frame:0
          TX packets:83 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:22920 (22.3 KiB)  TX bytes:9927 (9.6 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:480 (480.0 b)  TX bytes:480 (480.0 b)

When I use telnet just for testing purposes

rjw telnet 192.168.0.197 80
Trying 192.168.0.197...
telnet: connect to address 192.168.0.197: Connection refused
telnet: Unable to connect to remote host

I ran this to see if the port was open
root@localhost ~]# netstat -nlp | grep 80
tcp        0      0 :::80                       :::*                        LISTEN      3800/httpd          
unix  2      [ ACC ]     STREAM     LISTENING     15180  2392/master         private/verify
unix  2      [ ACC ]     STREAM     LISTENING     18559  2726/gnome-session  /tmp/orbit-howdy/linc-aa6-0-758035098999e
unix  2      [ ACC ]     STREAM     LISTENING     20086  2879/bluetooth-appl /tmp/orbit-howdy/linc-b3f-0-274d12f61b480

and I have made sure httpd is running.

So how do I ssh into this VM?
0
sharingsunshineAuthor Commented:
I finally got this to work.  To help others that may have the same issue.

I got most of the content from this link
http://ithelpblog.com/os/linux/redhat/centos-redhat/install-and-configure-ssh-on-centos-6-4-6-3-5-9-redhat-rhel-fedora/

need to make sure you have run this command
yum -y install openssh-server openssh-clients

chkconfig sshd on
[root@localhost Desktop]# /etc/init.d/sshd start

this should start up port 22 but to double check use this command
nc -v -z 127.0.0.1 22 this is testing if your port is open from your VM

If it is then go to your OS X host and use this syntax
ssh [username on VM]@[ip address you get from ifconfig]

if it is working initially you should get a screen message similar to this

The authenticity of host '192.168.0.197 (192.168.0.197)' can't be established.
RSA key fingerprint is 99:d8:36:a8:8f:9f:a5:5f:ed:7a:61:12:d2:7b:7c:c3.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.0.197' (RSA) to the list of known hosts.

 then it will prompt you for your username on VM's password:

if you want to use root privileges you will need to do sudo -i.  Provided you have set up  that username to have root privileges.
0
sharingsunshineAuthor Commented:
Thanks for everyone's input and assistance.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.