Outlook 2016 / Exchange 2010 automatic configuration

Exchange 2010, autodiscover records are correct and have no issues.  Autodiscover DNS records are correct and ping the correct public IP.  The SSL certificate includes the autodiscover host names.  There has never been an issue connecting from Outlook, phone, tablet, etc. through manual configuration.  But now, with Outlook 2016, automatic configuration is required and it is failing.  I'm trying it right now from Outlook 2013 because it gives me more information.   It establishes the network connection, it finds the email settings, pops up the login box.  I enter domain\username, and the password, and then get the error "Outlook cannot log on.  Verify that you are connected to the network and are using the proper server and mailbox name... "  If I click OK it brings up the correct local host name of the server and mailbox "=SMTP:{email address}.  I can't figure out what is wrong.  Should it be bringing up the public host name rather than the local one?  If so, where is it entered wrong?  I'm tearing my hair out trying to figure this out!  Help!
landiiiks2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Muhammad BurhanManager I.T.Commented:
You should have to configure autodiscovery for outlook2016.
Or
you should do the second choice (if currently you only have office 2016 installed): uninstall 2016 --> install 2013 --> Set up exchange account --> upgrade 2016

Setup autodiscovery:
http://www.experts-exchange.com/articles/17339/Understanding-and-Setting-Up-AutoDiscover-for-Exchange-2010-2013.html
Or
https://mshiyas.wordpress.com/2010/07/06/how-to-configure-and-verify-autodiscover-for-exchange-2007-and-2010/
0
landiiiks2Author Commented:
Thanks.   As I said,  autodiscover is set up and working correctly.  It passes all tests.   Plus I would get an error on stage two if it wasn't working,  not stage 3.  It is finding the correct server,  it just isn't logging in.
0
Muhammad BurhanManager I.T.Commented:
Actually outlook2016 uses Mapi/http to use autodiscovery instead of RPC over http,
Please ensure that exchange firewall allow MAPI over HTTP.
Or
To disable MAPI/HTTP and force RPC/HTTP, set this key on the client computer.
HKEY_CURRENT_USER\Software\Microsoft\Exchange
DWORD = MapiHttpDisabled
Value = 1
1
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

landiiiks2Author Commented:
Exchange 2010 does not use MAPI over HTTP.  Although Outlook 2016 uses MAPI over HTTP, it also uses Outlook Anywhere (RPC over HTTP).  Otherwise no Exchange 2010 or earlier servers could ever connect via Outlook 2016.  And I know that isn't the case - I've successfully connected Outlook 2016 to both Exchange 2007 and 2010 (without any registry hacks or other changes).  Also, in this particular case, the automatic connection is not working from Outlook 2013 either.  Yet the manual connection works perfectly.  And again, Outlook is making the connection to the server.  It just won't take the last step of logging in.
0
Amit KumarCommented:
Did you check it only for one user or for e-mail address it is happening, it is possible for which e-mail address you are trying it is hidden in GAL. Please give a try to another e-mail and which is already working in Outlook 2010/2013.
0
landiiiks2Author Commented:
I wish it had been that easy!   But no, the addresses I am trying are not hidden.  For what it's worth, I have tested with a VPN open to the network and it works.  So that would suggest something with the firewall, but 443 is open (and if it weren't it also wouldn't work with manual configuration or OWA).  Everything from inside is allowed out.  I don't know of any other port that is necessary for this to work...
0
Amit KumarCommented:
can you perform test connectivity ExRCA from this site using ActiveSync, Outlook Anywhere..


https://testconnectivity.microsoft.com/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
landiiiks2Author Commented:
Thank you!  I feel stupid now - it had passed all the tests I had tried before but for some reason I skipped one...  It turns out Outlook Anywhere was not enabled - I have no idea why.  But it is now, and is working fine!  Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.