Unable to hear any sound on Win 10 laptop after upgrade ?

People,

I'm using Windows 10 and regularly using Media Player Classic from KLite codec mega pack it was working well for all media types except Bluray movies:

Video: MPEG4 Video (H264) 1920x1080 29.97fps [V: h264 high L4.1, yuv420p, 1920x1080]
Audio: DTS 48000Hz stereo 1536kbps [A: English [eng] (dts-hd ma, 48000 Hz, stereo)]
Audio: DTS 48000Hz 6ch 4608kbps [A: English [eng] (dts-hd ma, 48000 Hz, 5.1)]

somehow no sound at all for the file type above in both WMP and MPC ?

Before the Win 10 upgrade it's all working fine.
Normal MP3, FLAC and other MKV files are working great.
LVL 11
Senior IT System EngineerIT ProfessionalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
According to your post, sound is working (Normal MP3 ... working great). So the audio driver is probably working.

Try the following:

Upgrade / reinstall the audio driver just to be sure.
Upgrade / reinstall the software in question. It may the software is not Windows 10 compliant or needs to be reinstalled.
awawadaCommented:
You have a Codec problem. This is not a driver problem.Do you have the K-Lite Codec Pack Mega Version 11.4.0? I have no problem.
http://www.codecguide.com/download_k-lite_codec_pack_mega.htm

You can also try VLC player.
http://www.videolan.org/
Senior IT System EngineerIT ProfessionalAuthor Commented:
Hi Awada,

I'm running:

MPC-HC (Nightly, 64-bit)
------------------------

Build information:
    Version:            1.7.9.145 (0cf555f) (develop)
    Compiler:           MSVC 2013 Update 5
    Build date:         Aug 10 2015

LAV Filters:
    LAV Splitter:       0.65.0.47
    LAV Video:          0.65.0.47
    LAV Audio:          0.65.0.47
    FFmpeg compiler:    MinGW-w64 GCC 5.2.0

Operating system:
    Name:               Windows NT 10.0 (build 10240)
    Version:            10.0 (64-bit)

Hardware:
    CPU:                Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
    GPU1:               Intel(R) HD Graphics 3000 (driver version: 9.18.7.9)
    GPU2:               Intel(R) HD Graphics 3000 (driver version: 9.18.7.9)
    GPU3:               Intel(R) HD Graphics 3000 (driver version: 9.18.7.9)

Open in new window

IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

☠ MASQ ☠Commented:
Sounds as if your Audio DTS decoder has been disabled - did you reinstall K-lite after upgrading to Win 10?
In any event try resetting the decoder defaults (launch MPC > View > Options > Misc. > Reset)
Are you outputting to 6.1 or do you need plain stereo?
awawadaCommented:
Agree MASQUERAID that was my next step.
Senior IT System EngineerIT ProfessionalAuthor Commented:
MASQ and Awawada,

Does this also have something to do with the disabled SPDIF as well ?

SPDIF not working either
since upgrading to Windows 10, my sound also not coming from my 5.1 speaker connected through my Toshiba Dynadoc.
JohnBusiness Consultant (Owner)Commented:
It might - I do not have that on my Windows 10 machine so cannot test it. Is your sound system compliant with Windows 10?
☠ MASQ ☠Commented:
Have you added the new Windows 10 drivers for the DynaDock?
Given some of the problems Win 10 currently has with DTS decoding see if you can get audio out from the DTS MP4's via HDMI first.
Senior IT System EngineerIT ProfessionalAuthor Commented:
Using the HDMI from my Win10 laptop into the Samsung SmartTV didn't work at all ?

but I can still play music (MP, FLAC, audio CD) from my laptop to the Samsung SmartTV as well as other ..MP4 files.

is this a bug in the K-Lite codec or windows 10 audio driver issue ?
JohnBusiness Consultant (Owner)Commented:
is this a bug in the ...  windows 10 audio driver issue ?  <--- Could be. Does the manufacturer list a Windows 10 driver for Audio (or combined Windows 8.1 / 10 driver)?
☠ MASQ ☠Commented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Senior IT System EngineerIT ProfessionalAuthor Commented:
ok, last night when I ran the upgrade of my codec into KLite Version 11.4.0 Mega, still no resolving the issue.
☠ MASQ ☠Commented:
It's not a codec issue -  this is broken in Windows 10.  If you want DTS BluRay playback while Microsoft fix it you should revert to your previous Windows install.
Senior IT System EngineerIT ProfessionalAuthor Commented:
Ah I see.

So I guess it will ahveto wait until some windows update fixes it ?
☠ MASQ ☠Commented:
Very likely, the DTS BluRay problem became apparent in July's TP version. There's a possible workaround with hardware decoding on some graphics cards but only with stereo over HDMI so looking for a newer graphics driver probably won't help in your situation.  It's not a codec thing though.
Senior IT System EngineerIT ProfessionalAuthor Commented:
Thanks !
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.