DNS - added a NIC to a VM set no DNS  on the new NIC   - from that server if I ping its own name it replies with the new IP on the new NIC

philb19
philb19 used Ask the Experts™
on
I just noticed this - and now some scripts dont work as they try and egress the new NIC - which in fact is for iscsi SAN - there is no gateway and no DNS set on the new adaptor  - WHY has this happened ? how in the server itself has it registered some sort on name record for the server tieing it to the new adaptor storage van. - i put hosts record in and flushns and now its back to the correct IP - I just want to understand whats going on here?  thanks  OS 2008 r2
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
local lookup first before DNS.

Author

Commented:
Thanks but where is the local mapping it was not in any hosts file?
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
It does not have to be in a local hosts file.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
This article explains the situation very well:

https://support.microsoft.com/en-us/kb/981953

However it still does not tell me "where" the name is mapped. - Ok it uses the first adapter in the bindings - but where is the entry for the mapping if not in the hosts file - An adaptor doesnt have a name assosciated with it? if not hosts and not DNS - is it in another file or in registry - how does it work? - thanks
Systems Engineer (Acting IT Manager)
Commented:
Change the binding order of the NIC's on the Windows server

1.

Open the Network Connections folder and view available connections.

2. Press ALT to display the menu bar, and then on the Advanced menu, click Advanced Settings. The Advanced Settings dialog box opens.

3. In the Advanced Settings dialog box, on the Adapters and Bindings tab, in the Connections list, click the connection that you want to modify. If you wish to change the order in which your connections are tried, click the up or down arrow buttons to rearrange the order.

4. In the Bindings for ConnectionName list, click the protocol that you want to move up or down in the list, and then click the up or down arrow buttons to rearrange the order of the protocols.

5. In the Advanced Settings dialog box, click the Provider Order tab.

6. On the Provider Order tab, in the Network Providers list, select the provider that you want to move up or down in the list, and then click the up or down arrow buttons to rearrange the order.


DirkMare

Author

Commented:
Thanks but I know very well how to do this - change bindings.

Im after an undestanding of where the name mapping takes place if not hosts or DNS
Dirk MareSystems Engineer (Acting IT Manager)

Commented:
The interface metric would also cause this. the second NIC should have a higher metric value.

Binding Providers
DirkMare

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial