Browsers (Chrome, Firefox, IE) will not resolve FQDN's on my local network, but all can ping FQDN's

I am trying to get various workstations to be able to go to "https://webserver1.newgoloka.local" in other words to resolve the FQDN. just https://webserver1 without the domain name resolves fine. What I am trying to do is get SSL set up properly (just for the internal intranet). The browser will throw a warning if the name typed in the address bar does not match the exact name on the certificate.

I can also ping the FQDN from any workstation, just fine. I also have a little C program that calls gethostbyname() and that works fine. I have also tried writing a little 4 line php file that calls gethostbyname(). That does NOT work when accessed in the browser. it works with anything other than internal FQDN's.

As far as I know my dns server is set up properly.

Problem exists on various hosts, windows and linux.
DNS server: bind9 on ubuntu 14.04
Webserver: "webserver1" ubuntu 14.04 kubuntu desktop installed
LVL 1
Jeff swicegoodTechnicianAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
does a nslookup webserver1.newgoloka.local show you the ip of the machine that holds the apache web server..?? if so then look at your htaccess and apache configuration
0
Jeff swicegoodTechnicianAuthor Commented:
Ok, that started working on it's own. Now when I go to webserver1.newgoloka.local it's saying "invalid certificate authority" on my ubuntu desktop machine. Does that mean the root certificate was not added properly?
0
David Johnson, CD, MVPOwnerCommented:
correct the root certificate is not present or in the correct store.
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

gr8gonzoConsultantCommented:
On a windows machine that is experiencing the problem, I'd suggest going to the command line and typing:
ipconfig /all

Look for the main network adapter (usually "Ethernet adapter Local Area Connection" if it's plugged in via an ethernet cable) and write down the entries next to "DNS Servers". Those are the servers that need to know about the "webserver1.newgoloka.local" host in order to provide a local / intranet IP address back to the requesting computer. If you have more than 1 server, then perhaps not all of them are configured to resolve local addresses (your DHCP server is normally responsible for handing out configuration, including DNS servers).
0
Jeff swicegoodTechnicianAuthor Commented:
The DNS part is working. I have tried many different ways to import the root certificate, but "invalid certificate authority." I went through the whole process for the third time of generating a root cert, making a signing request, signing the cert, and configuring apache, and finally importing the root CA certificate for use in chrome on linux and windows. Let's focus on Windows. In windows I used MMC snapin manage certificates to hit import and go through the wizard. Simple enough. What could have gone wrong?
0
David Johnson, CD, MVPOwnerCommented:
Given a CA certificate file 'example.crt',MUST END IN .CRT" follow these steps to install it on Ubuntu:
First, copy your CA to dir /usr/local/share/ca-certificates/
sudo cp example.crt /usr/local/share/ca-certificates/example.crt
then, update CA store
sudo update-ca-certificates
Do you get the output like:
Updating certificates in /etc/ssl/certs... 1 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d....
Adding debian:example.pem
windows click on the file and select the store manually trusted_root_providers
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jeff swicegoodTechnicianAuthor Commented:
Yes it does have that output, except it says "replacing" instead of "adding."
Windows, I followed the procedure, but same result.
0
David Johnson, CD, MVPOwnerCommented:
if it is replacing then it already exists.
0
David Johnson, CD, MVPOwnerCommented:
where is the error message coming from? browser /apache?
0
Jeff swicegoodTechnicianAuthor Commented:
Now it works in WIndows. I was importing the wrong certificate, the signed certificate not the root cert. Still a no go in Ubuntu. Error is coming from browser.
0
Jeff swicegoodTechnicianAuthor Commented:
The output from sudo update-ca-certificates looks right.
0
gr8gonzoConsultantCommented:
Which browser on Ubuntu? I've seen a couple browsers that have their own CA store.
0
Jeff swicegoodTechnicianAuthor Commented:
Chrome, Firefox.
0
Jeff swicegoodTechnicianAuthor Commented:
Chromium.
0
Jeff swicegoodTechnicianAuthor Commented:
You were right they have their own stores. Here is the solution for chrome:

certutil -d sql:$HOME/.pki/nssdb -A -t TC -n "webserver1 CA cert" -i cacert.crt

Open in new window

0
Jeff swicegoodTechnicianAuthor Commented:
Firefox has it own built-in certificate manager. Just import.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.