install sql server 2008 on win8.1

Hi,

I have some old software I need to run  again, using asp.net

I need to use vs2010 and sql server 2008 (management) on win8.1

The instructions are to load framework  3.5 sp1 and windows installer. Do I need to do this with win8.1?

Will I have other issues to get this to install because there looks like so many pieces of software to get to run.
jagguyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
sql server MUST be upgraded immediately to the latest update before use.
Add net 3.5 via programs and features, windows components
0
jagguyAuthor Commented:
how as it didnt install on 8.1, ?
0
Fernando SotoRetiredCommented:
Hi jagguy;

To your question, "The instructions are to load framework  3.5 sp1 and windows installer. Do I need to do this with win8.1?",  from Microsoft documentation
The .NET Framework 3.5, however, is not automatically installed with Windows 8, Windows 8.1 or Windows 10, and must be separately enabled to run applications that depend on it. This must happen through Windows Update, which is invoked in one of three ways. All of these require an Internet connection:
To your question, "Will I have other issues to get this to install because there looks like so many pieces of software to get to run.",  the link I posted above has three different ways to install all that may have issues.
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

jagguyAuthor Commented:
Thanks for the information,
'my windows update/internet connection  has been on for a long time so I am not sure what you mean.
To install the framework3.5 what exactly do I do because saying installing something through an update doesnt help me much
0
Fernando SotoRetiredCommented:
Did you follow 1 of the 3 ways on the like I posted.
0
jagguyAuthor Commented:
sorry I really dont understand what you mean.
The framework 3.5 simply doesnt install after I download the whole thing, as nothing happens

also the link says .net 4.5 is installed with win8 so why do i need 3.5?
0
Fernando SotoRetiredCommented:
To your statement, "sorry I really don't understand what you mean.", On the link I posted in my original post there are three ways to install. Which option did you try?

To your question, "also the link says .net 4.5 is installed with win8 so why do i need 3.5?", Not sure what version of the .Net Framework is supported with Visual Studio 2010 but I assume that when you tried to install it it knows what versions are installed and would bypass that installation if it has a supported version.
0
David Johnson, CD, MVPOwnerCommented:
you cannot download it and install .net 3.51, you do it from programs and features and select .net framework 3.5 (includes .net 2.0- and 3.0) if it is not on your system it will download and install it using windows update
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.