Avatar of jonathanduane2010
jonathanduane2010
 asked on

importing site so new server

Hi Guys,

I am importing my existing site to new server, its a combination of a custom cms and wordpress. its here at http://iradio.ie

So far i have created an account on new server uploaded the files there i think the next step is to create two databases and import the data in would that be correct according to this settings.php ?

<?
if ( !defined('BASEURL') ) define("BASEURL", "http://www.iradio.ie/");
if ( !defined('MYSQLSERVER') ) define("MYSQLSERVER", "localhost");
if ( !defined('MYSQLUSER') ) define("MYSQLUSER", "iradio_iradio");
if ( !defined('MYSQLPW') ) define("MYSQLPW", "sqlpasswordnotreal");
if ( !defined('MYSQLDB') ) define("MYSQLDB", "iradio_iradio");
if ( !defined('SERVERROUTE') ) define("SERVERROUTE", "/var/www/public_html/sites/site/");
if ( !defined('TESTINGSITE') ) define("TESTINGSITE", false);
$ip_address = 123;
if (isset($_SERVER["REMOTE_ADDR"])) $ip_address = $_SERVER["REMOTE_ADDR"];

$devIPS = array( '82.122.65.29', '79.140.211.206', '159.134.156.214', '37.157.0.2', '79.140.211.206', '37.157.0.2', '81.133.53.93' );

if ( in_array( $ip_address, $devIPS ) ) {
	if ( !defined('CACHEIT') ) define("CACHEIT", false);
	if ( !defined('SITETITLE') ) define("SITETITLE", 'iRadio');
}
if ( !defined('CACHEIT') ) define("CACHEIT", false);

if ( !defined('SITETITLE') ) define("SITETITLE", 'iRadio');

if ( !defined( "CLOUDFLARE" ) )	define( "CLOUDFLARE", "/" );
if ( !defined( "CLOUDFLARE_EMAIL" ) ) define( "CLOUDFLARE_EMAIL", "matt@hovr.co" );

?>

Open in new window


I have changed password here, basically i am wondering what my next step is? i am uploading it here

http://185.105.4.132/~jonathanduane/
WordPressPHPWeb Services

Avatar of undefined
Last Comment
Kimputer

8/22/2022 - Mon
Kimputer

This is the answer for the Wordpress part (as I don't know which custom CMS you're using). For the most part, you are correct to restore the databases in the new location.

If the URL has changed for the Wordpress portion, you need to adjust it also in the database:
You have to get access to the database (phpmyadmin or similar).
Or edit the downloaded database before uploading it.
In the Wordpress database Options, edit the siteurl entry to reflect the new location.
ASKER CERTIFIED SOLUTION
Kimputer

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes