Can't access to this firewall with public hostname, why?

This is using Cisco ASA 5505 firewall. There are 2 interfaces, one being the WAN, and another is LAN. This firewall is working fine, with the only problem being users in Internal LAN can't access a hosted web server by public hostname. For example, an internal web server having an Private IP 10.24.1.x, with firewall port forwarding aaa.bbb.ccc.15 mapped to www.abc.com. For this web server, user can access www.abc.com from any where via the Internet. However, if user is back to work in office, he/she will find that accessing to www.abc.com is simply not successful. If they access by private IP, then, no problem.

Appreciate if you have can help to solve the "mystery". Please see attached ASA Config file.
EE---cisco-ASA-5505config.txt
LVL 1
MichaelBalackAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

systechadminConsultantCommented:
please make sure that you also have Internal DNS record.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Muhammad BurhanManager I.T.Commented:
please allow port 53 in firewall and then check again
0
Pete LongTechnical ConsultantCommented:
Assuming the users and the web server are both on 10.24.1.x?

You would need to create  a split DNS record on your internal DNS servers for www.abc.com that points to its 10.24.1.x address, This is quite common see

Windows - Setting Up Split DNS

Pete
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Pete LongTechnical ConsultantCommented:
Or depending on the version your firewall is running perform 'DNS doctoring' add the DNS keyword to the NAT statement like so

Post version 8.3

object network obj-Web-Server
host 10.24.1.x
nat (inside,outside) static aaa.bbb.ccc.15  dns
0
MichaelBalackAuthor Commented:
Hi Mohammed and PeteLong,

Thanks for the suggestions and guidance. I will arrange to be onsite to look into the problem.
I'll update you guys about the status.
0
MichaelBalackAuthor Commented:
Hi Mohammed and PeteLong,

Sorry to drag the problem for such long. However, I will be onsite to look into the problem tomorrow morning, will update you guys by then.

Good luck to me.
0
MichaelBalackAuthor Commented:
Thanks expert - Gaurav, use of this method to resolve to its internal IP. It works
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.