Link to home
Start Free TrialLog in
Avatar of nigelbeatson
nigelbeatsonFlag for United Kingdom of Great Britain and Northern Ireland

asked on

hp server raid 1 drive failed

we have a single hp server running sbs2008 which has 2 x seagate 500gb drives configured in a raid 1.

I have removed the defective drive now, but the server still won't boot.

it gets to the Windows progress bar than fails to a blue screen stating :-

a problem has been detected and Windows has been shut down.....,,


STOP: 0x00000024 (0x00000000009044, 0xFFFFFA8007184C70, 0xFFFFFFFFC0000102, 0x00000000000000)

can anyone advise whether it is possible to get this server into a bootable condition whilst we are waiting for the replacement drive to arrive?

many thanks
Avatar of Raheman M. Abdul
Raheman M. Abdul
Flag of United Kingdom of Great Britain and Northern Ireland image

Have you tried to boot into last known good configuration?
tried in safe mode?
Then run chkdsk /r
Avatar of nigelbeatson

ASKER

yes tried both of those options
thanks
I seem to recall from years ago, that there was only one of the pair of drives that was actually bootable, and if it was that one that failed, you had to make a change to some config somewhere to tell it to use the other one.

I was hoping that things had improved since then, but it may not be that, of course. it happens so infrequently, I thought I would ask the experts.😀
Avatar of Kimputer
Kimputer

That stop code usually calls for a
chkdsk /f
or
chkdsk /r (depending on how much time you want to spend on it)
I noticed that the raid 1 was marked as degraded and not marked as bootable.

I marked the raid, although it showed that a member drive was missing, as bootable, and it started up into Windows with a command prompt running wpe init???

I was not expecting this so closed it down.

can anyone throw any light on what this is and why it would invoke this?

many thanks
Windows with a command prompt in WPE environment can happen if a boot loops a few times and Windows decides you need to repair it.
so you think it's ok for me to let it run and complete? I did not want to somehow reconfigure the whole server.

thanks
There's nothing to run and complete. The prompt is probably there waiting for you. In this screen though, you can run the chkdsk /f or /r, so at least the NTFS file system gets repaired.
the command which runs on startup is doing something, it sat there for a few seconds, but I closed the server down, as I did not want to reconfigure the server. as I said, I did not know what it was doing, but if you think it's ok to start the server and let the " wpe init" process complete, I will do so.

if it then starts up to the desktop I can run the chkdsk as suggested.

please confirm
ASKER CERTIFIED SOLUTION
Avatar of Kimputer
Kimputer

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
it just started to run the wpe init process in the command box, but I did not let it complete.

if you are confident it is ok to let it continue to completion I will restart the server, and let it run.

many thanks
ok - I have let the command run ie wpe init, it completed, then it ran hpssbem.exe

but this came back :-

the file or directory is corrupted and unreadable.

I would remind you that this was a mirrored pair and we only now have one of the 2 drives installed.

I cannot run chkdsk /f as it reports that :-

cannot lock current drive.
Windows cannot run disk checking on this volume because it is write protected.

any suggestions on where we go from here?

many thanks
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
hssbem.exe states that :-

the file or directory is corrupt and unreadable

I then just have a command prompt.

if I type chkdsk /f

we get :-

cannot lock the current drive
Windows cannot run disk checking on this volume because it is write protected.

we then just get a command prompt again.

it does not ask if we want to run it at the next reboot??

if we exit the command prompt, the server will reboot, but chkdsk does not run, it just goes back into wme init followed by hpssbem.exe

any ideas

many thanks
The second drive was had also bad sectors on it, and we ended up sending it out for data recovery.

I am not quite sure how to handle this incident, as we did not get a resolution.

I am quite happy allocating points if it is appropriate, but I think I should just close the incident.

If anyone has any problems with that, please let me know.

Many thanks to all who tried to help.
Yes you can allocate points. Most people here tried to get you to do a chkdsk to check the reliability of that disk. And that is a solution, as experts here can't just drive to your house and take the disk to their high tech data recovery lab. We can only advise you, and that advice led you to send it off to a data recovery center.