XenApp 6.5 Hangs on logout "User Profile Service"

I am getting many users every day that cannot logout, and then cannot log back in. They get "The task your are trying to do can't be completed because Remote Desktop Services is currently busy."

When I go to locate the user I find that they are no longer listed under users in the taskmgr, and instead I have to use Citrix AppCenter to find the session ID for that user.  

Users get stuck with the following processes:

csrss.exe
LogonUI.exe
winlogon.exe

I have tried many things to resolve this and nothing seems to be working, we have reverted back to an old group policy, I have tried removing the antivirus, Windows Updates, I have tried this hotfix "https://support.microsoft.com/en-us/kb/2661332" I have followed the instructions here "http://support.citrix.com/article/CTX130116.?_ga=1.221726800.954835743.1441746016" I tried turning off wsearch..  nothing seems to be working.

running XenApp 6.5 with Server 2008 R2, we are not currently using profile manager.

Is anyone familiar with this and maybe have suggestions on troubleshooting the issue?


Thank you for any help and suggestions, this problem is really starting to get hard to deal with.
dgalvin0609Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sekar ChinnakannuStaff EngineerCommented:
Did you installed all the latest windows patches and roll up packs? if not goahead and install the same and check. For details http://support.citrix.com/article/CTX129229
0
Brian CTXSupportCitrix ConsultantCommented:
The sessions are basically hung in a down state.  I've seen this multiple times and it can have varying causes.

First off, what patch level are you running?

Disable the Themes and Desktop Window Manager Session Manager services if you are not using Aero.  This causes problems with some Hotfix Rollup Packs.

Delete stale Group Policy Cache:  https://macgyveritblog.wordpress.com/2014/01/27/recreate-the-local-group-policy-cache-in-windows/

Delete the Citrix policy cache:  http://support.citrix.com/article/CTX134961

I need the patch information to assist further.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dgalvin0609Author Commented:
Sorry to take so long to respond on this, the problem currently seems to have stopped on many servers by modification of the logon/logoff monitoring of our SpectorSoft monitoring software.  I have been trying to see if it is still an ongoing issue, it seems that on many servers it has completely gone away but there are still a few that it remains.  Even on the ones that it remains, they have greatly been reduced as well.

Patch level = xa650w2k8r2x64r06
0
Brian CTXSupportCitrix ConsultantCommented:
Not very familiar with that product, but check to see if it has options to add exclusions.  You'd probably want to add exclusions similar to the ones you would add for anti-virus.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.