Moving Exch2010 to new hardware

I have 2 exchange servers 2010 on a DAG. Second exchange server is in remote location but on same site in AD. Primary site A has all mailboxes replicated to site B. Site A exchange CAS role got corrupted with SP3 install so rolled back to sp2. Now all clients go to site B for CAS. 100MB connection between site A & B. So I created new exch2010 in site A  with all patches and SP3. I like to move all mailbox and decommission the old exch2010 in site A.

Summery:
Site A old exch2010 with SP2 (needs to be decommissioned, CAS not working )
Site A new exch2010 with sp3
Site B old exch2010 with sp2

Can someone can give me step by step instructions to move mailboxes, updated mx records, update CAS array roles etc.??
Also should make this new exch server a part of DAG and replicate first?? what should be the best course of action.
numanmalikAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ET SupportCommented:
The good practice would be setup the Site B databases copy as "primary" and stop the DAG and CAS array . users should remain communicate to the Site B server CAS with auto discover function and mailbox access also should be there as Site B server has already a full replica of Databases. you need to update the DNS entry for cas array address and autodiscover to Site B server during this time

Proceed with Site A old exchange decommission and then configure new CAS array and DAG with new Site A exchange server and Active Site B server.
0
AmitIT ArchitectCommented:
How you rolled back to SP2. As it is not possible to roll back to SP2, once you SP3 setup updated your Schema. Either SP3 never installed on both server. Secondly, now you install new server with SP3. You option left is to upgrade all server to SP3 first and then plan the decom. Better you reinstall crash server with recover swtich. Review my article.


http://www.experts-exchange.com/articles/18110/How-To-Recover-Failed-Mailbox-Sever-In-Exchange-2010-DAG-Environment.html
0
numanmalikAuthor Commented:
Amit,
I'm new to this environment. Previous efforts were done to install SP3 on Exch2010 on site A but server crashed. They brought back the server and now has SP2 (don't know what steps were taken). Schema was updated and it has now a new Exch2010 with SP3.
I do want to take the risk to install SP3 on the old exch2010 again. too risky. I like to take all the roles away from that server and decommission it.

Question : 1- Do I have to install sp3 on old Exch2010 in site A and then decommission it?
2- As ET support mention to make Exch2010 with SP2 in site B as primary, remove old Exch 2010 in Site A from DAG and decommission then create new DAG with new exch2010 with SP3.
or
Move all mail boxes from old exch2010 to new exch2010 in site A. decommission old one after removing from DAG and create a new DAG site A & B.

Below info are confirmed
Site A old exch2010 with SP2 (needs to be decommissioned, ) DAG
Site A new exch2010 with sp3
Site B old exch2010 with sp2 DAG
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

ET SupportCommented:
Move mailbox option ( from old exch 2010 in site A to new ) involves more human actions as you have to schedule the migrations if the number of mailboxes high may take time. Also during the migration the migrating users wont be able to access mails.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
numanmalikAuthor Commented:
I agree but exch2010 in site B has SP2. Should I install SP3 before I make that as primary?
0
ET SupportCommented:
Yes, you can. There is no problem with DAG when running different versions of exchange 2010
0
AmitIT ArchitectCommented:
In current situation you cannot recover old server. As it need same service pack to recover and in your case you already upgraded schema to SP3 and Exchange won't allow you to use SP2.

Best you move mailbox to new server. There is no downtime involved in mailbox move. User won't notice anything when you are doing mailbox move. However, you need to keep eye on log generation on your server, so you don't face out of disk space issues. Do in batches.
0
ET SupportCommented:
I would like to give a clarity on SP2 and SP3  schema..

If your all exchange servers are running in SP2 but schema is already updated SP3 version by an incomplete or orphaned installs, you can still install Service pack 2 in the environment. Only thing you need to manually edit the schema version number in ADSI

CN=ms-Exch-Schema-Version-Pt
0
numanmalikAuthor Commented:
Guys I'm getting 2 different opinions and I agree on both but I like to make it safer with no downtime. I like the idea to move into new exch 2010 server which already has SP3 and then follow the rest. but switching roles to site B as primary looks much easier but then ultimately I have to install sp3 on it

Can we agree on one solution??
0
AmitIT ArchitectCommented:
I would suggest you to open up a case with Microsoft.
1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.