RDP display size

I am using Windows 7 Professional.  When I use the Remote Desktop Client, I am able to Maximize the session to full screen.  Under The RDP Options I have it set to:
Full Screen (large) and High Color (16 bit).
However, randomly when I start a new RDP session it will stop allowing me to maximize to full screen.
I can't seem to figure out what is the cause but it is happening on and off for a long time.  Please let me know if you have any ideas on what might be causing this.  Thanks.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Hard to say (because the error has been going on for a long time through all kinds of updates).

Try running System File Checker. Open cmd.exe with Run as Administrator and run SFC /SCANNOW twice. Close out, shut down (power off), start up and test.

If SFC does not work, you may to run a Repair Install. You need the Windows 7 DVD to do this.
fjkaykr11Author Commented:
John,  thanks for the info. So this is a known issue and not a setting that might be causing.   I don't have the ability to reinstall the OS so guess I will just live with it.   I know another known issue that Microsoft wasn't able to help me resolve was the RDP clipboard would randomly stop working (fortunately I don't use feature very much anymore).
This is indeed a known issue on computers with a screen resolution of 1366 x 768.

You could try to force it to full screen by using the following RDP shortcut: Ctrl + Alt + Break

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fjkaykr11Author Commented:
I haven't noticed int he past few days so I haven't had chance to try the suggested solution but given it is a known issue I would like to close the question.  Thanks for the assistance.
JohnBusiness Consultant (Owner)Commented:
You are very welcome and I was happy to assist.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.