Unable to modify Autodiscover URI for an Exchange 2010 CAS

Below shows the output from my powershell session that was started via the Exchange Management Shell shortcut.

[PS] C:\Windows\system32>Get-ClientAccessServer

Name
----
CCSEMAIL2010

[PS] C:\Windows\system32>Get-ClientAccessServer -Identity CCSEMAIL2010

Name
----
CCSEMAIL2010

[PS] C:\Windows\system32>Set-ClientAccessServer -Identity CCSEMAIL2010 -AutoDiscoverServiceInternalUri "https://autodiscover.local.company.net/Autodiscover/Autodiscover.xml"
You must provide a value for this property.
    + CategoryInfo          : NotSpecified: (0:Int32) [Set-ClientAccessServer], DataValidationException
    + FullyQualifiedErrorId : 14B3A3C,Microsoft.Exchange.Management.SystemConfigurationTasks.SetClientAccessServer
    + PSComputerName        : ccsemail2010.local.company.net

[PS] C:\Windows\system32>

Open in new window


Per the TechNet article: https://technet.microsoft.com/en-us/library/bb125157%28v=exchg.141%29.aspx
The Set-ClientAccessServer cmdlet only requires one paramater to be set, that is the -Identity paramater. I don't understand what is "NotSpecified" and why there is a
reference to an Int32.
DonovanVAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MAS (MVE)EE Solution GuideCommented:
Set-ClientAccessServer -Identity CCSEMAIL2010 -AutoDiscoverServiceInternalUri "https://autodiscover.local.company.net/Autodiscover/Autodiscover.xml"

Why  .local.company.net?
Is your domain .local.domain.net?
Normally it sets to your external domain name. i.e "https://mail.emaildomain.com/Autodiscover/Autodiscover.xml"

Please try this
Set-ClientAccessServer -Identity CCSEMAIL2010 -AutoDiscoverServiceInternalUri "https://autodiscover.email.net/Autodiscover/Autodiscover.xml"
0
DonovanVAuthor Commented:
I have no externally accessible services nor do I have any servers that reside off-site. I'm not sure why setting the Uri to anything but a local destination would be appropriate.
0
Jeff GloverSr. Systems AdministratorCommented:
You can try putting the CAS server name in quotes. Sometimes will do the trick
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

DonovanVAuthor Commented:
I so wish this was that easy Ivjeff. Unfortunately, no luck doing that either. I get the exact same error with or without quotes. As a side note, all other cmdlets that can affect the server fail with the same error. I can't seem to affect the server at all via powershell.
0
Jeff GloverSr. Systems AdministratorCommented:
You may have to uninstall and reinstall the CAS role. Do you have separate CAS, HT and MBX servers? If so, can you run cmdlets that affect the mailbox servers or databases without error?
0
DonovanVAuthor Commented:
I went as far as spinning up an entirely new VM. I started from scratch and have ended up with the exact same result. Any powershell cmdlets that i use to issue changes to either server fail with the same error message.

To give a bit more info on the environment, we have a 2003 native functional level domain with a single exchange 2003 server. Exchange 2010 is being brought into the mix to perform a migration to the eventual end point of Exchange 2013. Also, if it matters the domain controller that holds the FSMO rolls is also run on the 2003 server, though there are two other DCs in the mix running on server 2012R2. The Exchange 2010 server is running on Server 2012 as R2 is not supported.
0
Jeff GloverSr. Systems AdministratorCommented:
It is a long shot but have you tried a remote powershell session from your desktop?
0
DonovanVAuthor Commented:
Sigh... nope. Still this
You must provide a value for this property. Property Name: HostServer
    + CategoryInfo          : NotSpecified: (0:Int32) [Set-ClientAccessServer], DataValidationException
    + FullyQualifiedErrorId : A8590CD4,Microsoft.Exchange.Management.SystemConfigurationTasks.SetClientAccessServer
    + PSComputerName        : ccsemail2010v2.cnet2k.cornerstonecredit.net

Open in new window

0
Jeff GloverSr. Systems AdministratorCommented:
You extended the schema for Exchange 2010, correct?
0
DonovanVAuthor Commented:
Correct. Via the Exchange 2010 installation files i performed


setup.com /PrepareSchema
setup.com /prepared

To prep the schema and AD for the inclusion of the exchange 2010 server
0
DonovanVAuthor Commented:
Not sure how interesting this is but I'm grasping at straws right now. I found a post online that talked about using ADSIEdit to clean up corruption in Active Directory. I used a couple of tools to do some research and here is what I've found.

ADSIEdit shows an odd number of mailboxes
tQ9a4us-1-.png
Listing the mailboxes via powershell shows this
rVC9wch-1-.png
I also verified that against the Exchange Management Console
ctGwYmh-1-.pngY3owpUV-1-.png
I then went back to ADSIEdit just to make sure
7nAfbnR-1-.png4eBGoGn-1-.png
That looks to me like two databases that say they are associated with the same server as far as AD is concerned but all other tools report only one.
0
DonovanVAuthor Commented:
I'm glad to report I've solved the issue. The root cause did in fact end up being the corruption in AD. After identifying the corrupt mailbox database record from my previous post I decided to remove it. I first removed the node inside the folder for the corrupt record then the container its self. After doing that, all set commands issued from Powershell now work as expected.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DonovanVAuthor Commented:
The root cause of the original error was a corrupt mailbox database record in AD.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Powershell

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.