windows 8.1 client and Hyper V 2012 R2

Dear Experts,

I have windows 8.1 laptop and added the MMC snap-in for Hyper V. This laptop is added to a domain related to my work from before. I have a HyperV 2012 R2 which I installed on server but I want to keep it in a workgroup only. I created an account on it for remote management and it is enabled. But I am not sure from the client how to access it . I am having issue running it with the account I have provided.

Please help as I was in windows 7 I went all the way upgrading my windows just to remote to this hyper v 2012 server.

Thanks,
LVL 4
Habib ZakariaNetwork Solutions ArchitectAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Muhammad BurhanManager I.T.Commented:
on Server
ensure Winrm service is running.

   on Client
1.servername and IP entry in 'c:\Windows\System32\drivers\etc\hosts' file.

2.Administrative Tools > Components Services > computers > right click on MyComputer > properties
Allow Anonymous Logon for Remote.

3.add windows credentials of the server.

4.Powershell cmd
      Set-Item WSman:\Localhost\Client\TrustedHosts -Value <Servername>
      winrm get winrm/config/client
 it must shows TrustedHosts = <Servername>

5.winrm qc
      hit y and enter, if it is not configured.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
John Howard's HVRemote. Download, follow the instructions for Domain RSAT/Hyper-V Workgroup.

It works and it's simple.
0
Habib ZakariaNetwork Solutions ArchitectAuthor Commented:
ok so here is a simple solution.

Created a user account under local users and groups --> I added it as a member of the administrator on my client laptop. The username is the same username and password I defined in the hyper-v and I ran the hyper v manager by doing runas and I used the username and password.

It connected just fine. I do not have to enable or check things additionally on the host.

Thanks,
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
An alternate to that is to run your user account as Standard User so that Run As Admin prompts for credentials. Or, force UAC into credentials mode instead of the Continue button (this is a good practice for local admin users).
0
Habib ZakariaNetwork Solutions ArchitectAuthor Commented:
My solution worked and simple
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hyper-V

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.