Visual Studio Higher to Lower Version Converter

I downloaded the latest version of source code and I am trying to compile the code On Visual Studio 2010 I get an error when I open the project (sln) in explorer."The selected file is a solution file, but was created by a newer version of this applciation and cannot be opened"
How to  compile the code from higher version to lower version  ?
prashanth agsoftware engineer Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ryan ChongCommented:
quick fix... create a new project in VS2010 and import your codes accordingly?
1
Ryan ChongCommented:
you may refer to this article for more info:

Create New Project From Existing Code Files Wizard
https://msdn.microsoft.com/en-us/library/1yy56kkd(v=vs.90).aspx
0
MlandaTCommented:
Just take note also of differences in target framework etc. VS2010 will only target up to NET 3.5

If your project is simple enough, you can try these options as well:

Visual Studio Project Converter: https://vsprojectconverter.codeplex.com/ - convert Visual Studio solution and project files from one version to another (both backwards and forwards)
Visual Studio Higher to Lower Version Converter: http://www.ajaymatharu.com/visual-studio-higher-to-lower-version-converter/
SolutionConverter: http://www.codeproject.com/Articles/80001/SolutionConverter
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

it_saigeDeveloperCommented:
@MlandaT - Actually VS2010 can target up to .NET 4.0.3.Capture.JPGSource

-saige-
1
MlandaTCommented:
Thanks for that correction. Was just blurting from my head and didnt cross check!
0
Jacques Bourgeois (James Burger)PresidentCommented:
Or simply upgrade your version of Visual Studio.

Visual Studio 2015 Community Edition is the equivalent of the Professional Edition and is free if you work for a company that has 5 programmers or less, and does not make more than $1 million a year. It will accept and create solutions for any version of the framework, as long as you have that version already installed.
1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic Classic

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.