Unable to connect to new Server 2012 R2 RDS deployment

I have a new RDS deployment on a Server 2012 R2 VM. I think I am getting close but I can't quite get it to work yet.
If I try to connect by server name, using Remote Desktop Connection on a Windows 7 Pro system, I get a logon prompt (so it must be able to at least find the remote server), but when I put in username and password I get this error:

"This computer can't connect to the remote computer.
Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator. "

Any thoughts?????
gregmiller4itAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rakesh KapoorCommented:
Please ensure that you have access to the server that you are trying to remote login. Add your user in the Remote Desktop Users groups.
Muhammad BurhanManager I.T.Commented:
try with administrator credentials, seems it not allowing you to access remotely
Luis MouraCommented:
You need to check if this user have access to RDP on this machine.
And allow RDP to this machine.
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

gregmiller4itAuthor Commented:
I am trying to log in with a Domain Admin user account.
When I go to the remote server> system properties > Remote > Select Users...it shows that the account I have been trying already has access (this is the one I use to log into the server locally as well). I have also added 'Domain users' to the Remote Desktop Users list.

I have set up Remote Desktop connections into lots of other systems previously and I am reasonably familiar with the process and I can usually sort it out when there are problems. But I have never set up an RDS server before and I am not sure where to look for this problem.

I don't think it can be a port or firewall problem because I am getting the log on box; so it must be able to see the RDS server remotely. But it won't let me log on and then I get a message as though it can't see it after all.

I can't follow the logic and I can't get past this problem.
Cliff GaliherCommented:
Sounds like a simple firewall issue. Are you using any 3rd party security software? To configure windows built-in firewall, don't try to do it manually. There is a simple task in Server Manager that enables remote desktop access and configures the firewall all at once. Use that task.
gregmiller4itAuthor Commented:
Thanks Cliff, but I think the problem must still lie somewhere else. I am using Windows Firewall on the server and Sophos Endpoint Protection on the workstation. I disabled the Firewall on both systems to test it and the problem did not change.
I also couldn't find the task in Server Manager that you mentioned.
Any ohter ideas?
Cheers,
Greg
Cliff GaliherCommented:
If you couldn't find the task then you likely didn't enable it.  It looks like this:  the status (enabled/disabled) is clickable.
Capture.PNG
gregmiller4itAuthor Commented:
Oh ok, I was looking in the RDS section in Server Manager. I have found what you are talking about and it is definitely showing 'Enabled'.....so still no further on m y quest to get this going.
Cliff GaliherCommented:
What client OS are you using to connect, and how did you set up your RDS deployment?
gregmiller4itAuthor Commented:
The PC I am using to connect is running Windows 7 Pro 64-bit and here is a link to the step-by-step instructions that I followed:
https://msfreaks.wordpress.com/2013/12/09/windows-2012-r2-remote-desktop-services-part-1/
I came unstuck when trying to configure for High Availability, but it was pointed out that since I only had a single RDS server I didn't need HA anyway.
I have a single physical server computer running Server 2012 R2 as a Hyper-V host with several VMs also running Server 2012 R2. I have a separate VM for RDS which holds all the associated RDS roles except Licencing which I put I the VM that is the DC (and the DC does nothing else).
When I look at RDS in Server Manager on the RDS VM the graphic is all grey (no green bits) which implies that I have done all the steps.
The other thing that might be worth noting is that the only thing that occurs in the Windows Event Logs at the time of attempted RDC logon, is in the Security Log. There is a 4624 Logon followed immediately by a 4634 Logoff.
So the Remote Desktop Connection is being made but immediately dropped.
Cheers,
Greg
Cliff GaliherCommented:
With NLA, authentication occurs before the RDP channel is set up. This was done to significantly improve security. So seeing anlogoj box or logon events doesn't mean RDP is working. This still smells like a firewall/port blocking issue. But at this point, there isn't much more remote troubleshooting advice I can give.
gregmiller4itAuthor Commented:
Well I just made an interesting discovery: I can connect via RDC from a Windows XP client. I have tried two different PCs with Windows 7 Pro (RDP V7.1 & V8.1) and both logon and then disconnect immediately.
The Windows XP client (RDP V6.1) works properly.
I think this would rule out the firewall issue.
I must be getting closer but I am still in the dark.
Any more ideas anyone?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gregmiller4itAuthor Commented:
Cliff's final post which explained that with NLA, authentication occurs before the RDP channel is setup, led me to try an XP (non-NLA) client which worked.
So it turns out that RDP is actually working, just not with NLA. This changes the premise of the initial question. I am giving some points to Cliff and will close this question and start a new one with the revised details of the problem.
Cheers,
Greg
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.