Unable to send any e-mails to one specific Domain, able to receive ok.

Suddenly our customer who uses Exchange Server 2010 cannot send any e-mails to any e-mail address on the www.templegate-electrical.co.uk Domain.

 I have tried from Outlook Client Software and also Outlook Web Access, but the result is always the same:-

 #550 5.1.1 RESOLVER.ADR.RecipNotFound; not found ##

 The e-mail bounces back immediately on the Client PC with a notification of:-

 The email address that you entered couldn't be found. Check the address and try resending the message. If the problem continues, please contact your helpdesk

 I have flushed the NK2 cache which has had no effect, and rebooted the Server and Client PC. Ensured it is not part of a Spam Block List etc.

 However I can e-mail this Domain with no problems at all using sales@templegate-electrical.co.uk.

I have run the Microsoft Remote Connectivity Analyser from the Server using the SMTP Outbound test and all is ok, except the final step which returns:-

Attempting to find the SPF record using a DNS TEXT record query.
  The Microsoft Connectivity Analyzer wasn't able to find the SPF record.
   Additional Details
  No records were found.
Elapsed Time: 125 ms.  
 
Does anyone know what can suddenly have gone wrong?

Thanks Steve
SCFudgellAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Paul MacDonaldDirector, Information SystemsCommented:
"RecipNotFound" means the e-mail address you're sending to is not valid.  This has nothing to do with being able to find the recipient's mail server.

Check the e-mail address and try again.
SCFudgellAuthor Commented:
That was my first reaction as well. I have checked and double checked the e-mail addresses and forced them to e-enter them afresh and cleared the NK2 data cache as well. But even using the sales@templegate-electrical.co.uk returns the same error.

Yet I am able to send quite happily to that e-mail address from our domain.

I know that's not the issue.
arnoldCommented:
Do you have access to the exchange server? Check what it resolves for nslookup -q=MX domainname
Check whether they have a special/transport rules for this domain that are no longer valid I.e. Pointing to the wrong location where that domain was served by before but no longer.
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

Paul MacDonaldDirector, Information SystemsCommented:
For sure this is a server-side issue, but there may be a client-side aspect.  It may be that the mailbox(es) in question is/were moved at some point.  If so, this could be the issue:

"If the Senders have sent previously sent to that address they probably have the old recipients X.400 in their address book y so you would have to clear them out and select again."

Beyond that, the server may have a rule established to block mail from your customer to that domain (whether or not it's intentional).
SCFudgellAuthor Commented:
Arnold, I do have access to the Exchange Server and ran an nslookup -q=MX www.templegate-electrical.co.uk 

I have attached the result.
Derek-Clark-Server-NS-Lookup.jpg
SCFudgellAuthor Commented:
Paul, thanks for you suggestions.

This isn't unique to any user, it applies to all users trying to contact any e-mail @templegate-electrical.co.uk, as such I do not think it's an issue with a specific Client.

but can you be more explicit? What type of rule?
arnoldCommented:
Remove the www from the query and compare the response to the logs to which your exchange is connecting to deliver messages for these recipients.
Www.domain.com us not the correct one to use.
SCFudgellAuthor Commented:
Arnold, I have re-run the nslookup as you suggested -q=MX templegate-electrical.co.uk

 I have attached the result.

I also decided to try to establish a Telnet connection, and tried Telnet mail.templegate-electical.co.uk 25

Unfortunately it says connection failed although I can connect happily to my own Exchange Server
Derek-Clark-Server-NS-Lookup-Revised.jpg
arnoldCommented:
I do not know where you are getting this information from, but according to public records, the domain does not exist except if one nic.uk root server is queried.

It looks like the domain is now fixed.  All UK Root servers reflect this information so you should not have issues going forward.

Usually, you have to look through the exchange server's logs to see where it is trying to connect to or what the error it returns is: i.e. no such domain means it can not locate the server responsible for this recipient domain. No such user, is rejected on the receiver side.


I think your example is more that your server could not locate the MX records for this domain.
SCFudgellAuthor Commented:
Hi Arnold,

What information are you referring to?

I still have the same problem, it is not possible to send any e-mails to this one specific Domain.

How can I make sure the Server is able to locate the MX record for this Domain?
arnoldCommented:
The response for domain name/service record lookups are inconsistent from the UK NIC root servers.
Nslookup -q=Ns co.uk.

Whose mail server do your email clients use to send out emails?

There are six or eight listed uk nic root server. When you send an email, the server looks up information and could hit one that at the time responds with no such domain.
If you have your own mail server, but you are forwarding all outgoing emails to your ISP, try without forwarding to see if you get a different less frequent issue with this domain..
Use mxtoolbox.com to make sure your MX/IP is not suseptible to being rejected I.e. Has matching forward/reverse name/ip resolution/settings...........
SCFudgellAuthor Commented:
Arnold,

Thank you for the information but I am confused.

I noticed that NSLookup returns unknown server and is using the IPV6 address, is this the root of the problem?
arnoldCommented:
unknown error means it can not resolve your servers IPv6 IP to a name.


possibly, though if it was an issue with your server, the impact would have been affected all your outgoing emails.

Here is the list of root servers responsible for co.uk suffix.

co.uk.                  172800  IN      NS      nsc.nic.uk.
co.uk.                  172800  IN      NS      dns2.nic.uk.
co.uk.                  172800  IN      NS      nsd.nic.uk.
co.uk.                  172800  IN      NS      dns1.nic.uk.
co.uk.                  172800  IN      NS      nsa.nic.uk.
co.uk.                  172800  IN      NS      dns4.nic.uk.
co.uk.                  172800  IN      NS      nsb.nic.uk.
co.uk.                  172800  IN      NS      dns3.nic.uk.

;; ADDITIONAL SECTION:
nsa.nic.uk.             172800  IN      A       156.154.100.3
nsa.nic.uk.             172800  IN      AAAA    2001:502:ad09::3
nsb.nic.uk.             172800  IN      A       156.154.101.3
nsc.nic.uk.             172800  IN      A       156.154.102.3
nsd.nic.uk.             172800  IN      A       156.154.103.3
dns1.nic.uk.            172800  IN      A       213.248.216.1
dns1.nic.uk.            172800  IN      AAAA    2a01:618:400::1
dns2.nic.uk.            172800  IN      A       103.49.80.1
dns2.nic.uk.            172800  IN      AAAA    2401:fd80:400::1
dns3.nic.uk.            172800  IN      A       213.248.220.1
dns3.nic.uk.            172800  IN      AAAA    2a01:618:404::1
dns4.nic.uk.            172800  IN      A       43.230.48.1
dns4.nic.uk.            172800  IN      AAAA    2401:fd80:404::1

nslookup -q=mx domain.co.uk. <name server/IP from the list>

You will see that some have information and others don't it seems they are currently out of sync. SOA Serial number is not the same. They may have two separate systems updating two separate sets of servers.
SCFudgellAuthor Commented:
Unfortunately, I didn't find a resolution here.

However, I noticed that the Client PC that was attempting to send the e-mail, had a vary large .PST and .OST file. Decided to delete it and rebuild it from scratch, letting it update from the Exchange Server rather than importing the old .PST.

Once completed it was able to send to the www.templegate-electrical.co.uk Domain ok again.

I assume it was putting some condition back to the Server.

Hopefully that may be useful knowledge for someone else.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.