Tablets, iPhones, and Androids wont connect to a Cisco Phone Server (10/5)

We used to have an 8.6 Cisco server (physical) and recently upgraded to 10.5 (virtualized). The new server is clustered with a publisher and subscriber.  They have self signed certs at this point and do not have DNS implemented. Configuration is through manual setup.

The old servers worked with Jabber on a variety of devices. While new devices WILL connect to the CUPS server and do IM / Presence, I cannot for love or money get it to connect and provide phone services or voicemail.  

When I attempt to use the reconnect option it tells me

Failed to get device configuration

I tried a mix of the Expressway install and config guide, combined with looking at the old phone server (which I still have, albeit isolated from production) to recreate the device profiles. Id love a simple how to guide on how to make Jabber work on mobile clients WITHOUT Expressway (though I will EVENTUALLY implement that too)

So, is there any reason that I couldnt make mobile devices on the local network (via wifi) connect to the phone server with their Jabber client?

If it should work, does anyone have a good step by step reference, preferably for 10.5

Lastly, anyone got any obvious "have you checked X" ideas?
LVL 1
Eric_PriceAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Eric_PriceAuthor Commented:
#1 - No. Mobile devices on the wifi will have no problem connecting to a properly configured Cisco phone server implementation.

#2 - I never found one. Its all a hodge podge of the old 8.6 docs and the new expressway docs. The good news is, once youre familiar with the overall config the 8.6 docs will pretty much work

#3 - My ultimate problem was that I failed to add a line association to the device after I created it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Telecommunications

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.