Shadowing in Terminal Server 2008 R2 not working

I'm never used shadowing in terminal services and was reading about how to use it.  I've remoted into my terminal server as the admin, launched Remote Desktop Services Manager, right clicked on the user I want to shadow and selected remote control.  When I do that, i get a window asking me to choose the disconnect keystrokes.  I click OK and nothing happens.  

Am I missing something?  I would expect a window to popup allowing me to see the user's terminal session.

Thanks very much
SupermanTBAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zalazarCommented:
Could you logon to the server and open a registry editor via Start |Run |regedit
and check the following parameters:
Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp
Parameter: Shadow
Could you verify that it's set to 1.

There is also
Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\Console
Parameter: Shadow
This should also be set to 1.

Then please open "Remote Desktop Session Host Configuration" from the Start Menu
Get the properties of "RDP-Tcp" and click the tab Remote Control
Set this to Use remote control with the following settings and define e.g. Require users' permissions and interact with this session.

You also need administrator permission on the RDP-Tcp configuration but as you are an Administrator this is probably already ok.
You could check this also via "Remote Desktop Session Host Configuration"
Get the properties of "RDP-Tcp" and click the tab security.
The Administrators group should have Full Control.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SupermanTBAuthor Commented:
I made the following two changes

1.  The domain administrators group was not granted permissions on the RDP-Tcp Configuration.  So I granted those permissions
2.  I made the changes you recommended  in this paragraph:

Then please open "Remote Desktop Session Host Configuration" from the Start Menu
Get the properties of "RDP-Tcp" and click the tab Remote Control
Set this to Use remote control with the following settings and define e.g. Require users' permissions and interact with this session.

I believe it was the permissions issue that fixed.  Thanks!
zalazarCommented:
You're welcome and thanks too.
Very good to hear that the issue is fixed.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.