how to reset administrator's password for Axway securetransport product.

I have a axway securetransport product installed on my linux machine. I don't have the administrator's password in record. Is there a way I can reset it.

I was able to stop the service and start the service without problem.

thanks.
Jason YuAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gheistCommented:
mkadmin adds new admin user to system that you can use to manage rest.
0
Jason YuAuthor Commented:
you mean add a new operation system user?
0
gheistCommented:
no. add new application admin.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Jason YuAuthor Commented:
I don't have any account to log into the software administrative interface, how could I do it?
0
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Default username/password is setup/setup
If you are still having issues then contact Axway
0
gheistCommented:
"mkadmin" linux command is included in axway software package.
you just run it, it shows help text on how to create new web admin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jason YuAuthor Commented:
Hi, gheist:

Thanks for your help, I found the command and reset the admin's password but it still says the password error. Then I created a new account, but i couldn't use the new account to log in. Do I need restart the securetransfer service?


[root@sft ~]# which mkadmin
/usr/bin/which: no mkadmin in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
[root@sft ~]# locate mkadmin
/usr/local/SecureTransport/bin/mkadmin
[root@sft ~]# /usr/local/SecureTransport/bin/mkadmin
mkadmin: Enter administrator account name: [admin]
mkadmin: Enter administrator password:
mkadmin: Retype administrator password:
mkadmin: Passwords do not match.
mkadmin: Enter administrator password:
mkadmin: Retype administrator password:
mkadmin: Administrator "admin" successfully updated.

[root@sft ~]# /usr/local/SecureTransport/bin/mkadmin
mkadmin: Enter administrator account name: [admin] jasony
mkadmin: Choose administrative role:
    1) Master Administrator
    2) Setup Administrator
    3) Account Manager
    4) Application Manager
    5) Delegated Administrator
    6) Database Administrator
1
mkadmin: Create administrator 'jasony' with role 'Master Administrator'? [y]y
mkadmin: Enter administrator password:
mkadmin: Retype administrator password:
mkadmin: Administrator "jasony" successfully created.

[root@sft ~]#
0
Jason YuAuthor Commented:
Please see the error showed in the attachment. thanks.
error.PNG
0
gheistCommented:
Make a new user
yes, restart
if it does not work ask axway why...
0
Jason YuAuthor Commented:
what is the administration port number?

I tried port 444 but it doesn't open any webpage, however on my test server, I was able to open a webpage, please advise.
0
Jason YuAuthor Commented:
Hi, Gheist:

Thanks for your last post, it helped me resolve the issue on my test instance. After I created a new administrator account, I was able to log in from the xxx.xxx.com:444 interface.

However, on my production server, I couldn't open the administrator's logon page which has the same port number, how could I troubleshooting this error,

thanks.
444-port-error.PNG
0
gheistCommented:
No idea, nor related to adding new axway admin.
0
Jason YuAuthor Commented:
This has been resolved by restart the admin script and reset the password, thanks for help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.