Unable to install updates from WSUS with Windows 8.1

I have WSUS 3.2.7600.256 running on Windows 2008R2. All of my Windows 7 computers are able to see, download and install updates from the WSUS server.

On Windows 8 I am getting "Some settings are managed by your system administrator."
maemckayIS ManagerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Thomas GrassiSystems AdministratorCommented:
Are you using the WSUS GPO Policy

Is this a domain?
maemckayIS ManagerAuthor Commented:
Hi Thomas,

Yes, we are using the WSUS GPO Policy and it is a domain.
ChrisSenior Technical ArchitectCommented:
What do you have in the windows update log? C:\windows\windowsupdate.log
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Thomas GrassiSystems AdministratorCommented:
maemckay

That is the normal settings you will see

the WSUs GPO applies the settings  

check these reg settings

req query hklm\software\policies\Microsoft\windows\windowsupdate

post results
David Johnson, CD, MVPOwnerCommented:
have you tried checking for updates
ncomperCommented:
Have you reviewed the updates on WSUS and selected updates for Windows 8 machines alongside the already allowed? if so have you synchronized and then approved the additional Win8 updates for deployment to the client machines
windows-itCommented:
In order to successfully deploy updates from a Windows Server 2008R2 to Windows8 clients you need to install the following update:
https://support.microsoft.com/en-us/kb/2734608 

After that, delete the Windows 8 clients on the WSUS and run the following command on the client:

wuauclt /resetauthorization /detectnow

Have you done that allready?
maemckayIS ManagerAuthor Commented:
irweazelwallis, here is what is in windowsupdate.log.
2015-10-02      09:18:50:684      1700      1918      AU      User login event timer expired for session id: -1.
2015-10-02      09:18:50:704      1700      1918      AU      #############
2015-10-02      09:18:50:704      1700      1918      AU      ## START ##  AU: Install updates
2015-10-02      09:18:50:704      1700      1918      AU      #########
2015-10-02      09:18:50:704      1700      1918      AU        # Initiating scheduled install
2015-10-02      09:18:50:706      1700      1918      AU      WARNING: There are no approved updates to install
2015-10-02      09:18:50:706      1700      1918      AU        # Exit code = 0x8024000C
2015-10-02      09:18:50:706      1700      1918      AU      #########
2015-10-02      09:18:50:706      1700      1918      AU      ##  END  ##  AU: Install updates
2015-10-02      09:18:50:706      1700      1918      AU      #############
2015-10-02      09:19:46:617      1700      354      AU      Windows Update is disabled by policy for user
2015-10-02      09:20:40:895      1700      354      IdleTmr      Decremented idle timer priority operation counter to 0

Thomas Grassi, no with Win7 I can see all at the updates that are approved and select which ones to install.
Here are the results from reg query hklm\software\policies\Microsoft\windows\windowsupdate

HKEY_LOCAL_MACHINE\software\policies\Microsoft\windows\windowsupdate
    WUServer    REG_SZ    http://wsus
    WUStatusServer    REG_SZ    http://wsus
    DisableOSUpgrade    REG_DWORD    0x0

HKEY_LOCAL_MACHINE\software\policies\Microsoft\windows\windowsupdate\AU

David Johnson, yes I have tried. When I click Check for updates, I get the error "Windows Update canot check for updates because settings on this PC are controlled by your system administrator".

ncomper, yes I have allowed Windows 8.1 updates to sync and have approved all available updates.

windows-it, no I had not done that update yet. I ran the update on the server, I deleted the client, ran wuauclt /resetauthorization /detectnow on the client. When I check WSUS for the client it is not showing up.
ncomperCommented:
When i last added new Windows10 clients they took some time to populate in the WSUS server. you may just need to allow the registration to take its course.
maemckayIS ManagerAuthor Commented:
ncomper, it has been a couple of hours and the Windows 8.1 client has not shown up.
David Johnson, CD, MVPOwnerCommented:
If you can, go to Run > key in gpedit.msc and review the following paths to ensure non administrators have access to windows updates
Computer Configuration\Administrative Templates\Windows Components\Windows Update
User Configuration\Administrative Templates\Windows Components\Windows Update
Thomas GrassiSystems AdministratorCommented:
Here are the results from reg query hklm\software\policies\Microsoft\windows\windowsupdate

HKEY_LOCAL_MACHINE\software\policies\Microsoft\windows\windowsupdate
     WUServer    REG_SZ    http://wsus
     WUStatusServer    REG_SZ    http://wsus
     DisableOSUpgrade    REG_DWORD    0x0

 HKEY_LOCAL_MACHINE\software\policies\Microsoft\windows\windowsupdate\AU


what port you using for wsus I see no port listed in your reg listing

Run same command on a computer that is working to compare

HTH
maemckayIS ManagerAuthor Commented:
David, all of the users are local admins.

Thomas, we are using port 80. I ran the script on a working Windows 7 computer and it is the same.
maemckayIS ManagerAuthor Commented:
I resolved the issue by changing Remove access to use all Windows Update features from Enabled to Disabled.

The setting was under User Configuration\Policies\Administrative Templates\Windows Components\Windows Update.

While this setting did not interfere with Windows 7, it did have an issue with Windows 8.

Help note on the policy, "On Windows 8 and Windows RT, if this policy is Enabled, then only notifications related to restarts and the inability to detect updates will be shown. The notification options are not supported. Notifications on the login screen will always show up."

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Thomas GrassiSystems AdministratorCommented:
I hope my pointing the gpo to you helped you figure this out
maemckayIS ManagerAuthor Commented:
Continuing to trouble shoot the issue lead me to figure it out in the end.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Peripherals

From novice to tech pro — start learning today.