Outlook default program (Microsoft exchange administrator has blocked you version of outlook)

I have a new 2012 terminal server installed with Office 365 minus Outlook 2013. Outlook 2010 is installed due to the absence of Outlook 2013. The system is running well and Outlook clients connect to their legacy Exchange server OK and all is functional. However a Legacy application launched on the Terminal Server also uses email as defined by Outlook. The application complains saying Microsoft exchange administrator has blocked you version of outlook. This application just determines the default mail client and uses it accordingly. Now when I check the default mail client under "Control Panel" Default Programs, also under IE Programs it shows the Outlook (Desktop) which is good except the icon appears to be Outlook 2013? Further down under IMAPI the Outlook 2010 icon appears so assume this is correct.

See image below.

Default Programs for Outlook

Searching called for registry checks but from what I can see all is OK. Outlook is set as default.

Also the registry appears to be pointing to the correct place.

OK so how do I confirm that Outlook 2010 is the default client as far as the server is concerned? Should I carry out a repair of Outlook 2010 because the default programs do not allow me to choose Outlook 2010 as the default and I am not sure why Outlook 2013 shows up when it has not been installed / disabled?

Should I do the the following as recommended by some to resolve the default program issue?

 Browse to the following location:

    C:\Program Files\Common Files\System\MSMAPI\1033

Next, delete MSMAPI32.DLL, when you start Outlook 2010 the file will be recreated by Outlook upon launch, and ask you to set the application as the default.

Note, if I type "Outlook"  in the run field of the server, Outlook 2010 fires up which tells me the association / default is correct.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

On this specific server, make sure you do not have outlook 2013.  If outlook 2010 is installed, follow the below steps to make outlook 2010 the default mail client.

Method 1:-Set as default within outlook.
On the Tools menu in Office Outlook, click Options, and then click the Other tab.
Under General, select the Make Outlook the default program for E-mail, Contacts, and Calendar check box.
Method 2:- Set as default from the internet explorer.
Start Internet Explorer.
On the View menu, click Internet Options.
Click the Programs tab.
In the Mail list, click Microsoft Office Outlook.
Click OK.
Method 3:- set as default from control panel.
Navigate to Control Panel\Programs\Default Programs\Set Default Programs
Click on the outlook icon on the left hand side.
Set as default.
Compuit1Author Commented:
Hi Santhoshu,

Yes, thank you, I have followed those steps previously and that is my dilemma. The windows application appears to attempt to utilize Outlook 2013 which is not configured and not available. Note Outlook 2013 is not installed and yet it shows traces. When following the three methods of setting Outlook 2010 as default it made no change to the issue.
1) Control Panel Method
2) IE Method
3) registry Method

What I did in the end is open outlook and save an email message to file. Close Outlook 2010. Go to the file location and double click to open. Windows prompted which to set as default. I chose Outlook 2010 and set as default. This was fine, however it did not resolve the application automatically finding Outlook 2010 either.
In the end I was able to configure the application to use and lock in the SMTP settings as provisioned by the on site  exchange server. The application now finds its mail services through its Internet mail settings and fires email out of the network successfully. This is now a good result.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Thanks for the update Compuit1.
Compuit1Author Commented:
The solutions offered resolve Outlook Default setting and association but do not explain why the application could not find the mail MAPI settings on a working 2012 R2 terminal server installed with Outlook 2010. Specifying Internet mail settings in the application facilitated email functionality. This is normally not required.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.