Unix Solaris SAR no Output

i am trying to run the sar command but i don't get any output  I am not sure how it works too well.  It was disabled and i enabled with: svcadm enable svc:/system/sar:default.
now it shows online.  But when i run: sar -q -f /var/adm/sa/sa01, I don't get any output.  Please help.
ShenAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gerwin Jansen, EE MVETopic Advisor Commented:
Can you try: sar -d or sar -u - do you get any output? If you get an error, what is it?

sar -f is taking input from a file instead of actual data - can you do: ls -l /var/adm/sa/sa01 and post the output here? The file sa01 may be empty or unreadable for you.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ShenAuthor Commented:
I've requested that this question be deleted for the following reason:

using another server.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.