Application runs under IIS6 but fails under IIS8.5 with "That assembly does not allow partially trusted callers" ERROR

We have an application hosted in ASP.Net and running well under IIS6. We are now migrating to windows server 2012 and using IIS8.5. After creating the application related pools and follow same steps as we did in IIS6, the application started but when trying to access the server we get a message 'That assembly does not allow partially trusted callers', and we are using "Classic mode" as a way to maintain compatibility with our current IIS6 version.

The pools (applications) are configured in IIS8.5 as [Full trust] even by default,  and we are using "Classic mode" as a way to maintain compatibility with our current IIS6 version. When we run tha application and tried to access any function on the server we get an error "That assembly does not allow partially trusted callers". The problem is resolved when we switched the application to run under "Integrated mode" rather than "Classic mode"... What does this mean?. I thought that using classic mode will be completely compatible with what used to run under IIS6. Any explanation, would be appreciatd. Thanks
fmichailAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Peter HutchisonSenior Network Systems SpecialistCommented:
You need to make some changes to the Web.config file for full compatibility for II 7 or 8.

https://msdn.microsoft.com/en-us/library/bb515251.aspx
0
fmichailAuthor Commented:
Peter,

We are using .net 3.5 and the link talks about .NET 4 is it OK to use?
0
Peter HutchisonSenior Network Systems SpecialistCommented:
Yes, the basic principles of conversion to of the config are the same for 3.5.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fmichailAuthor Commented:
Hi Peter, and sorry for the delay.
Our DBA found 2 steps in the installtion that he did not perform, one of them is to grant Read access to GAC area to the service account running the pool, and when he granted enough rights to the account, the applications worked, and he could even switch back and forth between the classic and integrated mode. It is not fully convincing to me, but he is now installing the applications one after one successfully.
I learned a lot from your link. Thanks again Peter
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.