Exchange 2010 SP2 install failed

2 servers, DC/file server and a single Exchange server.  Installed SP2 for Exchange 2010 and failed during CAS upgrade.  Error was [WARNING] IIS://server.local/W3SVC/2/ROOT/Autodiscover wasn't found. Please make sure you've typed it correctly.

Services did not restart, so rebooted.  Services came back online and mail flow was ok.  Internally everyone was good, and externally PC users were ok.  Mac/iOS users were not able to connect.  OWA was ok as was RPC.  Activesync was throwing alot of errors, which were ironed out in IIS.   Lots of errors that I have been picking off all day.  SP2 has not been installed, as it error's out here every time.  

Here is where I am stuck.  EWS disappeared in IIS.  Get-WebServicesVirtualDirectory | FL comes back with nothing.  Remove-WebServicesVirtualDirectory comes back with "The operation couldn't be performed because object 'server.local\EWS (Default Web Site)' couldn't be found on 'DC.local'".  New-WebServicesVirtualDirectory comes back with "The virtual directory 'EWS' already exists under 'server.local/Default Web Site'.".   Tried to reset virtual directories from EMC, but it is not listed.  

Was hoping to not restore from backup, or re-install CAS, but not sure where to go.
dettlejAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Peter HutchisonSenior Network Systems SpecialistCommented:
IIS has its own backups, so if you had a recent IIS backup of IIS, you can restore IIS folders using the APPCMD
e.g. APPCMD BACKUP /?

You can also reset individual virtual directories via the powershell:
https://technet.microsoft.com/en-us/library/ff629372%28v=exchg.141%29.aspx
0
Seth SimmonsSr. Systems AdministratorCommented:
once you fix your IIS/autodiscover issue, install SP3, not SP2
service packs are cumulative so you can go straight to SP3 then cumulative update 11
SP2 has been out of support since april 2014
0
dettlejAuthor Commented:
Thanks.  I tried restoring iis and it broke just about everything in CAS.  Running a Datto and spun up a VM and was able to launch Exchange and everything looked clean.  Going to go this route or now.  Although I think I might run into the same problem with EWS in IIS.  I will post back in the morning when the restore finishes.
0
dettlejAuthor Commented:
ok, I ended up uninstalling/reinstalling CAS on the Exchange server.  I had to setup the permissions/settings for the CAS services, but everything is back online.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dettlejAuthor Commented:
CAS services needed to be re-installed.  Tried all other recommendations with no luck
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.