Mouse changes behavior to make PC use difficult

Mouse changes behavior- the mouse requires another l-click to deactivate whatever action it was doing.
For instance, when scrolling down a directory of files, if I don't click before moving the cursor from the scroll bar to the photo icons, it will highlight all the files it passes over.
Same kind of behavior when I mark part of a text: If I don't l-click after finishing marking the text, the cursor will hang on to the marked text and drag it over everything it goes over.
Finally, when making the settings on the Mouse control panel, the speed is selected by moving the arrow on the slow to fast line   – move the arrow, stop lift the key and go to Apply Button  BUT, when moving to the Apply Button, the arrow on the slow to fast line will continue to move.   I have replaced the mouse, removed and replaced the driver and reset all of the mouse settings.   Thanks for any help.  /Howard
Howard222Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Mouse changes behavior- the mouse requires another l-click to deactivate whatever action it was doing

That sound like the center wheel can have activity to it. My center wheel can be clicked to hold certain actions and then I have to click to stop it. That is a normal action. and I do not use it much to prevent the issues you have. Check your center wheel activity and disable it if need be.

In Control Panel, Mouse, Pointer Options, set Motion to about 80% fast. In Wheel tab, set roll wheel to 3 lines. Disable other actions.

Finally try a very simple mouse:  Left, Right, simple wheel. Most mice today are excessively complicated for productive use.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
Did you check the last option in Mouse Control Panel? It should not be active, as it causes exactly the behaviour you described.
0
web_trackerComputer Service TechnicianCommented:
If the above do not resolve your issue, you can try updating your mouse drivers, if that does not work try uninstalling your mouse drives and let windows reinstall them. If you need help to either the updating or reinstalling the mouse drivers let me know and we can give you the steps.
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

nobusCommented:
did you try with another mouse?  it may simply be bad
0
MereteCommented:
Could be an uneven surface, age of mouse and if the cable is kinked.
Straighten cable, unplug USB and plug in to a different port.
 Is it wireless?
Hows the battery charge levels??
Check the mouse settings in control panel mouse
0
JohnBusiness Consultant (Owner)Commented:
@Howard222  - Your mouse could be defective, the surface could be bad, the settings may need changing, or the driver may need changing.

But we cannot help if you do not do us the courtesy of responding. Thank you.
0
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
Guys, the OP stated " I have replaced the mouse, removed and replaced the driver and reset all of the mouse settings.".
0
nobusCommented:
in such a case -  if it worked fine recently  -just do a system restore to such date
0
Howard222Author Commented:
I had changed the mouse, removed and reinstalled all drivers. But the final solution included removing the Logitech drivers completely FIRSTand then deselecting ALL OPTIONS that had to do with the Wheel.  Thanks all for the comments that made me think; sorry I had to go out of town after this started.  /Howard
0
JohnBusiness Consultant (Owner)Commented:
Thanks for the update and welcome back.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PC

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.