How to Assign Names to MAC Addresses displayed by Airport Extreme and Time Capsule

My network starts with a DSL Router (supplied by the ISP).  I have an AirPort Extreme which operates in Bridge Mode and connects wirelessly to the Router.  Under the Airport Extreme I have two Apple Time Capsules (on a different floor in my home) which also operate in Bridge Mode/Extend-a-wireless-network and each connect wirelessly to the AirPort Extreme.

Using Airport Utility, I'm able to see the wireless clients connected to either the Airport Extreme or the Time Capsules (see attached file).

In the past, most of my devices were identified in Airport Utility by their DHCP Client ID name.  Somewhere/somehow the ID of the connected devices has gradually become mixed (see attached image).  Some devices are identified by their IP address, some by their DHCP ID name and some by their MAC address.

I set the name for one of the laptops (via System Preferences > Network > Advanced > TCP/IP > DHCP Client ID) , renewed the DHCP Lease (in case that caused the router to update the newly set DHCP Client ID name) but the device still shows by its MAC address under one of the Time Capsules.  I would have expected that given the fact that the laptop has a Client ID name, that this name would have been reported in Airport Utility under the device it connects to.

How can I get both the Airport Extreme and the Time Capsules to report their connected devices by showing the DHCP Client ID name of the connected devices?

Thx
Airport_Utility_View_at_2015-10-05.jpg
qengAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strungCommented:
Have you double checked to make sure that the devices that show no name in fact have no name?
strungCommented:
Also, the results you see in the Airport Utility window are not necessarily up to date. A device you see in the list might be a device a guest connected with sometime ago.
Davis McCarnOwnerCommented:
If you setup DHCP reservations in the Airport Extreme, devices will always get the same ip and everything should stabilize: http://www.macobserver.com/tmo/article/how_to_configure_a_static_dhcp_reservation_with_airport_extreme
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

strungCommented:
I think the problem is that you are putting the computer name in the wrong place.

"System Preferences > Network > Advanced > TCP/IP > DHCP Client ID" is not where the Airport utility gets the computer name from.

The computer name is in:

System Preferences > Sharing > Computer Name

If you don't have a computer name there, it won't show up in Airport Utility.

Try putting the computer name in the Sharing prefs instead and see if that solves the problem. I am not sure how quickly it will show up on airport utility. You might have to go into the network prefs in your Mac and release and renew the IP address, or turn wifi off and on.
serialbandCommented:
Macs actually have 3 names, but frequently, only 2 are set.

You can look them up here with the scutil terminal command.
scutil --get LocalHostName
scutil --get HostName
scutil --get ComputerName


You can also set them individually.
scutil --set LocalHostName=name
scutil --set HostName=name
scutil --set ComputerName=name
qengAuthor Commented:
Thx gang.  I'm away from the equipment for a few days but will try out the suggestions.  One thing to keep in mind is that several of the devices which are connected to the network are of course not computers (printers, Apple TV units, iPhones, tablets, and various wi-fi connected devices etc.)
serialbandCommented:
You need DNS to handle names for those devices.
strungCommented:
You may be able to tell from the first 6 digits of the MAC address more of less which devices the MAC address belongs to using the Vendor MAC address lookup website:  http://aruljohn.com/mac.pl

For instance, this website will show you that the MAC address in your screenshot, 70:14:A6, belongs to a Apple Device, so you know it does not belong to one of your third party printers.

This will help you narrow down the missing items. With respect to the Apple items, they should all have place to put in the device name.
qengAuthor Commented:
Thx gang.  Back at this.  To answer some of the questions:

Strung:  "Have you double checked to make sure that the devices that show no name in fact have no name?"

Yes.  Double checked.  I can confirm that devices which do have a name, such as my MBPro, do not get their names consistently displayed.  Sometimes the device name gets displayed, sometimes the MAC address gets displayed, and sometimes the IP address gets displayed, all at the same time in AirPort utility (e.g. one of the connected devices, say one of the Time Capsules, might report one device connected to it by its name, the next device in the list my its IP address and a third device in its list of connected devices by its Mac Address.

Strung:  "Also, the results you see in the Airport Utility window are not necessarily up to date. A device you see in the list might be a device a guest connected with sometime ago."

The devices listed are up to date (we've had no Guests connect to the network in a long time).  I can account for all of the devices connected on the network.

Davis:  "If you setup DHCP reservations in the Airport Extreme, devices will always get the same ip and everything should stabilize: http://www.macobserver.com/tmo/article/how_to_configure_a_static_dhcp_reservation_with_airport_extreme"

I previously had my network setup this way, but had been advised by the ISP tech, when my ISP-supplied modem/router was changed recently (when these issues started to surface), to set all of my devices' Router Mode  (my AirPort Extreme and both Time Capsules) to 'Off - Bridge Mode'.

I am now noticing (which I didn't get before the ISP modem/router swap-out) that Internet connected devices, such as my laptop, now intermittently drop their internet connection regularly (e.g. this happens every few minutes on the laptop) and I often (but not always) receive a message when the internet connection is dropped that 'another device is using IP address etc.', which I suspect occurs when someone else in the house turns on another device which is connected to the network when it then connects to the internet.  Seems like the ISP modem/router assigns the previously used IP address of one of the devices (say my laptop) to another device which connects to the network.  I haven't confirmed this yet but suspect something like this is going on.  Never had ip address conflict errors prior to the ISP modem/router swap and reconfiguration of my Airport Extreme and Time Capsules to Bridge Mode only.

Strung:  "I think the problem is that you are putting the computer name in the wrong place."

I can confirm that the (same) device name, for example on the laptop, was in fact correctly entered in both locations, namely:
"System Preferences > Network > Advanced > TCP/IP > DHCP Client ID"
and in
"System Preferences > Sharing > Computer Name"

Even though the device name was entered in both locations on the laptop, the device name fails to appear in the connected devices listed under the Time Capsule to which the laptop connects.  The device shows itself connected in the Time Capsule list under its Mac Address, while other devices under the same Time Capsule, at the same time, show a combination of IP addresses, device names.

serialband:  "Macs actually have 3 names, but frequently, only 2 are set."

Bang on.  I was able to confirm with scutil that LocalHostName and Computer Name were set and identical but that HostName wasn't set.  I was unsuccessful, using the scutil command with the syntax you suggested, in setting the HostName.  I'll research/troubleshoot, try again, and report back.

serialband:  "You need DNS to handle names for those devices."

I'm not sure what you mean by that.  I'm interpreting your comment to mean that the Domain Name Server (out somewhere in the vast internet) is supposed to acquire my device's names from my network and report them back to the network, along with an IP address, so that the networked devices (presently in Bridge Mode) such as AirPort Extreme and Time Capsule, can display their connected device names.  Although that might be correct, with my limited knowledge, that doesn't make sense to me.

I didn't know what/if any action to take based on this comment.

Strung:  "You may be able to tell from the first 6 digits of the MAC address more of less which devices the MAC address belongs to using the Vendor MAC address lookup website:  http://aruljohn.com/mac.pl"

Thx.  My issue isn't that I can't ultimately tell which devices are which.  I can visit each device (e.g. an Apple TV unit, and display it's Mac Address on the connected TV) and figure out their Mac Address.  What I'm trying to do is to stabilize the network configuration as well as get the connected devices, as displayed in AirPort Utility, to consistently display their device names.  As it is right now, not only are my IP connections dropping in and out but the device names being displayed in the lists for each network node (e.g. for the Airport Extreme and both Time Capsules) are displayed as a mixture of IP addresses, Mac Addresses, and device names, all in the same list, at the same time (only one name format per device though; in other words, devices are being correctly accounted for and not double listed).
strungCommented:
The reason for the change to bridge mode when you got the new modem was presumably that the old modem was acting only as a modem and your Airport had to do the the Network Address Translation function. Your new modem doubles as a router and does the NAT, so you have to use bridge mode for the Airport to avoid double NAT.

So the modem is also doing the DHCP and any IP address conflicts you are having originate in the modem, not the Airport.
strungCommented:
By the way, instead of just hovering over the time capsule in Airport Utility, try double-clicking on it while holding down the option key. This will give you quite a bit more information about each device. See screenshot attached.
Screen-Shot-2015-10-18-at-12.56.57-P.pdf
qengAuthor Commented:
Strung,

Thx for that tip.  I does give me a bit more info than clicking on the Time Capsule (gives among other things the Time Capsule's Mac Addresses, one for Ethernet, and each of the 2.4 GHz and 5 GHz networks).

Wondering whether I should be limiting my network to only 5GHz or whether that will limit the types of devices which can connect.
strungCommented:
That would limit the types of devices that can connect. Also 5Ghz usually does not have quite the range of 2.4, so if you have both that gives you more flexibility.
qengAuthor Commented:
Strung,

As for the Bridge Mode, what you state is correct (at least per my limited understanding).

What I'm wondering though, given the recently introduced conflicts, is whether I should go back to having the modem secure just one IP address, I access the internet via that IP address, and I assign static IP addresses from the Airport Extreme under that modem?
strungCommented:
That would mean turning off NAT on the modem, in effect setting the modem to bridge. Can you do that? Does the ISP give you access to the modem set up page to do that?
schapsCommented:
@qeng, did you ever get this resolved?
In reading through this, I definitely think it's the ISP's modem causing your issues. I would turn "DHCP and NAT" mode back on on the primary Airport Extreme. Yes, you will have double NAT, and that is not something you want to keep going long-term, but it will work fine for short-term testing. The primary consideration in doing that is making sure that the IP subnet created by the DSL router is different from the one (and with no overlap) created by your AEx. Whether you change the DSL to a different subnet so you can keep the existing one internally or change the AEx-created subnet is up to you. If you have nothing using static IP's internally, just turn on the AEx DHCP/NAT to set up your network and power cycle your slave AEx's and then restart everything else to get new IPs. [Note: your AEx will show a yellow light and complain about the double NAT, but you can override it.]

If your issues with network connectivity then go away, you know you've got that aspect solved, and you then just have to solve the double-NAT issue. You could call the ISP and demand that they put the DSL modem in bridge mode, which many will do upon strong request.

Alternatively, you set a "connect using static" IP on the AEx using whatever DHCP IP address you see it already has from the DSL modem, then login to the DSL modem and turn on "DMZ" and point it to your AEx's external IP. This method bypasses NAT on the modem and generally works fine, but it's not the best way to do it. Your AEx should stop the complaining about double NAT, and I've had setups working that way just fine for years.

Let me know if you need further explanation on any of this.

P.S. Regarding double NAT, I work with a software engineer who was recently visiting friends in a very rural area, and the only internet was served from a long string of repeaters over many miles. He ran tests and determined his Internet connectivity was going through 56 layers of NAT. He could not believe it worked at all. Latency was terrible, max speed was about 1 Mb/sec, but it worked. It was apparently a mistake by whoever had set up the network to keep NAT on all of the router/repeaters, but it nonetheless still worked for basic internet access. But, I digress...

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
qengAuthor Commented:
Strung & Schaps:

Thanks for this guys.  I'm just now getting back to this.  I'm still swamped with some other stuff but Schaps is on to something when he suggests "I would turn "DHCP and NAT" mode back on on the primary Airport Extreme" ... as I had a better grip of which devices were connecting to which access point.

To confuse the issue further, my ISP has just recently changed my modem/router again so I have to retrace my steps since we're now experiencing some new issues with signal drop-outs on our PVRs.

I'll award some points here so we can move on but don't be too surprised to see a question re-surface from me when I have time to dig back into this.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.