WSUS error post-installation

okay i get this message when try installing Wsus,, window server 2012 standard edition
 can anyone assist me fixing this issue
TIA

2015-10-05 14:39:23  Postinstall started
2015-10-05 14:39:23  Detected role services: Api, UI, WidDatabase, Services
2015-10-05 14:39:23  Start: LoadSettingsFromXml
2015-10-05 14:39:23  Start: GetConfigValue with filename=UpdateServices-Services.xml item=ContentLocal
2015-10-05 14:39:23  Value is true
2015-10-05 14:39:23  End: GetConfigValue
2015-10-05 14:39:23  Start: GetConfigValue with filename=UpdateServices-Services.xml item=ContentDirectory
2015-10-05 14:39:23  Config file did not contain a value "ContentDirectory"
2015-10-05 14:39:23  Microsoft.UpdateServices.Administration.CommandException: A required configuration value was not found in the system. This is usually caused by installing WSUS through PowerShell and not specifying a configuration file. Review the article Managing WSUS Using PowerShell at TechNet Library (http://go.microsoft.com/fwlink/?LinkId=235499) for more information on the recommended steps to perform WSUS installation using PowerShell.
   at Microsoft.UpdateServices.Administration.PostInstall.GetConfigValue(String filename, String item)
   at Microsoft.UpdateServices.Administration.PostInstall.LoadSettingsFromXml()
   at Microsoft.UpdateServices.Administration.PostInstall.Initalize(Parameters parameters)
   at Microsoft.UpdateServices.Administration.PostInstall.Execute(String[] arguments)
Fatal Error: A required configuration value was not found in the system. This is usually caused by installing WSUS through PowerShell and not specifying a configuration file. Review the article Managing WSUS Using PowerShell at TechNet Library (http://go.microsoft.com/fwlink/?LinkId=235499) for more information on the recommended steps to perform WSUS installation using PowerShell.
WHODOITRUSTMEAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
did you install using server manager or powershell?
0
WHODOITRUSTMEAuthor Commented:
Server Manager
0
Seth SimmonsSr. Systems AdministratorCommented:
at what point did the error appear?  while installing the role or when you attempted the post-install config?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

WHODOITRUSTMEAuthor Commented:
when attempted post-install config
0
Thomas GrassiSystems AdministratorCommented:
Are you installing with internal and SQL database?

Is this server a DC or member server?

When you select this Role did it display other prerequisites to be installed?
0
DrDave242Commented:
Ah, I've run across this before while troubleshooting a different WSUS installation issue. There are apparently a couple of possible ways to fix it:
Simply launch the WSUS console, which should prompt you for the necessary info.
Browse to C:\Windows\System32\ServerManager\ComponentConfiguration\ and open the UpdateServices-Services.xml file. Search for the ContentDirectory property, and you'll likely find that it has no value. Edit it as shown here. (All of the needed info is in the original post - you don't have to dig through all of the comments unless you want to.)
0
WHODOITRUSTMEAuthor Commented:
Thomas,
Are you installing with internal and SQL database?
 WID Database
WSUS Services
Is this server a DC or member server?
DC
When you select this Role did it display other prerequisites to be installed?
yes I ADDED FEATURES [tools] user interface management console
0
WHODOITRUSTMEAuthor Commented:
drdave242

ill try that next let you know the results
0
Thomas GrassiSystems AdministratorCommented:
I would not install this role on a DC

Do you have a member server?
0
WHODOITRUSTMEAuthor Commented:
we have 2 dc replicating to each other why the reason not to?
Do you have a member server?
yes but it is server 2008 r2
0
DrDave242Commented:
I don't think installing WSUS on a DC presents any problems, although I'm kinda surprised you didn't run into the issue in which the installation won't complete because the Windows Internal Database service won't start. The seems pretty common when installing it on a DC (but it's easy to fix).
0
Thomas GrassiSystems AdministratorCommented:
I would install it on the Windows 2008 Server

I run mine on windows 2008 no issues

Try installing on that server
0
WHODOITRUSTMEAuthor Commented:
dRDAVE242,
 did what you had suggested no luck this is what i get:


2015-10-09 14:54:03  Postinstall started
2015-10-09 14:54:03  Detected role services: Api, UI, WidDatabase, Services
2015-10-09 14:54:03  Start: LoadSettingsFromXml
2015-10-09 14:54:03  Start: GetConfigValue with filename=UpdateServices-Services.xml item=ContentLocal
2015-10-09 14:54:03  Value is true
2015-10-09 14:54:03  End: GetConfigValue
2015-10-09 14:54:03  Start: GetConfigValue with filename=UpdateServices-Services.xml item=ContentDirectory
2015-10-09 14:54:03  Value is C:\WSUS
2015-10-09 14:54:03  End: GetConfigValue
2015-10-09 14:54:03  Content directory is C:\WSUS
2015-10-09 14:54:03  Database roleservice is not installed
2015-10-09 14:54:03  End: LoadSettingsFromXml
Post install is starting
2015-10-09 14:54:03  Start: Run
2015-10-09 14:54:03  Configuring content directory...
2015-10-09 14:54:03  Configuring groups...
2015-10-09 14:54:03  Starting group configuration for WSUS Administrators...
2015-10-09 14:54:03  Found group in regsitry, attempting to use it...
2015-10-09 14:54:03  Searching for existing group...
2015-10-09 14:54:03  Existing group was found
2015-10-09 14:54:03  Writing group to registry...
2015-10-09 14:54:03  Finished group creation
2015-10-09 14:54:03  Starting group configuration for WSUS Reporters...
2015-10-09 14:54:03  Found group in regsitry, attempting to use it...
2015-10-09 14:54:03  Searching for existing group...
2015-10-09 14:54:03  Existing group was found
2015-10-09 14:54:03  Writing group to registry...
2015-10-09 14:54:03  Finished group creation
2015-10-09 14:54:03  Configuring permissions...
2015-10-09 14:54:03  Fetching content directory...
2015-10-09 14:54:03  Fetching ContentDir from registry store
2015-10-09 14:54:03  Value is C:\WSUS
2015-10-09 14:54:03  Fetching group SIDs...
2015-10-09 14:54:03  Fetching WsusAdministratorsSid from registry store
2015-10-09 14:54:03  Value is S-1-5-21-3819146159-1806916483-639220100-1620
2015-10-09 14:54:03  Fetching WsusReportersSid from registry store
2015-10-09 14:54:03  Value is S-1-5-21-3819146159-1806916483-639220100-1621
2015-10-09 14:54:03  Creating group principals...
2015-10-09 14:54:05  Granting directory permissions...
2015-10-09 14:54:05  Granting permissions on content directory...
2015-10-09 14:54:05  Granting registry permissions...
2015-10-09 14:54:05  Granting registry permissions...
2015-10-09 14:54:05  Granting registry permissions...
2015-10-09 14:54:05  Configuring shares...
2015-10-09 14:54:05  Configuring network shares...
2015-10-09 14:54:05  Fetching content directory...
2015-10-09 14:54:05  Fetching ContentDir from registry store
2015-10-09 14:54:05  Value is C:\WSUS
2015-10-09 14:54:05  Fetching WSUS admin SID...
2015-10-09 14:54:05  Fetching WsusAdministratorsSid from registry store
2015-10-09 14:54:05  Value is S-1-5-21-3819146159-1806916483-639220100-1620
2015-10-09 14:54:05  Content directory is local, creating content shares...
2015-10-09 14:54:05  Creating share "UpdateServicesPackages" with path "C:\WSUS\UpdateServicesPackages" and description "A network share to be used by client systems for collecting all software packages (usually applications) published on this WSUS system."
2015-10-09 14:54:05  Deleting existing share...
2015-10-09 14:54:05  Creating share...
2015-10-09 14:54:05  Share successfully created
2015-10-09 14:54:05  Creating share "WsusContent" with path "C:\WSUS\WsusContent" and description "A network share to be used by Local Publishing to place published content on this WSUS system."
2015-10-09 14:54:05  Deleting existing share...
2015-10-09 14:54:05  Creating share...
2015-10-09 14:54:05  Share successfully created
2015-10-09 14:54:05  Creating share "WSUSTemp" with path "C:\Program Files\Update Services\LogFiles\WSUSTemp" and description "A network share used by Local Publishing from a Remote WSUS Console Instance."
2015-10-09 14:54:05  Deleting existing share...
2015-10-09 14:54:05  Creating share...
2015-10-09 14:54:05  Share successfully created
2015-10-09 14:54:05  Finished creating content shares
2015-10-09 14:54:05  Configuring WID database...
2015-10-09 14:54:05  Configuring the database...
2015-10-09 14:54:06  Establishing DB connection...
2015-10-09 14:54:06  Checking to see if database exists...
2015-10-09 14:54:06  Database exists
2015-10-09 14:54:06  Switching database to single user mode...
2015-10-09 14:54:06  Loading install type query...
2015-10-09 14:54:06  DECLARE @currentScriptVersion   int
DECLARE @currentDBVersion       int
IF NOT EXISTS(SELECT * FROM sys.databases WHERE name='SUSDB')
BEGIN
    SELECT 1
END
ELSE
BEGIN
    SET @currentScriptVersion = (9200 + 16384)
    SET @currentDBVersion = (SELECT SchemaVersion FROM SUSDB.dbo.tbSchemaVersion WHERE ComponentName = 'CoreDB')
    IF @currentDBVersion < 926
    BEGIN
        SELECT 3
    END
    ELSE IF @currentDBVersion < @currentScriptVersion
    BEGIN
        SELECT 2
    END
    ELSE IF @currentDBVersion = @currentScriptVersion
    BEGIN
        SELECT 0
    END
    ELSE
    BEGIN
        SELECT 4
    END
END

2015-10-09 14:54:06  Install type is: Reinstall
2015-10-09 14:54:06  Creating logins...
2015-10-09 14:54:06  Fetching account info for S-1-5-20
2015-10-09 14:54:06  Found principal
2015-10-09 14:54:06  Found account
2015-10-09 14:54:06  Got binary SID
2015-10-09 14:54:06  Fetching WsusAdministratorsSid from registry store
2015-10-09 14:54:06  Value is S-1-5-21-3819146159-1806916483-639220100-1620
2015-10-09 14:54:06  Fetching account info for S-1-5-21-3819146159-1806916483-639220100-1620
2015-10-09 14:54:06  Fetching account info for S-1-5-21-3819146159-1806916483-639220100-1620
2015-10-09 14:54:07  Found principal
2015-10-09 14:54:07  Found account
2015-10-09 14:54:07  Got binary SID
2015-10-09 14:54:07  Setting content location...
2015-10-09 14:54:07  Fetching ContentDir from registry store
2015-10-09 14:54:07  Value is C:\WSUS
2015-10-09 14:54:07  Swtching DB to multi-user mode......
2015-10-09 14:54:07  Finished setting multi-user mode
2015-10-09 14:54:07  Writing DB settings to registry...
2015-10-09 14:54:07  Marking PostInstall done for UpdateServices-WidDatabase in the registry...
2015-10-09 14:54:07  Configuring IIS...
2015-10-09 14:54:07  Start: ConfigureWebsite
2015-10-09 14:54:07  System.Runtime.InteropServices.COMException (0x80070003): The system cannot find the path specified.

   at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
   at System.DirectoryServices.DirectoryEntry.Bind()
   at System.DirectoryServices.DirectoryEntry.get_AdsObject()
   at System.DirectoryServices.PropertyValueCollection.PopulateList()
   at System.DirectoryServices.PropertyValueCollection..ctor(DirectoryEntry entry, String propertyName)
   at System.DirectoryServices.PropertyCollection.get_Item(String propertyName)
   at Microsoft.UpdateServices.Administration.UseCustomWebSite..ctor()
   at Microsoft.UpdateServices.Administration.PostInstall.ConfigureWebsite(Int32 portNumber)
   at Microsoft.UpdateServices.Administration.PostInstall.Run()
   at Microsoft.UpdateServices.Administration.PostInstall.Execute(String[] arguments)
Fatal Error: The system cannot find the path specified.
0
WHODOITRUSTMEAuthor Commented:
Thomas i would like to install it on 2012 server
0
WHODOITRUSTMEAuthor Commented:
this is what my xml file looks like:


<?xml version="1.0" encoding="utf-16"?><INSTANCE CLASSNAME="ServerComponent_UpdateServices_Services"><PROPERTY NAME="ContentDirectory" TYPE="string"><VALUE>C:\WSUS</VALUE></PROPERTY><PROPERTY NAME="ContentLocal" TYPE="boolean"><VALUE>true</VALUE></PROPERTY></INSTANCE>
0
Thomas GrassiSystems AdministratorCommented:
Not a good practice installing applications on a DC.


The xml looks good


Do you have a sql server anywhere?

If so try installing and using a sql server DB not internal
0
DrDave242Commented:
Yeah, that XML looks fine, and it's gotten further than before. The installation now appears to be running into trouble during the IIS configuration.

I did a little searching and found this discussion thread, which revolves around exactly the same error you're seeing and contains a couple of things you may want to try.
0
WHODOITRUSTMEAuthor Commented:
2015-10-09 16:53:49  Postinstall started
2015-10-09 16:53:49  Detected role services: Api, UI, WidDatabase, Services
2015-10-09 16:53:49  Start: LoadSettingsFromParameters
2015-10-09 16:53:49  Content local is: True
2015-10-09 16:53:49  Content directory is: C:\WSUS
2015-10-09 16:53:49  SQL instname is:
2015-10-09 16:53:49  End: LoadSettingsFromParameters
2015-10-09 16:53:49  Start: Run
2015-10-09 16:53:49  Configuring content directory...
2015-10-09 16:53:49  Configuring groups...
2015-10-09 16:53:49  Starting group configuration for WSUS Administrators...
2015-10-09 16:53:49  Found group in regsitry, attempting to use it...
2015-10-09 16:53:49  Searching for existing group...
2015-10-09 16:53:49  Existing group was found
2015-10-09 16:53:49  Writing group to registry...
2015-10-09 16:53:49  Finished group creation
2015-10-09 16:53:49  Starting group configuration for WSUS Reporters...
2015-10-09 16:53:49  Found group in regsitry, attempting to use it...
2015-10-09 16:53:49  Searching for existing group...
2015-10-09 16:53:50  Existing group was found
2015-10-09 16:53:50  Writing group to registry...
2015-10-09 16:53:50  Finished group creation
2015-10-09 16:53:50  Configuring permissions...
2015-10-09 16:53:50  Fetching content directory...
2015-10-09 16:53:50  Fetching ContentDir from registry store
2015-10-09 16:53:50  Value is C:\WSUS
2015-10-09 16:53:50  Fetching group SIDs...
2015-10-09 16:53:50  Fetching WsusAdministratorsSid from registry store
2015-10-09 16:53:50  Value is S-1-5-21-3819146159-1806916483-639220100-1620
2015-10-09 16:53:50  Fetching WsusReportersSid from registry store
2015-10-09 16:53:50  Value is S-1-5-21-3819146159-1806916483-639220100-1621
2015-10-09 16:53:50  Creating group principals...
2015-10-09 16:53:51  Granting directory permissions...
2015-10-09 16:53:51  Granting permissions on content directory...
2015-10-09 16:53:51  Granting registry permissions...
2015-10-09 16:53:51  Granting registry permissions...
2015-10-09 16:53:51  Granting registry permissions...
2015-10-09 16:53:51  Configuring shares...
2015-10-09 16:53:51  Configuring network shares...
2015-10-09 16:53:51  Fetching content directory...
2015-10-09 16:53:51  Fetching ContentDir from registry store
2015-10-09 16:53:51  Value is C:\WSUS
2015-10-09 16:53:51  Fetching WSUS admin SID...
2015-10-09 16:53:51  Fetching WsusAdministratorsSid from registry store
2015-10-09 16:53:51  Value is S-1-5-21-3819146159-1806916483-639220100-1620
2015-10-09 16:53:51  Content directory is local, creating content shares...
2015-10-09 16:53:51  Creating share "UpdateServicesPackages" with path "C:\WSUS\UpdateServicesPackages" and description "A network share to be used by client systems for collecting all software packages (usually applications) published on this WSUS system."
2015-10-09 16:53:51  Deleting existing share...
2015-10-09 16:53:51  Creating share...
2015-10-09 16:53:51  Share successfully created
2015-10-09 16:53:51  Creating share "WsusContent" with path "C:\WSUS\WsusContent" and description "A network share to be used by Local Publishing to place published content on this WSUS system."
2015-10-09 16:53:51  Deleting existing share...
2015-10-09 16:53:51  Creating share...
2015-10-09 16:53:51  Share successfully created
2015-10-09 16:53:51  Creating share "WSUSTemp" with path "C:\Program Files\Update Services\LogFiles\WSUSTemp" and description "A network share used by Local Publishing from a Remote WSUS Console Instance."
2015-10-09 16:53:51  Deleting existing share...
2015-10-09 16:53:51  Creating share...
2015-10-09 16:53:51  Share successfully created
2015-10-09 16:53:51  Finished creating content shares
2015-10-09 16:53:51  Configuring WID database...
2015-10-09 16:53:51  Configuring the database...
2015-10-09 16:53:52  Establishing DB connection...
2015-10-09 16:53:52  Checking to see if database exists...
2015-10-09 16:53:52  Database exists
2015-10-09 16:53:52  Switching database to single user mode...
2015-10-09 16:53:55  Loading install type query...
2015-10-09 16:53:55  DECLARE @currentScriptVersion   int
DECLARE @currentDBVersion       int
IF NOT EXISTS(SELECT * FROM sys.databases WHERE name='SUSDB')
BEGIN
    SELECT 1
END
ELSE
BEGIN
    SET @currentScriptVersion = (9200 + 16384)
    SET @currentDBVersion = (SELECT SchemaVersion FROM SUSDB.dbo.tbSchemaVersion WHERE ComponentName = 'CoreDB')
    IF @currentDBVersion < 926
    BEGIN
        SELECT 3
    END
    ELSE IF @currentDBVersion < @currentScriptVersion
    BEGIN
        SELECT 2
    END
    ELSE IF @currentDBVersion = @currentScriptVersion
    BEGIN
        SELECT 0
    END
    ELSE
    BEGIN
        SELECT 4
    END
END

2015-10-09 16:53:55  Install type is: Reinstall
2015-10-09 16:53:55  Creating logins...
2015-10-09 16:53:55  Fetching account info for S-1-5-20
2015-10-09 16:53:55  Found principal
2015-10-09 16:53:55  Found account
2015-10-09 16:53:55  Got binary SID
2015-10-09 16:53:55  Fetching WsusAdministratorsSid from registry store
2015-10-09 16:53:55  Value is S-1-5-21-3819146159-1806916483-639220100-1620
2015-10-09 16:53:55  Fetching account info for S-1-5-21-3819146159-1806916483-639220100-1620
2015-10-09 16:53:55  Fetching account info for S-1-5-21-3819146159-1806916483-639220100-1620
2015-10-09 16:53:55  Found principal
2015-10-09 16:53:55  Found account
2015-10-09 16:53:55  Got binary SID
2015-10-09 16:53:55  Setting content location...
2015-10-09 16:53:55  Fetching ContentDir from registry store
2015-10-09 16:53:55  Value is C:\WSUS
2015-10-09 16:53:55  Swtching DB to multi-user mode......
2015-10-09 16:53:56  Finished setting multi-user mode
2015-10-09 16:53:56  Writing DB settings to registry...
2015-10-09 16:53:56  Marking PostInstall done for UpdateServices-WidDatabase in the registry...
2015-10-09 16:53:56  Configuring IIS...
2015-10-09 16:53:56  Start: ConfigureWebsite
2015-10-09 16:53:56  Configuring website on port 8530
2015-10-09 16:54:36  2015-10-09 16:54:06  Info      IISCustomAction    Performing Setup Action, Command /Install
2015-10-09 16:54:35  Info      IISCustomAction    Command /Install Succeeded

2015-10-09 16:54:36  End: ConfigureWebsite
2015-10-09 16:54:36  Configuring performance counters...
2015-10-09 16:54:36  Configuring Stats.NET perf counter...
2015-10-09 16:54:36  Configuring reporting perf counter...
2015-10-09 16:54:36  Configuring client webservice perf counter...
2015-10-09 16:54:36  Configuring server sync webservice perf counter...
2015-10-09 16:54:36  Configuring API remoting perf counter...
2015-10-09 16:54:36  Bringing services online...
2015-10-09 16:54:36  Checking initialization status...
2015-10-09 16:54:36  Database needs initialization.
2015-10-09 16:54:36  StartServer starting...
2015-10-09 16:54:36  Generating encryption key to write to the registry...
2015-10-09 16:54:36  Generating encryption key to write to the database...
2015-10-09 16:54:36  Generating encryption key succeeded...
2015-10-09 16:54:36  Setting WSUSService to autostart...
2015-10-09 16:54:36  WSUSService is set to autostart.
2015-10-09 16:54:36  Starting WSUSService...
2015-10-09 16:54:36  Failed to start WsusService. Exception: System.InvalidOperationException: Cannot start service WSUSService on computer '.'. ---> System.ComponentModel.Win32Exception: An instance of the service is already running
   --- End of inner exception stack trace ---
   at System.ServiceProcess.ServiceController.Start(String[] args)
   at Microsoft.UpdateServices.Setup.StartServer.StartServer.StartAndConfigureService()
2015-10-09 16:54:36  Importing default detectoids.
2015-10-09 16:54:36  Importing CriticalUpdates.xml...
2015-10-09 16:54:37  Importing Drivers.xml...
2015-10-09 16:54:37  Importing FeaturePacks.xml...
2015-10-09 16:54:37  Importing MicrosoftCorporation.xml...
2015-10-09 16:54:37  Importing SecurityUpdates.xml...
2015-10-09 16:54:37  Importing ServicePacks.xml...
2015-10-09 16:54:37  Importing Tools.xml...
2015-10-09 16:54:37  Importing UpdateRollups.xml...
2015-10-09 16:54:37  Importing Updates.xml...
2015-10-09 16:54:37  Importing Windows.xml...
2015-10-09 16:54:37  Importing Windows2000family.xml...
2015-10-09 16:54:37  Importing WindowsServer2003DatacenterEdition.xml...
2015-10-09 16:54:37  Importing WindowsServer2003Family.xml...
2015-10-09 16:54:37  Importing WindowsXPfamily.xml...
2015-10-09 16:54:37  Importing LocalPublisher.xml...
2015-10-09 16:54:37  Importing LocallyPublishedPackages.xml...
2015-10-09 16:54:37  Importing Applications.xml...
2015-10-09 16:54:37  Importing Exchange.xml...
2015-10-09 16:54:37  Importing Office.xml...
2015-10-09 16:54:37  Importing SQL.xml...
2015-10-09 16:54:37  Importing Exchange2000Server.xml...
2015-10-09 16:54:37  Importing ExchangeServer2003.xml...
2015-10-09 16:54:37  Importing OfficeXP.xml...
2015-10-09 16:54:37  Importing Office2003.xml...
2015-10-09 16:54:37  Importing SQLServer.xml...
2015-10-09 16:54:37  Importing WindowsXP64BitEditionVersion2003.xml...
2015-10-09 16:54:37  Importing DefinitionUpdateSusXml.xml...
2015-10-09 16:54:37  Importing ClientServicingApiDetectoid.xml...
2015-10-09 16:54:37  Importing default detectoids succeeded.
2015-10-09 16:54:37  Creating default subscription.
2015-10-09 16:54:37  Instantiating UpdateServer
2015-10-09 16:54:50  CreateDefaultSubscription failed. Exception: System.Net.WebException: The request failed with HTTP status 503: Service Unavailable.
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Microsoft.UpdateServices.Internal.ApiRemoting.GetServerVersion()
   at Microsoft.UpdateServices.Internal.DatabaseAccess.AdminDataAccessProxy.GetServerVersion()
   at Microsoft.UpdateServices.Internal.BaseApi.UpdateServer.CreateUpdateServer(String serverName, Boolean useSecureConnection, Int32 portNumber)
   at Microsoft.UpdateServices.Internal.BaseApi.UpdateServer..ctor(Boolean bypassApiRemoting)
   at Microsoft.UpdateServices.Setup.StartServer.StartServer.CreateDefaultSubscription()
2015-10-09 16:54:50  StartServer encountered errors. Exception=The request failed with HTTP status 503: Service Unavailable.
2015-10-09 16:54:50  Microsoft.UpdateServices.Administration.CommandException: Failed to start and configure the WSUS service
   at Microsoft.UpdateServices.Administration.PostInstall.Run()
   at Microsoft.UpdateServices.Administration.PostInstall.Execute(String[] arguments)
0
DrDave242Commented:
It's getting even further now.

This thread relates to this particular error, and it looks like this is what fixed it for most of the participants:

I solved this issue by opening IIS Manager and deleting the old WSUS web site, then running the Complete WSUS Installation again.
0
WHODOITRUSTMEAuthor Commented:
i thing my web server IIS is broken or something i deleted and recreated the default web site
0
WHODOITRUSTMEAuthor Commented:
should u remove and reinstall the web server role?
0
DrDave242Commented:
If there's nothing else currently using IIS on that server, that may be your best option.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Thomas GrassiSystems AdministratorCommented:
This is why we do not install applications on DC servers.

take a look at this

http://blogs.technet.com/b/abizerh/archive/2009/07/16/should-iis-be-installed-on-domain-controller.aspx
0
WHODOITRUSTMEAuthor Commented:
alright its working now.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.