Cisco Router 1841

Hello All,

I have a new cisco router that i am trying to bring online but it does not seem to be able to hit the internet. I can ping the interface and the and the gateway but not the internet. I am fairly new at this but from what i do know i think it should be working. I'm sure that i am just missing something simple. I am posting my config below.

BradHome#sho run
Building configuration...

Current configuration : 1658 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BradHome
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$Rf6F$0.B3hVHmazAdkJwNuM4cy0
enable password
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
ip domain name router
ip ssh version 2
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description From ISP
ip address 192.168.1.2 255.255.255.0
ip nat outside
no ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
shutdown
no snmp trap link-status
!
interface FastEthernet0/1.2
encapsulation dot1Q 3
ip address 10.10.10.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/1.3
encapsulation dot1Q 4
ip address 10.10.20.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/1.4
encapsulation dot1Q 100
ip address 10.10.1.1 255.255.255.0
no snmp trap link-status
!
ip default-gateway 192.168.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
ip http server
no ip http secure-server
ip nat inside source list 100 interface FastEthernet0/0 overload
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password warcraft6
login local
transport input ssh
line vty 5 15
login local
transport input ssh
!
end

BradHome#



Thanks.
LVL 2
Bradley BishopAssociate Product DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mikebernhardtCommented:
I don't know from which interface it isn't working, but since you have this line:
ip nat inside source list 100 interface FastEthernet0/0 overload

you also need an access list 100 to spell out what gets NATted. It can be as simple as
access-list 100 permit ip any any
0
Bradley BishopAssociate Product DeveloperAuthor Commented:
Fa 0/0 is the outside interface, that is what is not working. Is there a better way to do it?
0
mikebernhardtCommented:
Where is the computer from which you are trying to reach the internet? Are you saying that you are trying to ping the ISP from the router itself?
0
Become an IT Security Management Expert

In today’s fast-paced, digitally transformed world of business, the need to protect network data and ensure cloud privacy has never been greater. With a B.S. in Network Operations and Security, you can get the credentials it takes to become an IT security management expert.

Bradley BishopAssociate Product DeveloperAuthor Commented:
yes i am on the router itself trying to ping google or the isp. I added the access-list 100 permit ip any any and that did not make a difference.
0
mikebernhardtCommented:
Is the ip address 192.168.1.2 in your config above just representative of the actual one your ISP gave you, or did you actually put that on your router? Sorry if that's a "is it plugged in?" sort of question. Can you ping the IP address of the ISP side of the link?

You will not be able to ping domain names unless DNS is configured on the router, only IP addresses.
ip domain-server x.x.x.x
0
Bradley BishopAssociate Product DeveloperAuthor Commented:
no problem. So i originally had the ISP plugged directly in however i could not get it to work and needed internet back to do research. So i have a linksys "router" there that is providing dhcp and a gateway so that i have internet and the 192.168.1.2 is from the linksys until i can get any problems with the config worked out. I am able to ping the Linksys gateway from the Cisco Router but i cannot ping any thing on the ISP side. I can however ping and get to the internet just fine on the rest of the network that is connected to the Linksys "router"

Yes i am only pinging ips.
0
Andy SCommented:
Why is interface FastEthernet0/1.1 shutdown ?
0
Bradley BishopAssociate Product DeveloperAuthor Commented:
no reason really. must have just forgot to turn it back on. I did so but it did not change anything.
0
JustInCaseCommented:
You need
#ip nat inside
on all of subinterfaces for networks that need to go to internet.
and you need ACL 100 as mikebernhardt already said :) so you can perform nat

access-list 100 permit ip 192.168.2.0 0.0.0.255 any
access-list 100 permit ip 10.10.0.0 0.0.255.255 any

if you don't nat all traffic (you need ip nat inside for that), you should set static routes on linksys  to point 192.168.1.1  as next hop to reach 10.x.x.x networks, since linksys have no idea where networks 10.10.0.0/16 are.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JustInCaseCommented:
If you want to use just Cisco router without Linksys router, you should configure changes from above and on Fa0/0 configure
# ip address dhcp
instead of static IP address (or static IP address that ISP gave you), and it should work.
In that case you should change default route to match changes.
0
Bradley BishopAssociate Product DeveloperAuthor Commented:
yea i had it that way before but could not get to the internet at all any where so switched it to this so that i could trouble shoot and once i know that the issue is resolved then i will be switching it back. I made your changes and all changes that have been suggested and still nothing the new config is as follows with a couple pings at the end the 192.168.1.254 is the linksys router:

BradHome#show run
Building configuration...

Current configuration : 1900 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BradHome
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$Rf6F$0.B3hVHmazAdkJwNuM4cy0
enable password
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
ip domain name router
ip ssh version 2
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description From ISP
 ip address 192.168.1.2 255.255.255.0
 ip nat outside
 no ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.1
 encapsulation dot1Q 2
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no snmp trap link-status
!
interface FastEthernet0/1.2
 encapsulation dot1Q 3
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no snmp trap link-status
!
interface FastEthernet0/1.3
 encapsulation dot1Q 4
 ip address 10.10.20.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no snmp trap link-status
!
interface FastEthernet0/1.4
 encapsulation dot1Q 100
 ip address 10.10.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no snmp trap link-status
!
ip default-gateway 192.168.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
ip http server
no ip http secure-server
ip nat inside source list 100 interface FastEthernet0/0 overload
!
access-list 100 permit ip 192.168.2.0 0.0.0.255 any
access-list 100 permit ip 10.10.0.0 0.0.255.255 any
access-list 100 permit ip any any
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password warcraft6
 login local
 transport input ssh
line vty 5 15
 login local
 transport input ssh
!
end

BradHome#ping 192.168.1.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.254, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms
BradHome#ping 8.8.8.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
BradHome#
0
JustInCaseCommented:
That should work if default route is OK.
follows with a couple pings at the end the 192.168.1.254
Is your router IP address 192.168.1.254???
If so then your default route  and default gateway should be set:

ip default-gateway 192.168.1.254
ip route 0.0.0.0 0.0.0.0 192.168.1.254

What is result of
# sh ip interface brief
0
JustInCaseCommented:
You can also remove default gateway and default route with

# no ip default-gateway 192.168.1.254             <-----  whatever address is currently  set
# no ip route 0.0.0.0 0.0.0.0 192.168.1.254      <-----    the same as above ^ :)

and set default route as
# ip route 0.0.0.0 0.0.0.0 FastEthernet 0/0

That eliminates need for you to know ip address of next hop.
0
Bradley BishopAssociate Product DeveloperAuthor Commented:
that did it! man i knew i was missing something dumb! Thank you all so much. just because you asked here is the sh ip interface brief.

BradHome#ping 8.8.8.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/40 ms
BradHome#sh ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.2     YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  up                    up
FastEthernet0/1.1          192.168.2.1     YES NVRAM  up                    up
FastEthernet0/1.2          10.10.10.1      YES NVRAM  up                    up
FastEthernet0/1.3          10.10.20.1      YES NVRAM  up                    up
FastEthernet0/1.4          10.10.1.1       YES NVRAM  up                    up
NVI0                       unassigned      YES unset  up                    up
BradHome#
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.