Can't grant Full Access Permission on the Exchange Server

JohnMan777
JohnMan777 used Ask the Experts™
on
I have recently moved some users from one OU to another in the AD. Since then I receive an error when going to the exchange 2010 server. I click on one of the users, and select"Manage Full Access Permission." The following error message appears:

"The operation couldn't be performed because object (path to OU where the user used to be) couldn't be found on (name of domain server). It was running the command Get-MailboxPermission."  ( see attached picture.)

When I move the same user back into his old OU, it works fine again. The error message is gone.

I've seen some google articles about updating the Forest that look a bit scary and may not apply here as I'm using the GUI only.

For any help offered, please explain why this is happening and why your fix will work. I'd like to know what's really going on here.

Thank you,

John
2015-10-05-16_06_48-Clipboard.png
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Senior Network Consultant / Engineer
Commented:
This sounds like a refresh issue to me.

Can you move the user, close the management console, and then try to set the permissions again?

How long did you wait before trying to set full access after moving the object?
Top Expert 2015

Commented:
please check OU security options is it inherited from root or inheritance is disabled. seems Exchange servers group does not have permission on specific OU.

create another OU and try moving same user to new one then check.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial