Link to home
Start Free TrialLog in
Avatar of Josh Rowe
Josh RoweFlag for Australia

asked on

Out of Office Issues

We are currently unable to turn on out of office in both outlook and OWA. In outlook I am getting the "You automatic reply settings cannot be displayed because the server is currently unavailable" I did the autoconfiguration test and there were no errors. It was working. I recently was trying to get HTTPS redirection working, and I changed the URL in the default website and the error pages, but I have changed these settings back with no success. I tried entering the OOF URL from the test results and it doesn't seem to resolve. I believe it may be an IIS issue? We are currently running Exchange 2010 on a Server 2012 R2 box and 2013 clients.
Avatar of Josh Rowe
Josh Rowe
Flag of Australia image

ASKER

This is the error I get when entering the URL returned in the autoconfig results.
2015-10-06-11_31_38-smctnv-email01--.jpg
I have been trying a few different things, and I have worked out I can still enable and disable the out of office settings via powershell.
Avatar of Miguel Angel Perez Muñoz
How risky is resetting the EWS directory? It says I need to reconfigure the virtual directory, but I am not sure what to reconfigure. Am i just replicating the settings currently in the directory?
No, you delete virtual directory config and files and recreates. You must to reconfigure auth method and other stuff (like external and internal url).
Running Get-WebServicesVirtualDirectory you can take note of your current config and recreate: https://technet.microsoft.com/en-us/library/aa998810(v=exchg.160).aspx
I ran the command. The information returned is Name: EWS (Default Web Site), Server: SMCTNV-EMAIL01 and InternalURL: https://smctnv-email01.sunmetals.com...

Is this the only information I would need to take not of, or is there more verbose information listed somewhere else I need to be aware of?

Sorry to be pedantic, I have not spent much time messing around with this side of exchange before, and need to be sure before I change something that's going to affect multiple areas of our email system.
You must run command "Get-WebServicesVirtualDirectory | fl" to get full detailed configuration
I have reset the virtual directory and it hasn't made a difference unfortunately. I tried it a couple times, I also tried creating a new EWS folder which did not work. Is there any way to generate a new folder with the asmx and webconfig files?
ASKER CERTIFIED SOLUTION
Avatar of Josh Rowe
Josh Rowe
Flag of Australia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Found the resolution myself. Turned out to be an issue relating to absolute paths in the config file. Good information from Miguel Angel Perez Muñoz on resetting the EWS virtual directory. Unfortunately though it didn't resolve my issue as I have read it has done for other people with similar issues relating to Out of Office.