Avatar of James Buller
James Buller
 asked on

C Drive Read / Write

Hi Guys

We have a training XP computer in our company and when a domain admin is logged in (company owner) they are unable to write to the c:

When we switch to another domain admin they are able to. i've tried forcing the group policy but still no luck

Any ideas?

Many thanks
Storage HardwareIT AdministrationWindows XPActive DirectoryOS Security

Avatar of undefined
Last Comment
McKnife

8/22/2022 - Mon
Michael Best

What error message is given?
James Buller

ASKER
Access is denied for the company owner (domain admin account) all ok for the other domain admin account
McKnife

Normal behavior since windows xp. Only admins may write to c: directly. ON your system where it does work, the UAC is off while on the other, it is on.
3 solutions:
-don't write to c: but use a folder
-turn off UAC
-change access rights on c:
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
James Buller

ASKER
Thanks McKnife but its a folder off C:

I understand that people can't normally write to the C:

We don't want to change the access writes as it works on another computer thats next to it with the same settings
McKnife

Ok, please show the access rights using a screenshot.
ASKER CERTIFIED SOLUTION
noxcho

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Michael Best

Right click the folder and take ownership of the folder.

https://support.microsoft.com/en-us/kb/308421
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
McKnife

Domain admins (as a group, so all of them) are by default in the local administrator group, so the selected solution could not have any effect. What solved it?
noxcho

Looks like the company owner is using a domain admin account which is not a default Domain Admin. That's why it is not in local admins group. I have seen this problem with XP very often when trying to deploy the software to remote XP machine which is part of AD but even using the DC Admin account it failed. Till I added on XP locally the account to admin group.
McKnife

You are not admin until you elevate - same for domain admins. But: if you put "his" domain admin into that group "administrators", it cannot be different since elevation needs to take place anyway.
The only user that does not need to elevate is the account "administrator" (no matter if domain or local account).

So he will have done other adjustments as well, like tuning the ACL to feature his admin's name, directly, I guess. Right, James?
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy