Exchange 2010 does not create expected email account for users.

Hi Experts.
I have 1 2012 standard box running as AD and 1 2008 Enterprise R2 running as AD member and Exchange 2010 w/sp1.
The AD domain name is sunrisebhc.local.  The users need to have email accounts end with .com not .local so i've added the domain sunrisebhc.com to the accepted domains and made it default in the "organization configuration\hub transport\accepted domains.
At this point i expected exchange to create emails addresses  ending with .com during mailbox creating but its creating .local......  
  HELP PLS.
vizoitaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MAS (MVE)EE Solution GuideCommented:
Did you create an email address policy.
if not please create one you will get the new email address
http://exchangeserverpro.com/exchange-server-2010-email-address-policies/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Zacharia KurianAdministrator- Data Center & NetworkCommented:
Follow the link provided by @MAS. Also make sure that  all users have the check box enabled to update the recipient policy.

Zac.
1
Scott CSenior EngineerCommented:
As an aside, you really need to update your Exchange.  Exchange 2010 is currently at SP3 RU11.  Running at just SP1 you are 5 years out of date.
1
vizoitaAuthor Commented:
MAS, you nailed it.  Just edited the email policy from .local to .com and its happy now. Thank you very much
0
MAS (MVE)EE Solution GuideCommented:
Glad to know it helped and  fixed
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.