Exchange 2010 and custom transport rule

I am trying to create a transport rule that will reject the message with enhanced status code I created. Exchange doesn't seem to recognize the rule at all. I want to send a reply to anyone that sends an email to 1 of our old email domains that will no longer be available.

Rule
Apply rule to messages
from users that are "outside the organisation"  and when a recipients address matches "@olddomain.com"
send "Diags for email admins" to sender with '5.7.999"
I send test emails to myself with the old domain address, I get the emails but my google and yahoo accounts don't get an ndr
LVL 6
Smith and AndersenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
Check Auto replies option is enabled at Org Level.

Check this
http://www.howto-outlook.com/howto/automaticreply.htm
0
Smith and AndersenAuthor Commented:
Hi Amit
I do have them all checked except for use message text line wrap at column
0
AmitIT ArchitectCommented:
Do you have any mailboxes or contacts for "@olddomain.com
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Smith and AndersenAuthor Commented:
Yes. My mailbox has an alias with the old domain address
0
AmitIT ArchitectCommented:
Test this, disable the rule and send email to that address and what is the result.
0
Smith and AndersenAuthor Commented:
Hi Amit
I disabled the rule and sent an email from my gmail account and I got the email
0
AmitIT ArchitectCommented:
Can you try this. Create a contact for that address and remove that address from mailbox. Then enable the rule and test again. Let me know the result. I did something similar long back, however I used mail marshal.
0
Smith and AndersenAuthor Commented:
Hi Amit
I figured out the issue
As soon as I made olddomain my primary address it worked
Can this be done for alias's??
0
AmitIT ArchitectCommented:
Good ...However, I haven't tired with Alias.
0
Will SzymkowskiSenior Solution ArchitectCommented:
Alias are not identified by rules in the Exchange environment. It will always use the Primary SMTP address which is why your test only worked when it was the Primary SMTP.

Will.
0
AmitIT ArchitectCommented:
I guess Will answers your question above. I suggest, creating contacts for old domain address and then set the rule.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.